Window management - Grid: Windows should not show the semi-maximise preview when the minimum width of the window is greater than the semi-maximise width

Reported by John Lea on 2011-02-23
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Compiz
High
Unassigned
Unity
High
Sam Spilsbury
compiz (Ubuntu)
High
Sam Spilsbury
unity (Ubuntu)
High
Sam Spilsbury

Bug Description

compiz 1:0.9.7.4-0ubuntu1, unity 5.8.0-0ubuntu2, Ubuntu Pangolin

Description:
- When a user tries to semi-maximise a window with a minimum horizontal size e.g. the Empathy 'Messaging and VoIP Accounts' window , a semi-maximise gesture preview is displayed. However releasing the window will not semi-maximise the window because the window's minimum size is less than with width of the semi-maximise.

To reproduce:
0. If necessary, switch to a display width that is less than double the minimum width of a window you have handy. For example, 1280 pixels and Ubuntu Software Center, which has a minimum width of 730 pixels.
1. Drag all the way to the right edge of the screen.
2. Release the drag.
3. Drag all the way to the left edge of the screen.
4. Release the drag.

What happens:
1. The semi-maximize preview overlay appears.
2. The window is placed as if it takes up half the screen, but is resized only to its minimum width, so its right side falls off the edge of the screen.
3. The semi-maximize preview overlay appears.
4. The window is semi-maximized at *less than* its specified minimum width.

What should happen:
1. Normal window movement continues, with no semi-maximize preview.
2. The window is moved, but not semi-maximized, because it's too wide.
3. Normal window movement continues, with no semi-maximize preview.
4. The window is moved, but not semi-maximized, because it's too wide.

[Updated from the original description, where the preview would appear but the semi-maximizing wouldn't happen.]

John Lea (johnlea) on 2011-02-23
Changed in ayatana-design:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → John Lea (johnlea)
tags: added: udt
David Barth (dbarth) wrote :

The feature itself (semi-maximizing) is working. However, there are applications, as you describe, which will refuse to honor the window manager's resizing command.

This bug should be splitted into per-application bugs to figure out how to fix the applications individually.

David Barth (dbarth) wrote :

Actually, since application windows have to define a mininum size, the compiz plugin could check the app. windows requirement before displaying the semi-maximize outline / hint.

Changed in compiz (Ubuntu):
importance: Undecided → Low
status: New → Triaged
David Barth (dbarth) wrote :

A nice to have fix for the release, but not critical to ship.

John Lea (johnlea) on 2011-03-09
Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-04-19
Changed in ayatana-design:
importance: High → Medium
tags: added: udo
Jason Smith (jassmith) on 2011-05-05
Changed in compiz (Ubuntu):
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
milestone: none → oneiric-alpha-1
Changed in unity:
status: New → Triaged
importance: Undecided → Low
milestone: none → alpha1
John Lea (johnlea) on 2011-05-06
Changed in ayatana-design:
importance: Medium → High
Didier Roche (didrocks) on 2011-05-30
Changed in unity (Ubuntu):
status: New → Triaged
Changed in compiz (Ubuntu):
milestone: oneiric-alpha-1 → oneiric-alpha-2
Didier Roche (didrocks) on 2011-06-22
Changed in unity:
milestone: 4.0.1 → 4.2.0
Didier Roche (didrocks) on 2011-07-05
Changed in unity:
milestone: 4.2.0 → 4.4.0
Martin Pitt (pitti) on 2011-07-07
Changed in compiz (Ubuntu):
milestone: oneiric-alpha-2 → oneiric-alpha-3
Didier Roche (didrocks) on 2011-07-21
Changed in unity:
milestone: 4.4.0 → 4.6.0
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0
Omer Akram (om26er) on 2011-09-24
Changed in compiz (Ubuntu):
milestone: oneiric-alpha-3 → none
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: 4.8.0 → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
description: updated
summary: - Windows with should not show the semi-maximise gesture preview when
- their minimum width is greater than the semi-maximise width
+ Compiz still tries to semi-maximize windows when their minimum width is
+ too large
John Lea (johnlea) on 2012-04-25
summary: - Compiz still tries to semi-maximize windows when their minimum width is
- too large
+ Window management - Windows should not show the semi-maximise preview
+ when the minimum width of the window is greater than the semi-maximise
+ width
description: updated
John Lea (johnlea) on 2012-10-12
Changed in compiz:
status: New → Triaged
importance: Undecided → High
Changed in unity:
importance: Low → High
Changed in compiz (Ubuntu):
importance: Low → High
Changed in unity (Ubuntu):
importance: Low → High
MC Return (mc-return) on 2013-06-19
Changed in compiz:
milestone: none → 0.9.10.0
MC Return (mc-return) on 2013-06-23
summary: - Window management - Windows should not show the semi-maximise preview
- when the minimum width of the window is greater than the semi-maximise
- width
+ Window management - Grid: Windows should not show the semi-maximise
+ preview when the minimum width of the window is greater than the semi-
+ maximise width
Sami Jaktholm (sjakthol) on 2013-07-14
tags: added: grid
Changed in compiz:
milestone: 0.9.10.0 → 0.9.10.2
MC Return (mc-return) on 2013-07-24
Changed in compiz:
milestone: 0.9.10.2 → 0.9.11.0
John Lea (johnlea) on 2013-09-20
Changed in ayatana-design:
importance: High → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints