Window management - Invisible border does not extend to the top of the window

Reported by Remco on 2011-02-11
70
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Compiz
High
Andrea Azzarone
Compiz Core
High
Sam Spilsbury
compiz (Ubuntu)
High
Andrea Azzarone

Bug Description

Resizing windows is very easy from the left, bottom and right sides of windows, because of the invisible border. But the top side of a window does not have such a border, making it difficult to resize from there.

Desired Resolution:
- Add invisible resize area to the top border of windows. This invisible area should be the same width as the invisible resize areas on the left, right and bottom borders of the window.

Related branches

lp:~andyrock/compiz/invisible-borders-titlebar
Merged into lp:compiz/0.9.10 at revision 3735
PS Jenkins bot: Approve (continuous-integration) on 2013-06-05
Christopher Townsend: Approve on 2013-06-04
Sam Spilsbury: Approve on 2013-06-04
Remco (remco47) wrote :
description: updated
David Callé (davidc3) on 2011-02-14
Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) on 2011-02-21
Changed in unity (Ubuntu):
status: New → Confirmed
John Lea (johnlea) on 2011-09-22
tags: added: onew udo
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Fix Committed
description: updated
Omer Akram (om26er) on 2011-09-24
Changed in compiz-core:
status: New → Confirmed
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
John Lea (johnlea) on 2011-09-28
Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
Omer Akram (om26er) on 2012-01-27
Changed in compiz-core:
status: Confirmed → Triaged
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in compiz-core:
importance: Undecided → Low
Daniel van Vugt (vanvugt) wrote :

I suspect this was an intentional decision to work around other invisible border bugs. However it's likely those bugs are now all fixed. I don't think there is a reason to not have a top invisible border any more...

John Lea (johnlea) on 2012-02-03
summary: - Invisible border does not extend to the top of the window
+ Window management - Invisible border does not extend to the top of the
+ window
no longer affects: compiz-core
affects: unity → compiz-core
Changed in compiz-core:
milestone: backlog → none
affects: unity (Ubuntu) → compiz (Ubuntu)
Changed in compiz-core:
milestone: none → 0.9.7.2
Changed in compiz-core:
milestone: 0.9.7.2 → 0.9.7.4
Changed in compiz-core:
milestone: 0.9.7.4 → none
Changed in compiz-core:
milestone: none → 0.9.7.6
Changed in compiz-core:
milestone: 0.9.7.6 → 0.9.7.8
Changed in compiz-core:
milestone: 0.9.7.8 → 0.9.8.0
Changed in compiz:
assignee: nobody → Sam Spilsbury (smspillaz)
importance: Undecided → Low
status: New → Triaged
Changed in compiz:
milestone: none → 0.9.8.0
Changed in compiz-core:
milestone: 0.9.8.0 → none
Changed in compiz:
milestone: 0.9.8.0 → 0.9.8.1
Changed in compiz:
milestone: 0.9.8.2 → 0.9.8.4
Changed in compiz:
milestone: 0.9.8.4 → 0.9.9.0
John Lea (johnlea) on 2012-10-15
Changed in compiz:
importance: Low → Medium
Changed in compiz-core:
importance: Low → Medium
Changed in compiz (Ubuntu):
importance: Low → Medium
Changed in compiz:
milestone: 0.9.9.0 → 0.9.9.2
John Lea (johnlea) on 2013-01-31
Changed in ayatana-design:
importance: Medium → High
Changed in compiz-core:
importance: Medium → High
Changed in compiz:
importance: Medium → High
Changed in compiz (Ubuntu):
importance: Medium → High
Chris Wilson (notgary) on 2013-02-22
Changed in hundredpapercuts:
status: New → Triaged
importance: Undecided → High
milestone: none → raring-compiz
assignee: nobody → Paper Cuts Ninja (papercuts-ninja)
Changed in compiz:
milestone: 0.9.9.2 → 0.9.10.0
Changed in compiz:
assignee: Sam Spilsbury (smspillaz) → Andrea Azzarone (andyrock)
Changed in compiz (Ubuntu):
assignee: Sam Spilsbury (smspillaz) → Andrea Azzarone (andyrock)
Changed in compiz:
status: Triaged → In Progress
Changed in compiz (Ubuntu):
status: Triaged → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz at revision 3735, scheduled for release in compiz, milestone 0.9.10.0

Changed in compiz:
status: In Progress → Fix Committed
Changed in compiz (Ubuntu):
status: In Progress → Fix Committed
Stephen M. Webb (bregma) on 2013-07-23
Changed in compiz:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (70.8 KiB)

This bug was fixed in the package compiz - 1:0.9.10+13.10.20130822-0ubuntu1

---------------
compiz (1:0.9.10+13.10.20130822-0ubuntu1) saucy; urgency=low

  [ Sam Spilsbury ]
  * Bump version to 0.9.10

  [ Łukasz 'sil2100' Zemczak ]
  * Remove debian/patches/unity_support_test.patch:
    - Running the support test from compiz has bad side effects, from now
      on we run it from Xsession.d
  * Automatic snapshot from revision 3644

  [ Iven Hsu ]
  * Opacify: Only dim the windows above the active window.(LP:
    #1189374). (LP: #1189374)
  * KWD: Fix compile errors with KDE 4.11. The KWin developers made
    kdecorationbridge.h private. See:
    http://lists.freedesktop.org/archives/compiz/2013-March/003479.html
    (LP: #1193792). (LP: #1193792)

  [ Nikolay Martynov ]
  * When static switcher is enabled and has an option to show
    application icon turned on the icons are expected to be ~1/3 of a
    thumbnail (48px). Instead they are displayed in 512px size and
    completely cover everything. This change addresses this issue. See
    LP #1173914. (LP: #1173914, #1186426)

  [ BryanFRitt ]
  * Fixed the non-working Annotate 'Clear' Button. Moved this option's
    CCSM position upwards to keep the button shortcuts together. (LP:
    #1202907). (LP: #1202907)

  [ Mehrdad Afshari ]
  * Added "move window to previous monitor" feature to compiz Put
    plugin. (LP: #1178581)

  [ Hu Kang ]
  * gtk-window-decorator: destroy action menu when any of the (close,
    min, max) buttons on the title bar is pressed. (LP: #1101648)
  * Remove redundant src/logmessage/include/core/logmessage.h (LP:
    #1067246). (LP: #1067246)

  [ Steve Langasek ]
  * Fix for bug #763148 (with added test cases): when the desktop is
    resized, windows should stay on their original workspace. (LP:
    #763148)

  [ Brandon Schaefer ]
  * Unrevert 3728, fix failing tests. Change the behaviour of
    undecorating windows. Previously when a window was undecorated, we
    would shift it back to an appropriate position according to its
    gravity member. That behaviour was problematic because in the
    StaticGravity case the window has to just stay in the same place.
    But then if you had a window with StaticGravity which then did get a
    decoration and later removed it, it would be placed as though it was
    decorated and appear to be in the wrong place. The correct behaviour
    is to place all windows as though they have decorations, and then
    when decorations are removed, to move the window back to the corner
    as indicated in its gravity and then expand its size to cover the
    obscured regions no longer hidden because the decorations went away.
    (LP: #1165343).   1. Completely remove decorOffsetMove and other
    related code from      decor.cpp. Put the logic to handle the
    window->input () - window->border ()      placement offset inside of
    setWindowFrameExtents instead. Now the window      will always be
    offset from its original non-decorated position to the new
         decorated position, rather than having to guess between
    decoration sizes.   2. Make saveGeometry and restoreGeometry work
    relative to window->border ()      a...

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
no longer affects: hundredpapercuts
no longer affects: hundredpapercuts/precise
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.