mintMenu and MATE Menu are elevated/offset by compiz

Bug #1419346 reported by jacob on 2015-02-07
78
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
Ubuntu MATE
Low
Martin Wimpress

Bug Description

When I try to open the mint menu, it's elevated from the bottom mate panel somewhat. It should be seamless against the panel without any space. If you type text in the search box, it will reset to its proper position. If you click the menu after doing this, it will also appear to be normal. If you click it any more, it will go back to having a gap. I've attached an image showing this. This from what I've tested only seems to affect this plugin, and not the regular mate menu.

Current setup:

* OS: Arch linux
* Desktop Environment: Mate
* Window Manager: Compiz 0.9.12.1
* Window Decorator: Emerald 0.9
* Graphics card: GTX 760
* Driver: NVidia proprietary

jacob (cellsheet) wrote :
description: updated
description: updated
Rob McCathie (korrode) wrote :

Xfce has a similar situation.
Xfce's normal menu is fine, but the quite popular Whisker Menu for Xfce elevates like you describe.

Currently in Manjaro one of our changes to Compiz defaults is to set Fixed Window Placement position for Whisker Menu windows.:
https://github.com/manjaro/packages-community/blob/master/compiz-manjaro/compiz-manjaro-defaults.patch#L170

The settings as shown fixes it no matter the position of the Xfce panel.

Also the calendar display pop-up when clicking the clock in current development version of xfce4-panel also has a gap. (I haven't gotten around to adding that to our defaults yet.)

The solution was originally found by one of our users and reported to me here:
https://forum.manjaro.org/index.php?topic=12618.msg172013#msg172013

Rob McCathie (korrode) wrote :

Sorry i forgot to mention: The issue doesn't occur at all (and doesn't require out above workaround) when the Xfce4-panel with the Whisker Menu button is at the top of the screen, it only occurs when it's at the bottom.

jacob (cellsheet) wrote :

Ah thank you, though is this patch available for compiz on non-manjaro systems (i.e. vanilla arch)?

Rob McCathie (korrode) wrote :

Well, the compiz-manjaro package, which the patch i linked above is from, is fully compatible with Arch and is available on AUR:
https://aur.archlinux.org/packages/compiz-manjaro/

However, compiz-manjaro's patch is only addressing the problem for Xfce's Whisker Menu, it won't help Mintmenu, but you can easily fix it for yourself without needing any patching, the patch above only changes defaults (i.e. changes settings you can get to CCSM anyway).

Attached is what gets set, you can adapt it for Mintmenu.

Charles Bos (charlesbos1) wrote :

It seems to be a general problem with bottom placed panels. Out of interest, I tried running Compiz alongside KDE Plasma 5 and I noticed that the launcher menu there was also offset. I've added a very brief section about this to the Arch Wiki.

Vlad Orlov (monsta) wrote :

Same issue in Ubuntu MATE 15.04 with mate-menu (mintMenu fork) at the bottom panel. Same workaround - disable Place Windows plugin to get rid of the issue.

Unfortunately, the suggested fix for Whisker Menu didn't work for mate-menu. It even made things worse: now in 2/3 cases it's elevated as before, and in the rest 1/3 cases it's shown stickied to the upper left corner of the screen. O_o

Vlad Orlov (monsta) wrote :

Forgot to add that it's also been reported about mintMenu in Mint 17.1.

https://github.com/linuxmint/mintmenu/issues/121
http://forums.linuxmint.com/viewtopic.php?f=206&t=183895

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Vlad Orlov (monsta) on 2015-03-26
summary: - mint menu is elevated/offset by compiz
+ mintMenu is elevated/offset by compiz
Changed in linuxmint:
status: New → Confirmed
Changed in ubuntu-mate:
status: New → Confirmed

Disabling Place Windows doesn't work for the Xfce datetime plugin though. I think this is a general problem with the way Compiz handles bottom panel popout windows.

Out of interest Monsta, does the Whisker Menu fix work for mintmenu if the x and y positions are the lowest possible (-32768, -32768 on my machine) instead of -1, -1 ?

Vlad Orlov (monsta) wrote :

Unfortunately, no. The result is the same as with [-1, -1] - as I described above.

What's interesting is that MATE's Clock Applet isn't affected by this issue.
When you click on it, it always shows the calendar window where it should be - close to the panel.

Vlad Orlov (monsta) on 2015-03-27
tags: added: trusty utopic vivid xfce
Changed in compiz (Ubuntu):
importance: Undecided → Low
Changed in ubuntu-mate:
importance: Undecided → Low
summary: - mintMenu is elevated/offset by compiz
+ mintMenu and MATE Menu are elevated/offset by compiz
Yanpas (yanpaso) wrote :

Very cool workaround - tick "do not reserve space on egdes"

Yanpas (yanpaso) wrote :

And to place new windows right upper the panel - add small transparent panel

Yanpas (yanpaso) wrote :

Bad suggestion. Windows place beside the panel . Is there posibility in compiz to add screen margins?

Charles Bos (charlesbos1) wrote :

Very cool workaround - tick "do not reserve space on egdes"

@Yanpas where is that option?

Yanpas (yanpaso) wrote :

In xfce panel settings. I don't know how is it exactly written in English

Charles Bos (charlesbos1) wrote :

Ah yes I see it. That does indeed work but has the disadvantage of allow windows underneath the panel - hence your suggestion of the small transparent panel.

Yanpas (yanpaso) wrote :

New solution: "title=Whisker Menu" exclusion in compiz settings. It didn't worked for the 1st time, when I edited /usr/share/compiz/place.xml it began to work. Attaching my new file. I found those lines from compiz-manjaro.

Solution for date and time plugin: "title=wrapper-1.0". X and Y you should set yourself depending on your screen.

Running windows command: sleep2;wmctrl -l
xprop -name <NAME>

The attachment "only for xfce" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
tags: added: ubuntu-mate
removed: mate patch
Charles Bos (charlesbos1) wrote :

"Solution for date and time plugin: "title=wrapper-1.0". X and Y you should set yourself depending on your screen."

Yes, this works for me. Thanks. In my case, my screen is 1377x768 so I set a position of (1100, 586) which forces the calendar into the right place.

Charles Bos (charlesbos1) wrote :

Ok I think I understand the problem. It seems to be to do with Window decoration. In Emerald you have the ability to adjust the height of the titlebar. I noticed that the taller you made titlebar, the higher the Whisker Menu and the datetime calender were elevated. Likewise, making the titlebar less tall reduced the elevation. Disabling the window decoration plugin completely eliminated the elevation.

My conclusion is that Compiz needs to be told that windows of type panel cannot be decorated under any circumstances.

Charles Bos (charlesbos1) wrote :

Tried excluding all windows from window decoration but it didn't fix the problem. Only disabling the decor plugin or killing the running decorator, be it gtk-window-decorator or emerald, 'fixed' the problem. But definitely something to do with the decor plugin.

mypa (mykolaspanavas) wrote :

Same problem here :) Ubuntu Mate 15.04 + Compiz

Mark Unger (mrk-unger) wrote :

Yea, i have the same issue with Ubuntu Mate 15.10 + Compiz

Vlad Orlov (monsta) on 2015-12-03
tags: added: wily
da2 (hiboudev) wrote :

Hi,

A temporary fix for the mintMenu without to disable all Placement plugin : https://github.com/linuxmint/mintmenu/issues/121#issuecomment-170406477

David Black (db4tech) wrote :

Just found I've reported the same issue, but also include a fix.
Here's the link.
https://bugs.launchpad.net/ubuntu-mate/+bug/1559371

Thank you,
David

Changed in compiz (Ubuntu):
status: Confirmed → Invalid
Changed in compiz:
status: New → Invalid
Changed in ubuntu-mate:
assignee: nobody → Martin Wimpress (flexiondotorg)
status: Confirmed → In Progress

Thank you for taking the time to provide a fix for this issue. I've tested the change you proposed and prepared a merge proposal which you can find here:

  * https://code.launchpad.net/~ubuntu-mate-dev/compiz/fix-1559371/+merge/289588

Changed in ubuntu-mate:
status: In Progress → Fix Committed

Fix/Workaround in Linux Mint 17.3 MATE (confirmed partially)

a) Add above Windows Rules settings local -- the plugin must be enabled to take affect:
$ dconf write /org/compiz/profiles/mint/plugins/winrules/size-matches "['class=MintMenu.py', 'class=MateMenu.py']"
$ dconf write /org/compiz/profiles/mint/plugins/winrules/size-height-values "[0, 0]"
$ dconf write /org/compiz/profiles/mint/plugins/winrules/size-width-values "[0, 0]"

b) Fails: Alternatively changing the system-wide settings like above for Ubuntu MATE -- but in /etc/compizconfig/mint.ini -- did not work in my case.

Thanks to David Black and Martin Wimpress.

Full confirmation for the fix in LM 17.3 MATE inluding case b) from above. Further, all second values where for testing only and not for real application (should have been called 'class=foo.py'). Thanks.

Changed in ubuntu-mate:
status: Fix Committed → Fix Released
Vlad Orlov (monsta) wrote :

Seems to be working here.

org.compiz.profiles.mate.plugins.winrules size-matches ['class=MintMenu.py']
org.compiz.profiles.mate.plugins.winrules size-height-values [0]
org.compiz.profiles.mate.plugins.winrules size-width-values [0]

Vlad Orlov (monsta) wrote :

Forgot to say - in Mint 17.3.

Vlad Orlov (monsta) on 2017-11-15
no longer affects: compiz (Ubuntu)
no longer affects: linuxmint
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers