skydome fails in compiz rotate cube

Bug #1330080 reported by Christopher Barrington-Leigh on 2014-06-14
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

A setup which worked in 13.04 fails in 14.04: Straightforward use of a skydome image in the rotating cube of compiz.
Rather than show a background image, there is no just screen corruption when rotating the cube.
 Not sure why I bothered checking -- but I did, and this is a regression.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: compiz 1:0.9.11+14.04.20140423-0ubuntu1
Uname: Linux 3.14.0-031400-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Sat Jun 14 11:12:50 2014
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.3.10, 3.13.0-29-generic, x86_64: installed
 virtualbox, 4.3.10, 3.14.0-031400-generic, x86_64: installed
EcryptfsInUse: Yes
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:2203]
InstallationDate: Installed on 2014-03-11 (95 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140218)
MachineType: LENOVO 34372VU
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.14.0-031400-generic root=UUID=63d5fa0d-9ba0-4641-bdfa-c45adfb938b5 ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/05/2013
dmi.bios.vendor: LENOVO
dmi.bios.version: GCET97WW (2.57 )
dmi.board.asset.tag: Not Available
dmi.board.name: 34372VU
dmi.board.vendor: LENOVO
dmi.board.version: Not Defined
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrGCET97WW(2.57):bd12/05/2013:svnLENOVO:pn34372VU:pvrThinkPadX230Tablet:rvnLENOVO:rn34372VU:rvrNotDefined:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 34372VU
dmi.product.version: ThinkPad X230 Tablet
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.11+14.04.20140423-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.3-0ubuntu0.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.3-0ubuntu0.1
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3.1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Thu Jun 12 07:42:16 2014
xserver.configfile: default
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 728
 vendor LGD
xserver.version: 2:1.15.1-0ubuntu2

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
peddanet (peter-wein) wrote :

For me that worked:
dconf reset -f /org/compiz/

which resets compiz settings (maybe they were messed up during distro update vom 12.04). So it is probably not a bug...

coombesy (webeire) wrote :

yes running
dconf reset -f /org/compiz/

does stop the cube rendering issue. But as soon as I enable the skydome the issue comes back, even if I disable it the issue stay's until I reset compiz using above command. Tested this issue with png and jpeg skydome images. Pity, skydome including cube were my favourite compiz plugins. I'm using same graphics card as initial report `Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)`

Theodoros Gatsios (theogat-27) wrote :

I have the same issue with the skydome feature. I have tried almost everything, but the problem is still here.

BB M (coolshop007) wrote :

I have the same problem. After placing a jpeg picture in the background. The cube is not function properly. And also the background picture is too small. Did not fit into a full screen.

To post a comment you must log in.