Huge memory leaks in compiz after upgrade to 14.04

Bug #1315261 reported by Vidnel on 2014-05-02
164
This bug affects 36 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned

Bug Description

Since my upgrade to 14.04 from 13.10, the memory usage for compiz has been abysmal.

This is on three different laptops, two with intel i915 graphics and one with the latest nvidia driver. All suffer intolerable memory usage from various core components, compiz being the biggest aggressor.

In 13.10, compiz sat at an extremely comfortable 50 or so MB. for it to grow more than eight times as the norm is ridiculous.

Vidnel (vidnel) wrote :
summary: - Huge memory leaks in compiz
+ Huge memory leaks in compiz after upgrade to 14.04
description: updated
Wayne Stark (wastark-gmail) wrote :

I am having the same issue.
After login Compiz eats 60-70mb memory.
Once the dash is opened it jumps to 150-200mb.
If I open music in the dash it could go upto 500mb.
If I don't open the dash at all, compiz usually stays the right side of 100mb.

Bruno Nova (brunonova) wrote :

I'm also seeing high memory usage from compiz in my laptop (306 MiB right now according to Conky, 3h 15m uptime).
I noticed this problem in 13.10 too, but it seems to be worse now.

Daniel Loureiro (loureirorg) wrote :

same to me. Every 2 or 3 hours I need to reboot my PC, because Ubuntu begins to use virtual memory (and became unusable) even with all apps closed. One thing that helps me was remove the "indicator-multiload" tool from my system - this app must have some serious leak problem or should access compiz functions that have leak problems.

Someone else with this same problem is using this app (indicator-multiload)?

thunderamur (thunderamur) wrote :

After 22 days uptime compiz use more than 2.7 GB.

thunderamur (thunderamur) wrote :

And I make new install after release 14.04.

Viktor Suprun (popsul1993) wrote :

After 1 day uptime compiz use more than 2.8 GB. WTF, guys? And stange process `init --use` use more than 500 MB.

The highhat (thehighhat-q) wrote :

Confirming broken memory usage in Unity on14.04 x86_64.. After 12 hours following initial login, periodically locking screen, and using desktop, memory usage is 2.762 GB.

Changed in compiz:
status: New → Confirmed
Rajat Pandita (rajat-pandita) wrote :

I am also facing the same problem. After around 30 minutes of Useage Compiz is eating more than 150 MB. After a day it goes to 400MB. not sure what is gonig on. If I manually kill the compiz process. it fixes the issue till it again starts to hog memory. Killing compiz is the only workaround that I can think of.
I am on Ubuntu 14.10 64 Bit. using FGLRX Driver, However the issue has been like this even with the OpenSource radeon drivers as well.
Please fix this.

Rajat Pandita (rajat-pandita) wrote :

I have since my last reply got rid of 14.10 in favour of 14.04.2

I have a new Lenovo Z-50 Laptop now with NVIDIA 820M GPU. Intel Ci5 4th GEN CPU with Haswell Graphics. I am using Bumblebee s I am using my Intel Graphics all the time except when I am not gaming.

I have been monitoring the RAM useage by Compiz. It never goe above 65 MB. I tried reproducing the Issue by searching the Dash for a lot of different applications and launch them one by one. Earlier this used to cause Compiz to quickly chew RAM and grow up to 300MB in RAM utilization.

However this time around, it is not the case. Compiz seems to be behaving all the time now. Not sure if it is because I was using a dedicated AMD GPU and the FGLRX driver.
This time am using NVIDIA 346 Driver from Xorg-Edgers ppa.

I have been running 14.04.2 for 2 days and since last 8 hours or so, My System has not rebooted at all.

Hope this helps !

LH (lh89) wrote :

How is this not a critical bug?

I just finished testing on a fresh 15.04 install on a machine that has two high res displays (3840 x 2160 each). I suspect the problem may be exacerbated by the high res displays.

Compiz starts out with under 100 MB of RAM, then steadily grows (to over 2 GB of RAM) until X eventually completely crashes and you lose all of your state. This happens several times per day on the aforementioned fresh 15.04 install.

Is anyone working on this?

LH (lh89) wrote :

meant to provide the details for the above test:

  Graphics Card: Quadro K1100M/PCIe/SSE2
  Processor: Intel i7-4712HQ

I've tried it with multiple video drivers:

  NVIDIA binary driver nvidia-346 (version 346.59)
  NVIDIA binary driver nvidia-346-updates (version 346.59)
  Noveau driverfrom xserver.org

The distro is 64 bit Ubuntu 15.04

Will Cooke (willcooke) on 2015-08-12
tags: added: rls-w-incoming
tags: added: rls-x-incoming
removed: rls-w-incoming

Is there any update on this?
I can reproduce the issue with 64 bit running 15.04 with kernel 3.19.0-37 and as a CPU Intel Core2 Quad CPU Q8300 @ 2.50GHz.
Compiz starts with using fairly little ram but after a certain uptime it keeps on consuming more and more ram. (currently 10.6% and increasing after an uptime of 2 days). The video card is an on-board intel graphics 4 series controller (computer is dell optiplex 760). The driver is the i915.

eraserix (eraserix) wrote :

I did not upgrade the system but a clean install of 14.04. I ran some lxc start/stop tests during the night, and now compiz uses 6.38GB of memory (basically just start and stop two ubuntu precise containers all the time).

I use a self compiled 4.1.13 kernel and the i915 driver.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments