Regression: rev 3847 No focus on Desktop possible if a window is open

Bug #1303068 reported by Doug McMahon on 2014-04-05
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Compiz
High
Christopher Townsend
compiz (Ubuntu)
High
Christopher Townsend

Bug Description

Test case:
open an unmaxed window, try to return focus to Desktop
Affects: the ability to rename files on the Desktop

Related branches

Changed in compiz:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Christopher Townsend (townsend)
milestone: none → 0.9.11.0
Changed in compiz (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Christopher Townsend (townsend)
Changed in compiz:
status: Confirmed → In Progress
Changed in compiz (Ubuntu):
status: Confirmed → In Progress
Doug McMahon (mc3man) wrote :

The proposed commit seems to be working here ok, name/rename is ok & Dash again can be dismissed by clicking on Desktop

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.11+14.04.20140408-0ubuntu1

---------------
compiz (1:0.9.11+14.04.20140408-0ubuntu1) trusty; urgency=low

  [ Chris Townsend ]
  * Fix issue where Grid animation can sometimes show a preview of a
    different window than the one being gridded. (LP: #1176898)
  * Fix recent regression where the desktop window would not get focus
    when clicking the desktop. (LP: #1303068)
 -- Ubuntu daily release <email address hidden> Tue, 08 Apr 2014 13:48:38 +0000

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Changed in compiz:
status: In Progress → Fix Committed
razor7 (ghiamar) wrote :

I Confirm it's working fine!

Thanks a lot!

Stephen M. Webb (bregma) on 2014-11-06
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers