Regression r3751: Restarting Compiz changes size and position of windows

Bug #1217286 reported by MC Return on 2013-08-27
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Compiz
Medium
Marco Trevisan (Treviño)
GNOME Terminal
New
Undecided
Unassigned

Bug Description

[How to reproduce]

1. Open some windows
2. Restart Compiz

[What you would expect to happen]

The windows should all have the same size and position as before.

[What actually happens]

The windows all shift by the size of their decoration to the bottomright and their size grows by the size of the decoration also. :(

Note:
All these regressions are unnecessary complications.
It does not help to add a ton of tests all showing that the new code does what it should, because it does not do that in the real world.
Instead it would be better to leave out those tests and invest the time in manual testing instead, preventing such regressions from hitting the source in the first place...
Just my 2 cents.

Related branches

MC Return (mc-return) on 2013-08-27
Changed in compiz:
milestone: none → 0.9.11.0
importance: Undecided → High
Eleni Maria Stea (hikiko) wrote :

Here's what happens in my case:
http://imgur.com/a/8IVZS

Also I get this warning:
compiz (decor) - Warn: No default decoration found, placement will not be correct

I'll get a look at this bug!

Changed in compiz:
assignee: nobody → Eleni Maria Stea (hikiko)
Eleni Maria Stea (hikiko) wrote :

I tried to reproduce it several times but the only windows where I see size and placement changes are the gnome-terminal windows. Is it possible that this is just a gnome terminal bug? Could you attach a screenshot of the problem?

Changed in compiz:
assignee: Eleni Maria Stea (hikiko) → nobody
MC Return (mc-return) wrote :

It happens with every window and is a rather complicated, pre-raring release Compiz regression - no easy fix here.

gnome-terminal has nothing to do with this bug.

Eleni Maria Stea (hikiko) wrote :

I wrote a test xlib program that creates/destroys and maps/unmaps windows to debug another compiz bug and I got the behavior you describe each time I destroyed or unmapped a window! but I still can't get it in every window on my desktop when I restart compiz. Anyway, I am still investigating if the map/unmap create/destroy issues could be related to this bug too.

Eleni Maria Stea (hikiko) wrote :

It seems that the problem is that we have the decorations and the contents in 1 window :/

User Unknown (user-unknown) wrote :

This bug affects me as well, with XFCE4.10 as the DE on Ubuntu 13.10. Didn't Try with another DE, though.

Also, related, and where I initially noticed this issue: Whenever a window gets minimized to tray/iconified and then restored from tray, the size of the window will shrink by the size of its decoration and title bar. For me this is even way more annoying than the opposite case explained in this bug report, as I way more frequently minimize-to-tray windows such as messengers or mail clients and calendars than I need to restart compiz..

I just found bug #1287472 that apparently explains my initial issue, and its resolution would likely also fix this issue.

Changed in compiz:
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in compiz:
importance: High → Medium
Stephen M. Webb (bregma) on 2014-03-11
Changed in compiz:
status: In Progress → Fix Committed
Stephen M. Webb (bregma) on 2014-11-06
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers