Grid: Snap animation uses wrong window

Bug #1176898 reported by PBS on 2013-05-06
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Compiz
Low
PBS
compiz (Ubuntu)
Low
PBS

Bug Description

This is to do with the grid plugin in raring. When a window is snapped the animation uses the contents and position of the currently focused window, which is not always the same as the window being snapped. Steps to reproduce:

- Open Synaptic (for example), and do Edit>Search to create a random modal window, then snap the main window to an edge.
- The modal window gets animated, even though the main window gets snapped in the end.

OR

- Open something which takes a while to create a window - libreoffice for example.
- While it's opening start dragging another window. When libreoffice has created its window, snap the one being dragged.

OR MOST SIMPLY OF ALL

- Start dragging a window, alt-tab to another window while dragging, the try to snap
  the first window.

Related branches

PBS (pbs3141) wrote :
Sami Jaktholm (sjakthol) on 2013-05-06
Changed in compiz:
status: New → Confirmed
Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in compiz:
status: Confirmed → Triaged
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
Changed in compiz:
importance: Undecided → Medium
Changed in compiz (Ubuntu):
importance: Undecided → Medium
Changed in compiz:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in compiz (Ubuntu):
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in compiz:
importance: Medium → Low
Changed in compiz (Ubuntu):
importance: Medium → Low
Changed in compiz:
milestone: none → 0.9.10.0
PBS (pbs3141) on 2013-05-06
description: updated
MC Return (mc-return) on 2013-07-08
summary: - Snap animation uses wrong window
+ Grid: Snap animation uses wrong window
Sami Jaktholm (sjakthol) on 2013-07-14
tags: added: grid
Changed in compiz:
milestone: 0.9.10.0 → 0.9.10.2
MC Return (mc-return) on 2013-07-24
Changed in compiz:
milestone: 0.9.10.2 → 0.9.11.0
PBS (pbs3141) on 2014-04-05
description: updated
PBS (pbs3141) wrote :

This fixes it for me.

The attachment "compiz-grid-wrong-window.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Christopher Townsend (townsend) wrote :

Hi PBS,

Thanks for the patch! I'm going to review it and if all goes well, I'll make a merge proposal and get this in.

Changed in compiz:
assignee: Brandon Schaefer (brandontschaefer) → PBS (pbs3141)
status: Triaged → In Progress
Changed in compiz (Ubuntu):
status: Triaged → In Progress
assignee: Brandon Schaefer (brandontschaefer) → PBS (pbs3141)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.11+14.04.20140408-0ubuntu1

---------------
compiz (1:0.9.11+14.04.20140408-0ubuntu1) trusty; urgency=low

  [ Chris Townsend ]
  * Fix issue where Grid animation can sometimes show a preview of a
    different window than the one being gridded. (LP: #1176898)
  * Fix recent regression where the desktop window would not get focus
    when clicking the desktop. (LP: #1303068)
 -- Ubuntu daily release <email address hidden> Tue, 08 Apr 2014 13:48:38 +0000

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Changed in compiz:
status: In Progress → Fix Committed
Stephen M. Webb (bregma) on 2014-11-06
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers