[regression-r3635] Guake window appears placed by offset non-existent decoration

Bug #1159324 reported by Sam Spilsbury on 2013-03-24
36
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Compiz
High
Sam Spilsbury
0.9.9
High
Sam Spilsbury
compiz (Ubuntu)
Medium
Unassigned

Bug Description

See MCR1's comment on https://code.launchpad.net/~compiz-team/compiz/compiz.fix_1158161/+merge/154993

==

It now opens about 5 pixels too small on both sides, seems like it would expect a decoration there, but Guake is not decorated.
Also some recent change now makes Guake open too low, like it would expect to be decorated with a title bar...

Screenshot: http://uppix.net/7/1/6/b30f8f2bdd78cd3236b7a7b666966.png

Could ofc be that it is Guake's fault, but this problem never happened before...
Seems like the information that Guake does not use decoration gets lost somewhere now, it is rendered without it, but position and size are calculated for a decorated window...

Yakuake (sudo apt-get install yakuake), another drop-down terminal, shows similar problems.
In the case of Yakuake, setting horizontal size to 100% creates a 1920 pixel wide window, but it is shifted to the right to fit the non-existent decoration and so the right side of Yakuake gets rendered offscreen or on the second display...
The top, which should attach to the panel also shows a hole for the non-existent decoration title-bar.
review: Needs Fixing

Terra, the latest incarnation of drop-down terminal emulators, just opens with reduced horizontal size - Top and left side are placed correctly.
Screenshot: http://uppix.net/5/b/6/e1150112ba71eb5b63507ceba5fd5.png

Related branches

MC Return (mc-return) wrote :

Sam, thanks a lot for the fast response :)
I will test your fix ASAP.

MC Return (mc-return) wrote :

Sam, I've linked the MP here.

MC Return (mc-return) wrote :

Confirming. The linked branch fixes all issues described above.
Tested Guake, Terra and Yakuake. +1

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz at revision None, scheduled for release in compiz, milestone 0.9.9.2

Changed in compiz:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.9~daily13.03.29-0ubuntu1

---------------
compiz (1:0.9.9~daily13.03.29-0ubuntu1) raring; urgency=low

  [ Michael Terry ]
  * [regression-r3635] Guake window appears placed by offset non-
    existent decoration (LP: #1159324)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3641
 -- Ubuntu daily release <email address hidden> Fri, 29 Mar 2013 07:23:54 +0000

Changed in compiz (Ubuntu):
status: New → Fix Released
Changed in compiz:
milestone: 0.9.9.2 → 0.9.10.0
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz at revision None, scheduled for release in compiz, milestone 0.9.10.0

Iain Lane (laney) wrote :

Reopening; this got reverted despite what the bot claims.

Changed in compiz (Ubuntu):
status: Fix Released → Triaged
importance: Undecided → Medium
Changed in compiz:
status: Fix Committed → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.9~daily13.04.18.1~13.04-0ubuntu1

---------------
compiz (1:0.9.9~daily13.04.18.1~13.04-0ubuntu1) raring; urgency=low

  [ Ken VanDine ]
  * Revert 3636 from lp:compiz/0.9.9 to fix Qt apps getting window decorations
    placed behind the panel. (LP: #1165343)
    - This reintroduces bug 1159324, Guake window appears placed by offset
      non-existent decoration
  * [regression-r3635] Guake window appears placed by offset non-
    existent decoration (LP: #1159324)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3650
 -- Ubuntu daily release <email address hidden> Thu, 18 Apr 2013 05:46:57 +0000

Changed in compiz (Ubuntu):
status: Triaged → Fix Released
Adolfo Jayme (fitojb) on 2013-04-18
Changed in compiz (Ubuntu):
status: Fix Released → Confirmed
Changed in compiz:
milestone: 0.9.10.0 → 0.9.10.2
MC Return (mc-return) on 2013-07-24
Changed in compiz:
status: Confirmed → Fix Released
milestone: 0.9.10.2 → none
Launchpad Janitor (janitor) wrote :
Download full text (70.8 KiB)

This bug was fixed in the package compiz - 1:0.9.10+13.10.20130822-0ubuntu1

---------------
compiz (1:0.9.10+13.10.20130822-0ubuntu1) saucy; urgency=low

  [ Sam Spilsbury ]
  * Bump version to 0.9.10

  [ Łukasz 'sil2100' Zemczak ]
  * Remove debian/patches/unity_support_test.patch:
    - Running the support test from compiz has bad side effects, from now
      on we run it from Xsession.d
  * Automatic snapshot from revision 3644

  [ Iven Hsu ]
  * Opacify: Only dim the windows above the active window.(LP:
    #1189374). (LP: #1189374)
  * KWD: Fix compile errors with KDE 4.11. The KWin developers made
    kdecorationbridge.h private. See:
    http://lists.freedesktop.org/archives/compiz/2013-March/003479.html
    (LP: #1193792). (LP: #1193792)

  [ Nikolay Martynov ]
  * When static switcher is enabled and has an option to show
    application icon turned on the icons are expected to be ~1/3 of a
    thumbnail (48px). Instead they are displayed in 512px size and
    completely cover everything. This change addresses this issue. See
    LP #1173914. (LP: #1173914, #1186426)

  [ BryanFRitt ]
  * Fixed the non-working Annotate 'Clear' Button. Moved this option's
    CCSM position upwards to keep the button shortcuts together. (LP:
    #1202907). (LP: #1202907)

  [ Mehrdad Afshari ]
  * Added "move window to previous monitor" feature to compiz Put
    plugin. (LP: #1178581)

  [ Hu Kang ]
  * gtk-window-decorator: destroy action menu when any of the (close,
    min, max) buttons on the title bar is pressed. (LP: #1101648)
  * Remove redundant src/logmessage/include/core/logmessage.h (LP:
    #1067246). (LP: #1067246)

  [ Steve Langasek ]
  * Fix for bug #763148 (with added test cases): when the desktop is
    resized, windows should stay on their original workspace. (LP:
    #763148)

  [ Brandon Schaefer ]
  * Unrevert 3728, fix failing tests. Change the behaviour of
    undecorating windows. Previously when a window was undecorated, we
    would shift it back to an appropriate position according to its
    gravity member. That behaviour was problematic because in the
    StaticGravity case the window has to just stay in the same place.
    But then if you had a window with StaticGravity which then did get a
    decoration and later removed it, it would be placed as though it was
    decorated and appear to be in the wrong place. The correct behaviour
    is to place all windows as though they have decorations, and then
    when decorations are removed, to move the window back to the corner
    as indicated in its gravity and then expand its size to cover the
    obscured regions no longer hidden because the decorations went away.
    (LP: #1165343).   1. Completely remove decorOffsetMove and other
    related code from      decor.cpp. Put the logic to handle the
    window->input () - window->border ()      placement offset inside of
    setWindowFrameExtents instead. Now the window      will always be
    offset from its original non-decorated position to the new
         decorated position, rather than having to guess between
    decoration sizes.   2. Make saveGeometry and restoreGeometry work
    relative to window->border ()      a...

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.