[regression-r3606] Compiz broken with QT menus/floating controls in 13.04

Bug #1141079 reported by bwat47 on 2013-03-03
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Compiz
High
Łukasz Zemczak
0.9.9
High
Łukasz Zemczak
compiz (Ubuntu)
Undecided
Łukasz Zemczak

Bug Description

When using QT apps such as VLC player in ubuntu 13.04 menus and floating controls are all messed up. Whenever I bring up a right click menu in a QT app compiz thinks the menu is another window and it shows up as "untitled window" I saw this in xubuntu 13.04 + compiz as window manager and in a fresh 13.04 unity install.

In addition if you go fullscreen in vlc or smplayer and bring up the floating controls it glitches out and stops letting you bring them up, you also occasionally see flashes of the unity launcher/menu bar when you bring them up. This is a very big regression, and QT video players are basically unusable...

I also get random invisible menus in QT applications

Here is a video showing the untitled window bug and an issue with invisible menus in QT apps (you can see at the end the tools menu is totally invisible, this happens in every single qt app and is easy for me to reproduce): http://www.youtube.com/watch?v=eTOAHeOwdko&feature=youtu.be

I wasn't able to catch the fullscreen controls bug on video for some reason, that one only seemed to happen when I was in unity.

[Most easy way to reproduce]

Start a video with SMPlayer or VLC
Double-click the video to enter Fullscreen
Move the mouse to make player controls appear, note that they fade in as expected
Wait until controls autohide
Move the mouse to access controls again

[What you would expect to happen]

Controls should reappear.

[What actually happens]

Controls do not appear, you have to close and reopen the player to make them work again.

I initially thought this was something wrong with my install or something to do with XFCE, so I tried downloading a fresh ubuntu/unity raring ISO and saw the same issues there.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: compiz 1:0.9.9~daily13.03.01-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-9.18-generic 3.8.1
Uname: Linux 3.8.0-9-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.9-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Sat Mar 2 20:25:13 2013
DistUpgraded: Fresh install
DistroCodename: raring
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: CLEVO/KAPOK Computer Device [1558:0240]
InstallationDate: Installed on 2013-03-02 (0 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130301)
MachineType: System76, Inc. Lemur Ultra
MarkForUpload: True
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-9-generic root=UUID=d820c2f1-95d7-4f16-a47f-1773dc4753a0 ro resume=UUID=dacbaa13-f8b3-421d-94df-3c296640326c quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/25/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 4.6.5
dmi.board.asset.tag: Tag 12345
dmi.board.name: Lemur Ultra
dmi.board.vendor: System76, Inc.
dmi.board.version: lemu4
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr4.6.5:bd06/25/2012:svnSystem76,Inc.:pnLemurUltra:pvrlemu4:rvnSystem76,Inc.:rnLemurUltra:rvrlemu4:cvnNoEnclosure:ct10:cvrN/A:
dmi.product.name: Lemur Ultra
dmi.product.version: lemu4
dmi.sys.vendor: System76, Inc.
version.compiz: compiz 1:0.9.9~daily13.03.01-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.42-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0.2-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.2-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.3-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.6-0ubuntu3
xserver.bootTime: Sat Mar 2 17:30:32 2013
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.2-0ubuntu2
xserver.video_driver: intel

Related branches

bwat47 (bwat47) wrote :
bwat47 (bwat47) on 2013-03-03
description: updated
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
bwat47 (bwat47) on 2013-03-03
description: updated
bwat47 (bwat47) wrote :

According to this comment: http://ubuntuforums.org/showthread.php?t=2121776&p=12539692#post12539692 the regression was introduced in daily13.02.19

Doug McMahon (mc3man) wrote :

r3605 is fine, r3606 shows the poor behavior with context (sub)menus/launcher icon & the in window dropdown menus becoming non-functional, ect.

bwat47 (bwat47) on 2013-03-03
summary: - Compiz broken with QT menus/floating controls in 13.04
+ [regression-r3606] Compiz broken with QT menus/floating controls in
+ 13.04
Michael Terry (mterry) wrote :

Łukasz, I'm going to assign this to you. It may be as simple as reverting that fix. Feel free to reassign if someone else would have better domain knowledge.

Changed in compiz (Ubuntu):
assignee: nobody → Łukasz Zemczak (sil2100)
Łukasz Zemczak (sil2100) wrote :

Thanks for reporting the bug! If you don't mind, I'll try looking into the fix causing the regression a little bit more in the morning. Reverting is one of the options, but as it is a change that has been in trunk for a while now, maybe it would be better to try fixing this regression instead. But I'll know how much work it would be once I will be on it.

Changed in compiz:
assignee: nobody → Łukasz Zemczak (sil2100)
status: New → Incomplete
status: Incomplete → In Progress
Changed in compiz (Ubuntu):
status: Confirmed → In Progress
Łukasz Zemczak (sil2100) wrote :

@bwat47 and all others that are affected:

Could you please test the compiz package I prepared in ppa:sil2100/ppa ?
https://launchpad.net/~sil2100/+archive/ppa
compiz version 1:0.9.9~daily13.03.08.1-0ubuntu1~test1.

Does it fix all the issues you are encountering?

On 03/14/2013 10:57 AM, Łukasz Zemczak wrote:
> @bwat47 and all others that are affected:
>
> Could you please test the compiz package I prepared in ppa:sil2100/ppa ?
> https://launchpad.net/~sil2100/+archive/ppa
> compiz version 1:0.9.9~daily13.03.08.1-0ubuntu1~test1.
>
> Does it fix all the issues you are encountering?
>
Fixes all the issues seen here in vlc

Doug McMahon (mc3man) wrote :

fixes all previous issues with vlc here
(hopefully this comment isn't duped, a previous email reply seems to have gotten 'lost'

bwat47 (bwat47) wrote :

yeah, things seem to work properly now with that package

Łukasz Zemczak (sil2100) wrote :

Thanks for checking! I'll submit a merge request for review then. Not sure if it's a proper 'fix', maybe more of a workaround - but at least it does not require reverting the whole commit that has been applied. Also, it seems to still fix the issues that it was supposed to fix (the code-path seems ok as well). But let's get it reviewed and discussed on the merge proposal.

Doug McMahon (mc3man) wrote :

I see one issue with the test build -
If I max a window then restore can no longer do anything in the window deco area (close,min, restore button) nor grab & move window from there (alt+l.click

Łukasz Zemczak (sil2100) wrote :

Thanks, with Sam's help I think we have found a slightly better way of fixing it, so maybe this regression will not be happening anymore.

Doug McMahon (mc3man) wrote :

Have tried the new diff (1 line removal) locally & from a simple user perspective fixes bug with no apparent/visible regressions
(under the hood above my head...

Doug McMahon (mc3man) wrote :

Just to note - the previous bad behavior in the test ppa concerning Maxed > restored windows is now seen in the current compiz 1:0.9.9~daily13.03.20-0ubuntu1, so it wasn't from the 1st. proposed patch, was something in the source the test ppa used
opened as bug 1158161

Sam Spilsbury (smspillaz) wrote :

@Doug: fixed by https://code.launchpad.net/~compiz-team/compiz/compiz.fix_1158161/+merge/154882

The fix for java awoke some sleepers. Actually DecorWindow::update is such a bloody mess, I wish we could do something about it / get it under test.

Changed in compiz:
importance: Undecided → High
MC Return (mc-return) wrote :

@Sam: Seems like this is not yet fixed. Floating controls in Fullscreen affected media players,
just come up once per videoplayer...

[Most easy way to reproduce]

Start a video with SMPlayer or VLC
Double-click the video to enter Fullscreen
Move the mouse to make player controls appear, note that they fade in as expected
Wait until controls autohide
Move the mouse to access controls again

[What you would expect to happen]

Controls should reappear.

[What actually happens]

Controls do not appear, you have to close and reopen the player to make them work again.

description: updated
MC Return (mc-return) wrote :

Further testing shows that VLC media player just seems to be affected by this bug if it is unredirected, while you can reproduce this bug with SMPlayer or UMPlayer in any case (unredirected or not).

Changed in compiz:
milestone: none → 0.9.10.0
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz at revision None, scheduled for release in compiz, milestone 0.9.10.0

Changed in compiz:
status: In Progress → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz/0.9.9 at revision None, scheduled for release in compiz, milestone 0.9.9.2

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.9~daily13.04.15-0ubuntu1

---------------
compiz (1:0.9.9~daily13.04.15-0ubuntu1) raring; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * [regression-r3606] Compiz broken with QT menus/floating controls in
    13.04 (LP: #1141079)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3648
 -- Ubuntu daily release <email address hidden> Mon, 15 Apr 2013 04:17:27 +0000

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) on 2013-07-23
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers