Compiz reports incorrect _NET_DESKTOP_GEOMETRY until first viewport switch

Bug #1096455 reported by Matthieu Baerts on 2013-01-05
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Compiz
Medium
Sam Spilsbury
compiz (Ubuntu)
Medium
Sam Spilsbury

Bug Description

Hello,

Firstly, thank you for maintaining Compiz!

It's maybe a feature (and not a bug) but at startup Compiz creates only 1 viewport instead of 4.
We have this bug if we want 2x2 viewports (according to the CCSM) but if we change this default value (e.g. 3x2), Compiz creates 3x2 viewports at startup as wanted.

Note that if we switch from the first viewport to another one with Compiz shortkeys or plugin (e.g. with Ctrl+Alt+arrows or Expo plugin), then Compiz creates all theses 4 viewports as we can see:

Before:
   $ wmctrl -d
0 * DG: 1024x600 VP: 0,0 WA: 0,0 1024x600 N/A

After:
   $ wmctrl -d
0 * DG: 2048x1200 VP: 0,0 WA: 0,0 1024x600 N/A

This is maybe not important but that means that we can't know if this WM uses viewports or desktops and how many viewports/desktops are available because _NET_DESKTOP_GEOMETRY gives us "wrong" value (=> not the good one according to the CCSM). We can know if we can add desktops or viewports (and if we don't want to add desktop if viewports are supported)

Related branches

summary: - By default Compiz creates only 1 viewport at startup instead of 2x2
+ Compiz reports incorrect _NET_DESKTOP_GEOMETRY until first viewport
+ switch
Changed in compiz:
milestone: none → 0.9.9.0
importance: Undecided → Medium
Changed in compiz (Ubuntu):
importance: Undecided → Medium
TrakerJon (trakerjon) wrote :

I'm using Ubuntu 12.10 with Switcher v2.1.11, Cairo-Dock 3.1.2 and the MacOSX theme. I'm having the same issue with compiz-core 1:0.9.8.6-0ubuntu1. When first logging in only 1 desktop is available although when accessing CompizConfig Settings Manager > General Settings > Desktop Size the expected default 2 x 2 reference is correctly displayed. If you adjust these settings and then back to the default the proper number of desktops can now be viewed and validated (see below).

Before

$ wmctrl -d

  * DG: 1280x768 VP: 0,0 WA: 0,0 1280x768 N/A

$ wmctrl -d

After

0 * DG: 2560x1536 VP: 0,0 WA: 0,0 1280x768 N/A

Regards,

TrakerJon

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
TrakerJon (trakerjon) wrote :

Just to clarify, my issue reoccurs at each login not just "until first viewport switch".

TrakerJon

Matthieu Baerts (matttbe) wrote :

@trakerjon: yes but if you switch from one viewport to another one, it's fixed, no? (e.g. with Ctrl+Alt+arrows or Expo plugin)

Changed in compiz:
status: New → Confirmed
Sam Spilsbury (smspillaz) wrote :

Thanks.

I'll take a quick look at this now.

Changed in compiz:
assignee: nobody → Sam Spilsbury (smspillaz)
Matthieu Baerts (matttbe) wrote :

Oh, this bug seems already fixed!

@Sam: thank you for this quick fix ;)

Changed in compiz:
status: Confirmed → In Progress
Changed in compiz (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.9~daily13.01.21-0ubuntu1

---------------
compiz (1:0.9.9~daily13.01.21-0ubuntu1) raring; urgency=low

  [ Brandon Schaefer ]
  * Window Management - Implement maximize and semi-maximise transitions
    (LP: #689792)

  [ Sam Spilsbury ]
  * Several memory leaks in ccsIntegratedSettingListAppend() from
    ccsIntegratedSettingsStorageDefaultFindMatchingSettingsByPredicate()
    from
    ccsIntegratedSettingsStorageDefaultFindMatchingSettingsByPluginAndSe
    ttingName() (LP: #1100539)
  * Several leaks in g_settings_new() [g_object_new()] from
    ccsGSettingsNewNoPath() [ccs_gsettings_interface_wrapper.c:184] (LP:
    #1097649)
  * Compiz reports incorrect _NET_DESKTOP_GEOMETRY until first viewport
    switch (LP: #1096455)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 3569
 -- Automatic PS uploader <email address hidden> Mon, 21 Jan 2013 04:01:41 +0000

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers