compiz --replace does not bring back unity launcher, panels, window decorations

Bug #1095020 reported by Martin Wildam on 2013-01-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
Unity
New
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I am used to the fact that sometimes (since at least Ubuntu 10.04) that at least parts of compiz do not work sometimes after reboot or after a while working.

While under Ubuntu 12.04 this works without problems under Ubuntu 12.10 pressing ALT+F2 and entering compiz --replace the restore of the session does not work: Unity launcher is missing, top panel and window borders/decorators also.

See screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: compiz 1:0.9.8.4+bzr3412-0ubuntu0.1
ProcVersionSignature: Ubuntu 3.5.0-21.32-generic 3.5.7.1
Uname: Linux 3.5.0-21-generic i686
.tmp.unity.support.test.0:

ApportVersion: 2.6.1-0ubuntu9
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Tue Jan 1 13:20:07 2013
DistUpgraded: Fresh install
DistroCodename: quantal
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0263]
   Subsystem: Dell Device [1028:0263]
InstallationDate: Installed on 2012-12-18 (13 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release i386 (20121017.2)
MachineType: Dell Inc. Latitude E5500
MarkForUpload: True
PackageArchitecture: all
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-21-generic root=UUID=cfc5d11e-5350-45db-86e2-d6780d4a9814 ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/15/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A11
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA11:bd04/15/2009:svnDellInc.:pnLatitudeE5500:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude E5500
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.8.4+bzr3412-0ubuntu0.1
version.libdrm2: libdrm2 2.4.39-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu6.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120913.8637f772-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.9-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.2-0ubuntu3

Martin Wildam (mwildam) wrote :
Daniel van Vugt (vanvugt) wrote :

I think that is correct and normal. Try this instead:
    unity --replace

Changed in compiz (Ubuntu):
status: New → Incomplete
Martin Wildam (mwildam) wrote :

Currently I do not have an Ubuntu 12.10 available (from which I reported this bug) but tried on a test-vm with 12.04 and effect there is that Unity-launcher comes back and top panel, but window decorations still missing.

After applying all the latest updates (machine was not fully up-to-date) they came back after unity --replace but system shows strange behaviour then like flickering windows or starting nautilus twice when clicking on the launcher. Could be related to the vm guest (via virtualbox), so I will try this also on a bare metal installation.

Martin Wildam (mwildam) wrote :

I have tried unity --replace after expierencing high processor usage on a baremetal installation of 12.04 on my laptop.
First attempt did dont bring back the panel elements on the upper right.

On second attempt pressing ALT+F2 and executing unity --replace everything came back but apport came up with a crash report.

Martin Wildam (mwildam) wrote :

I can definitely say, that compiz --replace works fine (better than unity --replace) on Ubuntu 12.04.
So if unity --replace is the one to prefer, it should be fixed.

Changed in compiz (Ubuntu):
status: Incomplete → New
Daniel van Vugt (vanvugt) wrote :

Hmm, actually I should have tested it sooner. Running compiz --replace on 12.10 fails because of bug 1085591. Marking this as a duplicate of that until proven otherwise.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers