[raring][regression] Window management - Maximized windows aren't fullscreen in the workspace switcher

Bug #1087090 reported by John Swing on 2012-12-06
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Compiz
Medium
Christopher Townsend
0.9.11
Medium
Christopher Townsend
compiz (Ubuntu)
Medium
Christopher Townsend
Trusty
Undecided
Unassigned

Bug Description

[Impact]

Having a maximized window in Expo mode has kind of a jarring effect with a blank space where the Launcher and Panel should be. This leads to poor visual experience for users.

[Test case]

1. Make sure workspaces are enabled.
2. Open a window and make sure it's maximized.
3. Initiate Expo by hitting Super+S.

[Regression potential]

None identified.

* Debdiff is found at *

Original description:

Hello,

Since today's updates of compiz, the workspace switcher don't work the same way as before. When you have a maximized windows and you click on the launcher's workspace icon, the workspace switcher appears but the maximized windows aren't fullscreened. You can see the voids that represent the launcher and the panel.

I attached a screenshot for a better understanding of the problem.

Related branches

lp:~townsend/compiz/fix-expo-maximized-window-gap
Merged into lp:compiz/0.9.11 at revision 3868
Marco Trevisan (Treviño): Approve on 2014-06-05
PS Jenkins bot: Approve (continuous-integration) on 2014-05-26
lp:~compiz-team/compiz/prepare-0.9.11.3-SRU
Merged into lp:compiz/0.9.11 at revision 3867
Stephen M. Webb: Approve on 2014-11-04
PS Jenkins bot: Approve (continuous-integration) on 2014-07-25
John Swing (john-swing) wrote :
description: updated
John Swing (john-swing) wrote :
Daniel van Vugt (vanvugt) wrote :

Confirmed. I did not even realize the old behaviour existed. This probably regressed in r3481.

Changed in compiz:
milestone: none → 0.9.9.0
importance: Undecided → Medium
Changed in compiz (Ubuntu):
importance: Undecided → Medium
Changed in compiz:
status: New → Confirmed
Changed in compiz (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Actually, make it Low. I don't think it's a good idea to unrealistically pick and choose which workspaces to scale differently in expo based on their windows. All workspaces should be scaled identically.

Changed in compiz:
importance: Medium → Low
Changed in compiz (Ubuntu):
importance: Medium → Low
Sam Spilsbury (smspillaz) wrote :

Sounds like this is a regression on the old behaviour from when we upstreamed the patch.

Daniel the reason I made it do that was for the exact reasons this bug points out - things just look wrong when you enter the workspace switcher mode.

summary: - [raring]Maximized windows aren't fullscreen in the workspace switcher
+ [raring][regression] Maximized windows aren't fullscreen in the
+ workspace switcher
John Lea (johnlea) on 2012-12-17
Changed in ayatana-design:
status: New → Fix Committed
Changed in compiz:
status: Confirmed → Triaged
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
summary: - [raring][regression] Maximized windows aren't fullscreen in the
- workspace switcher
+ [raring][regression] Window management - Maximized windows aren't
+ fullscreen in the workspace switcher
Changed in ayatana-design:
importance: Undecided → Medium
Changed in compiz:
importance: Low → Medium
Changed in compiz (Ubuntu):
importance: Low → Medium
Changed in ayatana-design:
importance: Medium → High
assignee: nobody → John Lea (johnlea)
tags: added: udp
Changed in compiz:
milestone: 0.9.9.0 → 0.9.9.2
Changed in compiz:
milestone: 0.9.9.2 → 0.9.10.0
Fabrizio Narni (shiba89) wrote :

So this won't be fixed for raring?

MC Return (mc-return) on 2013-07-24
Changed in compiz:
milestone: 0.9.10.0 → 0.9.11.0
Oscar Carlberg (canhasspace) wrote :

Will this be fixed in Trusty? Since it's an LTS and 12.04 does not have this bug, it would make sense to fix this regression, looks much more polished when windows are maximized.

Changed in compiz:
assignee: nobody → Christopher Townsend (townsend)
Changed in compiz (Ubuntu):
assignee: nobody → Christopher Townsend (townsend)
Changed in compiz:
status: Triaged → In Progress
Changed in compiz (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.11+14.10.20140606-0ubuntu1

---------------
compiz (1:0.9.11+14.10.20140606-0ubuntu1) utopic; urgency=low

  [ Chris Townsend ]
  * Only ungrab the Mod2Mask modifier on buttons 4-7 to allow scrolling
    in unfocused Gtk windows while still allowing keybinding modifiers
    to other scroll wheel actions. (LP: #1311788)
  * Fix issue where window decorations would be placed under the Panel
    when opening a new window from an already open window. This is due
    to the already open window being taller or just as tall without be
    maximized than the workspace. (LP: #1303462)
  * Only constrain the non-modifier scrolling to the vertical scrolling
    buttons - buttons 4 & 5. (LP: #1311303)
  * Fix issue where maximized windows would get moved to different
    workspaces when disconnecting/connecting an external monitor.
    Windows should stay in the same workspace they are in when the
    monitor event occurs. (LP: #1304531)
  * Fix issue where custom keyboard shortcuts would get reset to
    defaults when rebooting or restarting Compiz. (LP: #1063617)
  * Fixes issue in the Expo plugin where a gap is shown in the place
    where the Launcher and Panel should be when windows are maximized.
    This was originally removed in rev. 3481. (LP: #1087090)
  * Fix issue where horizontal and vertical keyboard resizing could not
    happen at the same time. (LP: #347390)

  [ Marco Trevisan (Treviño) ]
  * Scale: use XShape extension to exclude dnd input in the screen-parts
    outside workArea This will work property also in multi-monitor,
    without requiring multiple X windows for each output device. Also
    don't terminate the scale unless a drag-n-drop action is not really
    over. Add a spinner that shows up over a window, during the DnD
    timeout. Plus, make sure we terminate the scale without focusing the
    selected icon when cancelling it and some code cleanup (LP: #607796)
  * Event: set the screen grabbed also when we get a NotifyWhileGrabbed
    Focus{In,Out} event (LP: #1305586)
 -- Ubuntu daily release <email address hidden> Fri, 06 Jun 2014 09:43:06 +0000

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Changed in compiz:
status: In Progress → Fix Committed
milestone: 0.9.11.0 → 0.9.12.0

This bug is fixed in Utopic but when I tried how it works by running the newest iso image in live mode I discovered a new problem.

The maximized windows dragged in the workspace switcher don't overlay the workspaces in the usual way. Instead they end up being under some of the workspaces and they can trigger display of tooltips from other windows.

Oscar Carlberg (canhasspace) wrote :

Yey! Awesome work with the fix. Will it be backported to 14.04?

description: updated
description: updated

Hello John, or anyone else affected,

Accepted compiz into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/compiz/1:0.9.11.1+14.04.20140617-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in compiz (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed

I'm not sure how to mark the verification because the problem which I described in comment #9 is also now in the SRU for Trusty.

Oscar Carlberg (canhasspace) wrote :

I can also confirm Mateusz issue, dragged windows does not overlay workspaces properly.

Verified with the following drivers:
- Nvidia propertiery
- Radeon Open Source
- Virtualbox Guest

All on vanilla 14.04 with upgraded packages from proposed;
sudo apt-get upgrade compiz-gnome/trusty-proposed libcompizconfig0/trusty-proposed compiz-plugins-default/trusty-proposed

Bah, I missed the comment on June 15th. Yeah, this is a regression and shouldn't be accepted in the SRU. What we'll have to do is:

1. Create a new bug report for Utopic about the regression.
2. Respin the SRU to remove this change.
3. Hopefully fix this correctly for Utopic.
4. Get it into a future SRU for Trusty.

tags: added: verification-failed
removed: verification-needed
description: updated
tags: removed: verification-failed

Christopher for some reason this bug is again listed for verification process in Pending SRUs for Trusty.

http://people.canonical.com/~ubuntu-archive/pending-sru.html

Seems like it was incorrectly placed on that listing because here there is no SRU test request and of course you reverted those changes in updated packages.

Mathew Hodson (mathew-hodson) wrote :

The fix was removed from -proposed.

Changed in compiz (Ubuntu Trusty):
status: Fix Committed → In Progress
Stephen M. Webb (bregma) on 2014-11-06
Changed in compiz:
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Attaching debdiff between source in trusty-updates and proposed SRU

Chris J Arges (arges) wrote :

Hello John, or anyone else affected,

Accepted compiz into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/compiz/1:0.9.11.3+14.04.20141104-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in compiz (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed

The proposed package verified.
--> The bug was corrected. Thanks.

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.1 LTS
Release: 14.04
Codename: trusty

$ LANG=C apt list --installed *compiz* | grep proposed

WARNING: apt does not have a stable CLI interface yet. Use with caution in scripts.

compiz/trusty-proposed,now 1:0.9.11.3+14.04.20141104-0ubuntu1 all [installed]
compiz-core/trusty-proposed,now 1:0.9.11.3+14.04.20141104-0ubuntu1 i386 [installed]
compiz-gnome/trusty-proposed,now 1:0.9.11.3+14.04.20141104-0ubuntu1 i386 [installed]
compiz-plugins/trusty-proposed,now 1:0.9.11.3+14.04.20141104-0ubuntu1 i386 [installed,automatic]
compiz-plugins-default/trusty-proposed,now 1:0.9.11.3+14.04.20141104-0ubuntu1 i386 [installed]
libcompizconfig0/trusty-proposed,now 1:0.9.11.3+14.04.20141104-0ubuntu1 i386 [installed]

tags: added: verification-done
removed: compiz switcher udp unity verification-needed workspace
tags: added: compiz switcher udp unity workspace

The verification of the Stable Release Update for compiz has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.11.3+14.04.20141104-0ubuntu1

---------------
compiz (1:0.9.11.3+14.04.20141104-0ubuntu1) trusty; urgency=medium

  [ Chris Townsend ]
  * Add NumLock and CapsLock button ungrab keymasks, so unfocused Gtk
    window scrolling will work when NumLock is off and CapsLock is on
    and any combination thereof. (LP: #1311788)
  * Fixes issue in the Expo plugin where a gap is shown in the place
    where the Launcher and Panel should be when windows are maximized.
    This was originally removed in rev. 3481. (LP: #1087090)
  * Bump version to 0.9.11.3.
 -- Ubuntu daily release <email address hidden> Tue, 04 Nov 2014 19:42:46 +0000

Changed in compiz (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers