Compiz fails to build in Arch Linux

Reported by Iven Hsu on 2012-10-23
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Compiz
High
Iven Hsu

Bug Description

Many errors in build/compizconfig/compizconfig-python/compizconfig.c.

The error output is attached.

Related branches

lp:~ivenvd/compiz/compiz.doc.fix_1070211
Merged into lp:compiz/0.9.9 at revision 3442
PS Jenkins bot: Needs Fixing (continuous-integration) on 2012-10-26
Daniel van Vugt: Approve on 2012-10-26
Sam Spilsbury: Approve on 2012-10-26
Iven Hsu (ivenvd) wrote :
Daniel van Vugt (vanvugt) wrote :

It fails much earlier for other people. See bug 1004592.

Changed in compiz:
milestone: none → 0.9.9.0
Iven Hsu (ivenvd) wrote :

No, bug 1004592 is about python3 default. And this bug is about the build error introduced this week. At least revsion 4327 builds with no errors (after fixed python issues).

Iven Hsu (ivenvd) wrote :

This is caused by revision 3434 which introduced PythonLibs of CMake, which always finds Python3 instead of Python2.

A workaround is to configure like this:

    cmake .. \
        -DCMAKE_INSTALL_PREFIX="/usr" \
        -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
        -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so

As the issue is not caused by compiz, I'm marking it invalid.

Changed in compiz:
status: New → Invalid
Iven Hsu (ivenvd) on 2012-10-26
Changed in compiz:
status: Invalid → In Progress
assignee: nobody → Iven Hsu (ivenvd)
Changed in compiz:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz at revision 3442, scheduled for release in Compiz 0.9.9.0

Changed in compiz:
importance: Undecided → High
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments