problems changing window focus in Unity Spread

Bug #1070034 reported by Paul Greindl on 2012-10-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

When entering the window "Spread" though "super+w" it often happens, depending on the applications open and the window size, that it's not possible to navigate to a certain window with the arrow keys as it (the window) is in wrong position in some way.

To make it easier to understand, and easier for me to describe, I made a screenshot in which I with red arrows show in which way I can navigate through windows and change window focus using arrow keys. Please find the file attached.

No idea why it is like this.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 6.8.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Mon Oct 22 21:41:21 2012
DistUpgraded: 2012-10-19 14:30:39,130 DEBUG enabling apt cron job
DistroCodename: quantal
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:055c]
MachineType: Dell Inc. Vostro 3360
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=3652D33152D2F519 loop=/hostname/disks/root.disk ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to quantal on 2012-10-19 (3 days ago)
dmi.bios.date: 05/10/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A04
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 07X5MJ
dmi.board.vendor: Dell Inc.
dmi.board.version: FAB1
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA04:bd05/10/2012:svnDellInc.:pnVostro3360:pvr:rvnDellInc.:rn07X5MJ:rvrFAB1:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Vostro 3360
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.8.4-0ubuntu3
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.39-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120913.8637f772-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.9-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.2-0ubuntu3

Daniel van Vugt (vanvugt) wrote :

I can't reproduce it yet, but have assigned this to compiz, where the scale plugin lives.

affects: unity (Ubuntu) → compiz (Ubuntu)
Paul Greindl (paul-greindl) wrote :

I've experienced it again and I think I've found a strange misbehavior which could be responsible for the problem. See the attached screenshot. The purple arrow shows "the problem".

Paul Greindl (paul-greindl) wrote :

What's the matter? I really don't understand whay it is behaving like this. Can someone who knows a little about the code behind this feature maybe take a look and see what's the problem.
Personally I experience this problem quite often, am I the only one? It's not that terrible but it's strange and gives a little beta-feeling...

See atached image (red arrows are possible switching directions using hte keyboard).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed

I have been experiencing this bug for quite a while in 12.04 64 bit. It occurs to me rather often, some windows remain inaccessible using arrows navigation, although it's difficult to say if there is a precise pattern or arrangement of windows that lead to the issue. However, I cannot reproduce the bug on a 32 bit install of 12.04, with the same set of compiz plugins and only slightly different options.

Any hints how to debug this? I would be very happy to provide additional info to help fix it.

The bug is definitely there also in the 32 bit version: some arrow movements in the spread are sometimes impossible.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers