"Fade to Desktop" and "Show desktop" plug-ins should be automagically disabled and hidden in CCSM if the Ubuntu Unity Plugin is enabled

Bug #1063171 reported by MC Return on 2012-10-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz
Undecided
MC Return
Unity
Fix Released
Low
MC Return
6.0
Fix Released
Low
MC Return
unity (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

[Test Case]
1. Open ccsm
2. Try to enable Fade to Desktop or Show desktop plugins
   -> Ensure that it conflicts with unity when unityshell plugin is enabled

[Regression Potential]
No regression potential.

Why ?
1. They do not work at all if Unity is running, because Unity uses its own code to fade to the desktop (unity/plugins/unityshell/src/UnityShowdesktopHandler.cpp/.h).
2. Those plug-ins will just frustrate users if they still seem functional in CCSM, but changes to them are ignored by Compiz anyway if Unity runs.

Related branches

Daniel van Vugt (vanvugt) wrote :

I think it's poor design to give Compiz any knowledge of Unity. It should only work the other way.

Changed in compiz:
status: New → Opinion
MC Return (mc-return) wrote :

I think it is poor design to present "fake" options to the user. Once Unity is activated those plug-ins are completely useless, do not work and only can frustrate users trying to do anything with them.

What is the problem of having Compiz know about Unity ?

But after all just CCSM has to know about the state of the unityshell plug-in and in this case automatically hide and disable those 2 non-working plug-ins.
This more intelligent behavior would also fix:

bug 1006429 and bug 1006434

Changed in compiz:
status: Opinion → New
MC Return (mc-return) wrote :

I have to mark this bug as "new", otherwise I cannot find it anymore via the "reported bugs" launchpad function which seems to automatically filter invalid and opinion bugs.

MC Return (mc-return) wrote :

Or we could probably use/add <feature>showdesktop</feature> to unity/plugins/unityshell.xml.in to display a warning like it is already used for various other plug-ins which are not allowed to provide the same feature twice.

The dialogue would look like this:

"Plugin Unity provides feature showdesktop which is also provided by Show Desktop/Fade to Desktop".
 Don't enable Show/Fade Desktop Disable Unity

MC Return (mc-return) wrote :

Should I implement that ?

MC Return (mc-return) wrote :

Example screenshot (here the feature is not showdesktop, but edgeresistance and the user tries to enable Snapping Windows while having the same feature already provided by Wobbly Windows).

MC Return (mc-return) wrote :

Actually this fix has to be made in unity/plugins/unityshell.xml.in, so I am adding Unity to this report.

Changed in unity:
assignee: nobody → MC Return (mc-return)
MC Return (mc-return) on 2012-10-10
Changed in compiz:
assignee: nobody → MC Return (mc-return)
status: New → In Progress
Changed in unity:
status: New → In Progress
Changed in unity:
status: In Progress → Fix Committed
Changed in compiz:
status: In Progress → Won't Fix
Changed in unity:
milestone: none → 7.0.0
status: Fix Committed → In Progress
importance: Undecided → Low
Changed in unity (Ubuntu):
status: New → In Progress
Galvatron (megatron) wrote :

Both plugins work perfectly for me. In the case of Show Desktop it's just a question of setting it to start after Unity, using Gconf Editor.

MC Return (mc-return) wrote :

@megatron: That are actually good news. :) With default settings they do not work.

I will verify your observation, and if working, change the startup sequence accordingly and remove the patch that prevents them from starting together (unityshell+showdesktop/unityshell+fadetodesktop).

The showdesktop plug-in is far superior in visual appearance compared to the fade effect Unity uses, so the showdesktop plug-in revealing the desktop by moving them to the edges should of course not be deactivated if there is a way to make this plug-in work together with Unity without creation of new problems.

MC Return (mc-return) wrote :

@megatron:
I can confirm your observations and have filed a new bug and will provide a fix soon. :)
The problem will be tracked here: bug 1067534.

Changed in unity:
status: In Progress → Fix Committed
description: updated
SilentSB (misu-qy) wrote :

“Ubuntu Unity Plugin" -> “Switcher”
find “Show minimized windows in switcher” and disabled, then I fixed it in my laptop

Hello MC, or anyone else affected,

Accepted unity into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/6.10.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed
Łukasz Zemczak (sil2100) wrote :

Works for me like a charm.

tags: added: verification-done
removed: verification-needed
Chris Halse Rogers (raof) wrote :

Hello MC, or anyone else affected,

Accepted unity into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/6.10.0-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Timo Jyrinki (timo-jyrinki) wrote :

Remains fixed with the new upload in proposed.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.10.0-0ubuntu2

---------------
unity (6.10.0-0ubuntu2) quantal-proposed; urgency=low

  * Cherry-picked from upstream:
    - [SRU Regression] Launcher icon corruption while rearranging
      (LP: #1071813)

unity (6.10.0-0ubuntu1) quantal-proposed; urgency=low

  [ Timo Jyrinki ]
  * New upstream release.
    - Gap between the dash gradient and the panel one (LP: #1062375)
    - [regression] Dash closes if the onscreen keyboard is outside of
      Dash' geometry (LP: #1058705)
    - Dash - Category expander arrow is in expanded mode no matter if
      category is actually expanded (LP: #1053047)
    - Unity panel does not show the kate menus in the correct order
      (LP: #1062283)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a() from
      g_object_unref() from _g_file_attribute_value_clear() from ... from
      query_info_async_cb() [libgvfsdbus.so] (LP: #1061510)
    - dash's music album previews: can't drag the scrollbar (LP: #1056995)
    - Small chunks of the panel shadow appear individually (and very dark)
      (LP: #1057528)
    - compiz crashed with SIGSEGV on Unity "Unmount" (LP: #1055812)
    - [regression] Dash - 'More suggestions' icons in App Lens are too
      large (LP: #1052513)
    - BamfLauncherIcon: ensure the icon and name values when the running
      state changes (LP: #772986)
    - Changes the swapping order of the detail mode. Now the currently
      active window gets moved to the end, instead of getting swapped
      with the last used window (LP: #1061229)
    - Fixes GetRegion tex coord maths (LP: #1058391)
    - Fixed fade-in behavior of Unity's showdesktop function (LP: #1063249)
    - Added <feature>showdesktop</feature> to unityshell.xml.in, because
      the feature showdesktop is provided by unityshell. (LP: #1006429)
      (LP: #1006434) (LP: #1063171)
    - Make HudLauncherIcon::ubus_manager_ "un-static" (LP: #1048274)
    - Fix reference counting problem which leads to memory leaks and a
      crash in MT grab handles (LP: #1046201)
    - Ensure categories with non-personal results can show up before empty
      categories with personal results (LP: #1067327)
    - fix a backup error (LP: #1066646)

  [ Łukasz 'sil2100' Zemczak ]
  * Cherry-picked from upstream:
    - Reverted the switch from boost to std which was part of the fix for
      LP: #1046201. The crash is still fixed without this change, so it was
      actually unneeded
 -- Lukasz 'sil2100' Zemczak <email address hidden> Tue, 30 Oct 2012 18:00:00 +0100

Changed in unity (Ubuntu Quantal):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.10.0-0ubuntu3

---------------
unity (6.10.0-0ubuntu3) raring; urgency=low

  * Upload to raring

unity (6.10.0-0ubuntu2) quantal-proposed; urgency=low

  * Cherry-picked from upstream:
    - [SRU Regression] Launcher icon corruption while rearranging
      (LP: #1071813)

unity (6.10.0-0ubuntu1) quantal-proposed; urgency=low

  [ Timo Jyrinki ]
  * New upstream release.
    - Gap between the dash gradient and the panel one (LP: #1062375)
    - [regression] Dash closes if the onscreen keyboard is outside of
      Dash' geometry (LP: #1058705)
    - Dash - Category expander arrow is in expanded mode no matter if
      category is actually expanded (LP: #1053047)
    - Unity panel does not show the kate menus in the correct order
      (LP: #1062283)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a() from
      g_object_unref() from _g_file_attribute_value_clear() from ... from
      query_info_async_cb() [libgvfsdbus.so] (LP: #1061510)
    - dash's music album previews: can't drag the scrollbar (LP: #1056995)
    - Small chunks of the panel shadow appear individually (and very dark)
      (LP: #1057528)
    - compiz crashed with SIGSEGV on Unity "Unmount" (LP: #1055812)
    - [regression] Dash - 'More suggestions' icons in App Lens are too
      large (LP: #1052513)
    - BamfLauncherIcon: ensure the icon and name values when the running
      state changes (LP: #772986)
    - Changes the swapping order of the detail mode. Now the currently
      active window gets moved to the end, instead of getting swapped
      with the last used window (LP: #1061229)
    - Fixes GetRegion tex coord maths (LP: #1058391)
    - Fixed fade-in behavior of Unity's showdesktop function (LP: #1063249)
    - Added <feature>showdesktop</feature> to unityshell.xml.in, because
      the feature showdesktop is provided by unityshell. (LP: #1006429)
      (LP: #1006434) (LP: #1063171)
    - Make HudLauncherIcon::ubus_manager_ "un-static" (LP: #1048274)
    - Fix reference counting problem which leads to memory leaks and a
      crash in MT grab handles (LP: #1046201)
    - Ensure categories with non-personal results can show up before empty
      categories with personal results (LP: #1067327)
    - fix a backup error (LP: #1066646)

  [ Łukasz 'sil2100' Zemczak ]
  * Cherry-picked from upstream:
    - Reverted the switch from boost to std which was part of the fix for
      LP: #1046201. The crash is still fixed without this change, so it was
      actually unneeded
 -- Didier Roche <email address hidden> Fri, 09 Nov 2012 08:06:47 +0100

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) on 2013-02-19
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Released → Fix Committed
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers