[fglrx] Compiz (opengl) - Fatal: glXQueryExtensionsString is NULL for screen 0

Bug #1054257 reported by Marco Giannini on 2012-09-21
146
This bug affects 32 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Unassigned
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

I have upgrade to Ubuntu 12.10 from Precise.
Unity do not start.
If i try to start from terminal i see this

http://pastebin.com/nXUY8E4m

I have proposed active
More info:
Compiz: 0.9.8.2+bzr3377-0ubuntu1
Unity: 6.6.0-0ubuntu1
Catalyst: 12.9

description: updated
description: updated
summary: - Unity do not start Ubuntu 12.10
+ Compiz (opengl) - Fatal: glXQueryExtensionsString is NULL for screen 0
affects: unity → compiz

I think this is the same issue as bug 1054724. And both are a side-effect of the fix for bug 944653.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) wrote :

Do we need a stacktrace to be sure?

Daniel van Vugt (vanvugt) wrote :

No stacktrace required. The error message explains it all; why compiz won't start.

Changed in compiz:
milestone: none → 0.9.8.4
Changed in compiz:
milestone: 0.9.8.4 → 0.9.9.0
mrmental (sam-baynham) wrote :

I am also experiencing this. AMD64/ATI Radeon HD 46xx, upgraded from precise via the software centre.
http://pastebin.com/TEL4nrZK
Have purged compiz configuration and reinstalled to no effect.

Daniel van Vugt (vanvugt) wrote :

Actually we do need a little more info.

Marco -
Please run:
    apport-collect 1054257
on the offending machine.

Changed in compiz:
status: New → Incomplete
Changed in compiz (Ubuntu):
status: Confirmed → Incomplete
summary: - Compiz (opengl) - Fatal: glXQueryExtensionsString is NULL for screen 0
+ [fglrx] Compiz (opengl) - Fatal: glXQueryExtensionsString is NULL for
+ screen 0
Changed in fglrx-installer (Ubuntu):
status: New → Incomplete
mrmental (sam-baynham) wrote :

Hi, quick update to my original comment; removing/purging fglrx at least lets unity start. Poss bug with ATI driver?
Regards
SB

mrmental (sam-baynham) wrote :

Final update; installing fresh FGLRX from ATI page failed to solve issue.

> installing fresh FGLRX from ATI page failed to solve issue
1. http://support.amd.com/us/gpudownload/linux/legacy/Pages/legacy-radeon_linux.aspx
fglrx 8.97 (Catalyst 12.6 Legacy) support legacy hardware (pre-HD5000) but doesn't support xserver 1.13 so it can not work on Quantal.
2. http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx
fglrx 9.00 published on AMD web-site (Catalyst 12.9 Beta, August build) is doesn't support xserver 1.13 so it can not work on Quantal. It also doesn't support legacy hardware.
3. https://launchpad.net/ubuntu/+source/fglrx-installer
fglrx 9.00 published in Ubuntu repository (September build) is support xserver 1.13 but it doesn't support Radeon HD 46xx so you can not use this driver on Quantal.

So in my opinion you most likely experience different issue. Solution is: uninstall proprietary driver or use proprietary driver on Precise.

Yesterday I upgraded the system and came the same error, unity and compiz does't work. I uninstalling fglrx and now my screen does't work anymore, everything is black. I listening the ubuntu initial sound, but my screen still black. Because of this problem I thinking if I install 12.04 or change distribution to another. None of the solutions presented solved, only worsened. Ubuntu 12.10 + ATI 46xx does't work.

cashy (kispal-istvan) wrote :

Same to me on NVIDIA Geforce GTX 660M. Background image appears, and Unity fails.
Ubuntu 12.10.

cashy

Changed in compiz:
milestone: 0.9.9.0 → 0.9.9.2
tags: added: quantal
Fabio Marconi (fabiomarconi) wrote :

affecting raring in duplicates

tags: added: raring
Anton Melnikov (skilrex) wrote :

Login as guest, may be it help you

Changed in compiz:
milestone: 0.9.9.2 → 0.9.10.0
LingYuxun (13241371658-u) wrote :

ubuntu13.04 is also affected

Bolche (companheiro-vermelho) wrote :

Same problem with ubuntu 13.04 using a ATI Radeon HD 7730M.
After installing the 13.3 beta driver (http://support.amd.com/us/kbarticles/Pages/AMDCatalyst13-3LINBetaDriver.aspx) I got the same error in Xorg.0.log as http://forums.gentoo.org/viewtopic-t-949372-start-0.html:

fglrx(0): Failed to allocate caches, disabling RENDER acceleration
fglrx(0): [intel] Failed to allocate video resources for front buffer 1920x1080 at depth 24
Fatal server error:
failed to create screen resources

JoaoPinto (joao-icaro) wrote :

Same here with NVIDIA GeForce 9300M GS and Ubuntu 12.10.

JoaoPinto (joao-icaro) wrote :

Found a fix for my problem and it now working.

Overview of my problem:
Ubuntu 12.10 + NVIDIA GeForce 9300 GS
Unity do not start Ubuntu 12.10 + Compiz (opengl) - Fatal: glXQueryExtensionsString is NULL for screen 0

What I did to solve this issue:
re-installed the nvidia drivers following this tutorial: http://www.dedoimedo.com/computers/ubuntu-quetzal-nvidia.html

   sudo apt-get install build-essential linux-source
   uname-r
   sudo apt-get install linux-headers-`uname -r`
   sudo apt-get install nvidia-current
   sudo /sbin/lsmod | grep nvidia
no nvidia found, so:
   sudo depmod -a
   sudo modprobe nvidia_current
   sudo /sbin/lsmod | grep nvidia
now it is ok, with count 0
   sudo /etc/init.d/lightdm restart

unity is restored! yay!

Hope this helps someone.

J

JoaoPinto (joao-icaro) wrote :

I'd like to thank my younger self for helping me.

After an update, something went a little kaka and the previously reported problem resurfaced.

All I had to do was follow my own previous post and after I re-installed the "linux-headers-XXX" everything went back to normal.

J

JoaoPinto (joao-icaro) wrote :

It seems that every single time I update and reboot, I have this problem. Not funny at all!

The solution is to "sudo apt-get install linux-headers-'uname -r'.

When I do that it seems that the package is not installed. Was it removed on the update?? After installing everything is back to normal.

How can we permanently solve this issue?

J

MC Return (mc-return) on 2013-07-24
Changed in compiz:
milestone: 0.9.10.0 → 0.9.11.0
JoaoPinto (joao-icaro) wrote :

I just experienced this issue AGAIN and solved it as mentioned in a previous post.

J

Launchpad Janitor (janitor) wrote :

[Expired for fglrx-installer (Ubuntu) because there has been no activity for 60 days.]

Changed in fglrx-installer (Ubuntu):
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for compiz (Ubuntu) because there has been no activity for 60 days.]

Changed in compiz (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers