cmake fails on python 2.6 as sys.version_info does not contain major_version or minor_version

Bug #1048964 reported by Sam Spilsbury on 2012-09-11
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Compiz
Medium
Sam Spilsbury

Bug Description

Traceback (most recent call last):
  File "<string>", line 1, in <module>
AttributeError: 'tuple' object has no attribute 'major'
CMake Error at compizconfig/compizconfig-python/CMakeLists.txt:19 (string):
  string sub-command REPLACE requires at least four arguments.

Related branches

Changed in compiz:
milestone: none → 0.9.8.4
assignee: nobody → Sam Spilsbury (smspillaz)
status: New → Confirmed
importance: Undecided → Medium
Changed in compiz:
status: Confirmed → In Progress
Changed in compiz:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz at revision 3385

Changed in compiz:
status: Fix Committed → Fix Released
simon (sausageandeggs) wrote :

Still getting the same error with 9.8.4 on Archlinux

http://pastebin.com/HRV649eA

Daniel van Vugt (vanvugt) wrote :

simon,

That looks like bug 1004592. Please comment on that one.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers