Random test failures in CCSGSettingsBackendConcept

Bug #1046701 reported by Daniel van Vugt on 2012-09-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz
Medium
Sam Spilsbury

Bug Description

This has happened, randomly, with several fresh branches from lp:compiz in recent days/weeks:

The following tests FAILED:
 324 - CCSGSettingsBackendConcept/CCSBackendConformanceTestInfo.TestGetInfo/0 (OTHER_FAULT)
 325 - CCSGSettingsBackendConcept/CCSBackendConformanceTestInitFiniFuncs.TestReadInit/0 (OTHER_FAULT)
 326 - CCSGSettingsBackendConcept/CCSBackendConformanceTestInitFiniFuncs.TestReadDone/0 (OTHER_FAULT)
 327 - CCSGSettingsBackendConcept/CCSBackendConformanceTestInitFiniFuncs.TestWriteInit/0 (OTHER_FAULT)
... many more ...

Related branches

Daniel van Vugt (vanvugt) wrote :

I keep thinking I made a mistake when the failures go away. Then a day or two later, they happen again with fresh branches from lp:compiz.

Daniel van Vugt (vanvugt) wrote :

Looks like the cause is:
383: (process:32126): GLib-GIO-ERROR **: Settings schema 'org.compiz' is not installed

I think we have a problem if the unit tests are relying on the host system to have this installed.

Daniel van Vugt (vanvugt) wrote :

Workaround:

rm -rf build
mkdir build
cd build
cmake ... again

It usually starts working again on the second try. :P

Changed in compiz:
milestone: 0.9.8.2 → 0.9.8.4
Changed in compiz:
status: Triaged → In Progress
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz at revision 3362

Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments