[regression] Window management - Middle clicking panel no longer focuses window behind it

Reported by Joe Talbott on 2012-08-23
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Compiz
Medium
Unassigned
Unity
Medium
Unassigned
compiz (Ubuntu)
Medium
Unassigned

Bug Description

I bind Alt-F3 to Lower window. When pressing the shortcut the window is lowered but it retains focus. I have to press Alt-F3 twice to switch focus from the lowered window

This is 12.10 as of August 23, 2012 at 14:00 UTC.

How to repeat:
   gsettings set org.gnome.desktop.wm.keybindings lower "['<Alt>f3']"
   # press Alt+F3

What happened:
   The window is lowered but keeps focus

What should happen:
   The next window in the stack should get focus.

---------------------------------------

The autopilot test:
unity.tests.test_panel.PanelGrabAreaTests.test_lower_the_maximized_window_works

Is failing.

What should happen:
1) Open gnome-calculator
2) Open gedit, and maximize it
3) Middle click the Panel

Expected:
Gedit should fall behind the calculator and the calculator should get focus

What happens:
Gedit falls behind the calculator, but gedit keeps focus.

NEEDS-DESIGN: Upon middle-clicking panel, should the last used window get focus too?
ANSWER FROM DESIGN: When a window is sent to the back, the last used window should get focus (the testcase and expected results described above are correct)

Joe Talbott (joetalbott) wrote :
tags: added: compiz-0.9
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
John Lea (johnlea) on 2012-10-09
summary: - lowered window retains focus
+ [regression] Window management - Middle clicking panel no longer focuses
+ window behind it
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
Changed in compiz:
importance: Undecided → Medium
Changed in compiz (Ubuntu):
importance: Undecided → Medium
Changed in ayatana-design:
status: New → Triaged
Changed in compiz:
status: New → Triaged
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
Changed in ayatana-design:
status: Triaged → Fix Committed
tags: added: udp
Changed in compiz:
status: Triaged → Invalid
Changed in compiz (Ubuntu):
status: Triaged → Invalid
Changed in unity:
status: New → Fix Released
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers