Window Management - Setting the UnMinimize animation is ignored (default animation still used)

Bug #1040455 reported by Daniel van Vugt on 2012-08-23
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Compiz
Critical
Daniel van Vugt
compiz (Ubuntu)
Critical
Unassigned

Bug Description

Setting the UnMinimize animation is ignored (Minimize animation still used)

--------------------
Alternative description:

In the Beta 1 release of 12.10, the unminimize animation has changed to using the "magic lamp" effect. This is incorrect, and this change needs to be reverted to the previous "Glide 2" plus Fade effects.

Both visual design and Christian Giordano (who is responsible for Unity animations) and reviewed this change, and request that it be reverted to its previous value.

Marking as 'Critical' because this is a very visible user interface regression that needs to be fixed asap.

Related branches

summary: - Setting the UnMinimize animation is ignored (Minimize animation still
- used)
+ Setting the UnMinimize animation is ignored (default Minimize animation
+ still used)
summary: - Setting the UnMinimize animation is ignored (default Minimize animation
- still used)
+ Setting the UnMinimize animation is ignored (default animation still
+ used)
Changed in compiz:
assignee: Ugo Riboni (uriboni) → nobody
importance: Low → Medium
Changed in compiz (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in compiz:
milestone: none → 0.9.8.2
Changed in compiz:
importance: Medium → Critical
Changed in compiz (Ubuntu):
importance: Medium → Critical
Daniel van Vugt (vanvugt) wrote :

Also, the default Ubuntu config was wrong. That's bug 1041119.

Changed in compiz:
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in compiz:
status: Triaged → In Progress
Changed in compiz:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz at revision 3333

John Lea (johnlea) on 2012-09-04
description: updated
tags: added: udp
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Critical
status: New → Triaged
status: Triaged → Fix Committed
Changed in compiz:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2012-09-19
summary: - Setting the UnMinimize animation is ignored (default animation still
- used)
+ Window Management - Setting the UnMinimize animation is ignored (default
+ animation still used)
Launchpad Janitor (janitor) wrote :
Download full text (5.2 KiB)

This bug was fixed in the package compiz - 1:0.9.8.2+bzr3377-0ubuntu1

---------------
compiz (1:0.9.8.2+bzr3377-0ubuntu1) quantal-proposed; urgency=low

  [ Sam Spilsbury ]
  * debian/python-compizconfig.install
    - Install compizconfig-python.pc
  * debian/patches/100_expo_layout.patch
    - re-add the expo layout that used to be in precise (LP: #1047067)
    - add some testcases

  [ Timo Jyrinki ]
  * New upstream snapshot.
    - Fix multiple window placement bugs (LP: #974242) (LP: #976032)
    - Don't waste CPU looping through and looking at all the windows if you're
      rendering an output that has no damage on it. (LP: #1014986)
    - Updated convert files to fix some typos in the key names. (LP: #1041631)
    - Fix crash when imgsvg is loaded, due to missing symbol
      (decor_apply_gravity from libdecoration). (LP: #956986)
    - Treat unresolved symbols at link time as an error, rather than letting
      them through and cause strange crashes later. (LP: #1043143)
    - Refactors a little bit of the upgrade code and gets it under test to
      prepare to fix (LP: #1042537)
    - Updated AUTHORS from the full bzr log, and re-sort the list.
      (LP: #1042095)
    - Fixes FTBFS for kde4-window-decorator (LP: #1041310)
    - Fix obvious omissions from the introduction of unminimize_*,
      which were causing the unminimize animation settings to be ignored
      (LP: #1040455)
    - resize plugin: don't crash if resize wasn't initiated externally
      (LP: #1045191)
    - Clean up capitalization (LP: #1045652)
    - Avoid division by zero, if plugins try to deform a window down to size
      zero. (LP: #1045235)
    - Make "Unredirect Fullscreen Windows" more reliable. This fixes the
      problem with unredirection failing to engage at all (LP: #1041066) when
      gtk-window-decorator creates offscreen windows that are stacked on top.
      This also fixes the problem with unredirect hiding all windows,
      because it thinks the desktop window should be stacked on top
      (LP: #980663).
    - Ensure unredirected windows don't stay unredirected if they're no longer
      on top. (LP: #1041047)
    - Fix launching terminal functionality and make show-hud default key
      visible. Update the defaults to org.compiz.integrated to reflect the
      actual gnome values pre-gnome-3. (LP: #1040081) (LP: #1046199)
      (LP: #1046190)
    - Fix show-hud, bump COMPIZ_GNOME_INTEGRATED_SETTINGS_LIST_SIZE.
      (LP: #1046212)
    - Fixed: Windows with an alpha-channel, like gnome-terminal, were not
      being considered as possibly covering fullscreen windows. But they most
      certainly can. This ensures such RGBA windows are visible if they're
      stacked above a fullscreen window. (LP: #1046661)
    - Remove ListToStringList (LP: #1046184)
    - Fix typo causing CMake Error (LP: #1045665)
    - Transitions gtk-window-decorator over to use GSettings. Add a testing
      framework for the options code. (LP: #1042323)
    - Also need kdeworkspace since kdecorationbridge.h is there
      (LP: #1046770)
    - Implements some cleanup that was suggested on the merge for the original
      port to gsettings. Other issues fixed as wel...

Read more...

Changed in compiz (Ubuntu):
status: Triaged → Fix Released
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignq
removed: udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers