Changing "Composite > Detect Refresh Rate" is ignored initially

Bug #1027868 reported by Daniel van Vugt on 2012-07-23
128
This bug affects 27 people
Affects Status Importance Assigned to Milestone
Compiz
High
Christopher Townsend
compiz (Ubuntu)
High
Christopher Townsend

Bug Description

Changing settings in CCSM, it looks like disabling Composite > Detect Refresh Rate is initially ignored. That is, until I change the Refresh Rate also. Then the manual refresh rate finally takes effect.

Related branches

Changed in compiz:
milestone: 0.9.8.0 → 0.9.8.1
Changed in compiz:
milestone: 0.9.8.2 → 0.9.8.4
Changed in compiz:
milestone: 0.9.8.4 → 0.9.9.0
Changed in compiz:
milestone: 0.9.9.0 → 0.9.9.2

Same Problem here with Nvidia 313.18 / 310 on 13.04 ... Refresh Rate 50hz at reboot, Detect Displays off and manual set 60hz lost.

Changed in compiz:
status: New → Confirmed

Workaround:

Create a Script with the desired Refresh Rate and mark it as excutable and add it to startup Programs:

 #!/bin/bash
 sleep 5 &&
dconf write /org/compiz/profiles/UnityNeu/plugins/composite/refresh-rate "60"

Now i dont have to open CCSM after every restart and got my 60hz refresh-rate.

Changed in compiz:
milestone: 0.9.9.2 → 0.9.10.0
Changed in compiz:
assignee: Daniel van Vugt (vanvugt) → nobody
Øyvind Stegard (oyvinst) wrote :

Confirming with nvidia on 13.04. xrandr reports 60Hz refresh rate for the current resolution, but detection sets 50 (window dragging looks sluggist). Have to fiddle with settings "Detect .." and actual refresh rate value to get 60Hz. Seems to revert again after logout/login cycle.

J Ivany (jive-any) wrote :

I'm confirming this with nvidia drivers on the final release of 13.04, I've used the script work around above but how are newbs supposed to game on this OS if OpenGL performance is so degraded by default?

tags: added: opengl slow
tags: added: gl performance
removed: opengl
J Ivany (jive-any) wrote :

This is a show stopper and should be set to 120 by default as that would be a multiple 60, and 120hz is the native refresh rate of most new monitors.

J Ivany (jive-any) wrote :

please fix this before 13.04 is officially released

J Ivany (jive-any) wrote :

Actually Michael Beckers script doesn't work for me, I still have to set the refresh rate manually every reboot. PLEASE FIX THIS BUG.

Michael (starkpc) wrote :

try this:

dconf write /org/compiz/profiles/unity/plugins/composite/refresh-rate "60"

it works for me :)

@Michael: thank you
Also you should add an empty line after: #!/bin/bash

MC Return (mc-return) on 2013-06-24
Changed in compiz:
importance: Medium → High
Changed in compiz:
milestone: 0.9.10.0 → 0.9.10.2
MC Return (mc-return) on 2013-07-24
Changed in compiz:
milestone: 0.9.10.2 → 0.9.11.0

This bug needs to be forwarded upstream (https://wiki.ubuntu.com/Bugs/HowToTriage#Forwarding_upstream).

Havner (havner) wrote :

This is even more severe in 13.10 now.
The dconf script sets the refresh rate (visible in dconf-editor) but the compiz ignores it altogether. Window dragging is always sluggish.

Havner (havner) wrote :

Sorry, I take that back. Setting this after the launch is honored by compiz after all. Still, the bug itself still exists.

tags: added: saucy
gurqn (gurqn-home) on 2013-12-27
tags: added: trusty
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: ubuntu → compiz (Ubuntu)
Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in compiz (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Paulo Narciso (p-narciso) wrote :

Is this bug even being looked at? This is critical. Running at 50hz makes everything run laggy and stuttery. This worked in the past, so It's a regression. Please don't release 14.04 with this bug.

Changed in compiz (Ubuntu):
status: Confirmed → Triaged
Changed in compiz:
status: Confirmed → In Progress
Changed in compiz (Ubuntu):
status: Triaged → In Progress
Changed in compiz:
assignee: nobody → Christopher Townsend (townsend)
Changed in compiz (Ubuntu):
assignee: nobody → Christopher Townsend (townsend)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.11+14.04.20140409-0ubuntu1

---------------
compiz (1:0.9.11+14.04.20140409-0ubuntu1) trusty; urgency=low

  [ Chris Townsend ]
  * Add support to build kde4-window-decorator for KDE 4.10 and older.
    (LP: #1288953)
  * (LP: #1027868)
  * Allow binding of other buttons greater than button 7 for windows
    other than the desktop. (LP: #1304877)
 -- Ubuntu daily release <email address hidden> Wed, 09 Apr 2014 22:14:18 +0000

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) on 2014-04-10
Changed in compiz:
status: In Progress → Fix Committed
Stephen M. Webb (bregma) on 2014-11-06
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers