Incorrect detection of shader support on fglrx

Bug #1026920 reported by Daniel van Vugt on 2012-07-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz
Medium
Daniel van Vugt
fglrx
New
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Daniel van Vugt
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

On this system:

OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Radeon HD 5450
OpenGL version string: 4.2.11627 Compatibility Profile Context
OpenGL shading language version string: 4.20

the opengl plugin can't find all the extensions it needs to set GL::shaders==true. However I think based on the above information, it really should be able to support GLSL.

Related branches

Daniel van Vugt (vanvugt) wrote :
Daniel van Vugt (vanvugt) wrote :

Invalid. I found the problem is the fglrx driver itself. Which is apparently a very old problem with fglrx...

If your binary is named "compiz" then fglrx disables shader support, for apparently no good reason any more.

Changed in compiz:
status: Triaged → Invalid
assignee: Compiz Linaro Team (compiz-linaro-team) → Daniel van Vugt (vanvugt)
status: Invalid → Won't Fix
Daniel van Vugt (vanvugt) wrote :

Won't Fix. Because it's not compiz' fault, but the fault of fglrx.

That said, Ubuntu's compiz builds contain a workaround for this bug already.

summary: - [GLES] Suspected incorrect detection of shader support
+ [GLES] Incorrect detection of shader support on fglrx
Changed in compiz:
importance: High → Medium
status: Won't Fix → Triaged

Changed my mind again. Leave this bug triaged so at least there is a permanent searchable record of the problem.

Changed in fglrx-installer (Ubuntu):
status: New → Triaged
Changed in compiz (Ubuntu):
status: New → Fix Released
Sam Spilsbury (smspillaz) wrote :

Shall we backport the distro patch in the meantime?

Daniel van Vugt (vanvugt) wrote :

Yeah looks OK for trunk.

Changed in compiz:
assignee: Daniel van Vugt (vanvugt) → nobody
Changed in compiz:
milestone: 0.9.8.0 → 0.9.8.1
Changed in compiz:
milestone: 0.9.8.2 → 0.9.8.4
Changed in compiz:
milestone: 0.9.8.4 → 0.9.9.0
Daniel van Vugt (vanvugt) wrote :

AMD report this is now fixed upstream in the Catalyst driver. Not sure what version... Looks like maybe 12.9?...
http://support.amd.com/us/kbarticles/Pages/AMDCatalyst129betadriver.aspx

Changed in compiz:
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in compiz (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in compiz:
status: Triaged → In Progress
summary: - [GLES] Incorrect detection of shader support on fglrx
+ Incorrect detection of shader support on fglrx
Changed in compiz:
status: In Progress → Fix Committed
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments