crash in gtk-windows-decorator meta_get_button_position

Bug #1015593 reported by Alan Pope ๐Ÿบ๐Ÿง๐Ÿฑ ๐Ÿฆ„ on 2012-06-20
24
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Compiz
Critical
Sam Spilsbury
Compiz Core
Critical
Daniel van Vugt
compiz (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

[Test Case]
1. Open any window
2. Press alt
   -> Make sure the gtk-windows-decorator does not crash

[Regression Potential]
No obvious ones instead of breaking window decorations in overall.

Original description

Running latest compiz built by didrocks.. Pressed alt and gtk-windows-decorator broke..

Related branches

Changed in compiz:
milestone: none → 0.9.8.0
importance: Undecided → Critical
Changed in compiz:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz:
status: New → In Progress
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz at revision 3261

Changed in compiz:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (7.6 KiB)

This bug was fixed in the package compiz - 1:0.9.8+bzr3249-0ubuntu1

---------------
compiz (1:0.9.8+bzr3249-0ubuntu1) quantal-proposed; urgency=low

  * New upstream snapshot.
    - Fall back to a refresh rate that is more likely to look correct; 60Hz.
      (LP: #1009338)
    - Benchmark plugin should consume its key binding, and not pass the key to
      the underlying window. (LP: #1009320)
    - Avoid needless STL operations leading to expensive heap operations.
      (LP: #1006335)
    - Fix a typo that was causing (LP: #1002606)
      (widthIncBorders/heightIncBorders)
    - Check if the window is decorated before trying to change its event window
      states (which won't exist if not decorated) (LP: #1007754)
    - Use the XDamage extension more efficiently (the way it was designed to be
      used). This dramatically reduces CPU usage, reduces wakeups, and
      increases frame rates. It also solves at least one observed performance
      bug (LP: #1007299) and probably several more.
    - Avoid constructing and destructing lots of strings on every single event,
      which was wasting lots of CPU (LP: #1005569)
    - md LINGUAS doesn't exist, it's mnk (Mandinka in ISO 639-3)
    - Move grid plugin to google test and don't depend on the plugin for the
      test (LP: #1005009)
    - Don't read plugin.Initialized and test the value. (LP: #1004848)
    - libcompizconfig's install () commands were still using the old includedir
      and libdir variables rather than their libcompizconfig_* variants.
      (LP: #1005176)
    - Execute the cmake files separately to ensure that DESTDIR is respected.
      (LP: #1005177)
    - Don't set_target_properties on a target that might not exist
      (LP: #1005008)
    - Don't allow windows which we weren't even tracking as decoratable to
      become decorated if they try and change their hints. (LP: #963794)
    - Change the mouse pointer while dragging windows in expo. Just like the
      ubuntu branches do. (LP: #987647)
    - Fix uninitialized memory use (LP: #1004338)
    - Fix uninitialized variable (LP: #1004335)
    - Delay unbinding of pixmaps until then next rebind (LP: #729979)
      (LP: #1002602)
    - Don't drop plugins from the list to try and load before you've even tried
      to load them. Doing so makes missing plugins silently ignored instead of
      an error message (LP: #1002715). It also means valid plugins in more
      unusual, but real locations in LD_LIBRARY_PATH will never get loaded
      (LP: #1002721).
    - If running test cases under a real X server, we don't care if Xvfb is
      missing (LP: #994841)
    - Don't assume pkg_check_modules always sets _PREFIX (LP: #993608)
    - Don't clear selections in ~PrivateScreen because it causes a race between
      the existing and the new compiz instances, breaking --replace and
      non-replace behaviour. (LP: #988684) (LP: #989545)
    - Always paint with infiniteRegion as the clip region if the window is
      transformed and always use the supplied region if painting with offset or
      on transformed screen. (LP: #987639)
    - Add synchronization primitives to the decoration protocol so that there
      isn't a r...

Read more...

Changed in compiz (Ubuntu):
status: New → Fix Released
Changed in compiz-core:
status: New → Triaged
importance: Undecided → Critical
milestone: none → 0.9.7.10
Daniel van Vugt (vanvugt) wrote :

Fix committed to lp:compiz-core/0.9.7 at revision 3112.

Changed in compiz-core:
assignee: nobody → Daniel van Vugt (vanvugt)
status: Triaged → In Progress
status: In Progress → Fix Committed
Timo Jyrinki (timo-jyrinki) wrote :

12.04 LTS packages for testing at https://launchpad.net/~timo-jyrinki/+archive/compiz-precise-sru - seems to fix the issue for me compared to the earlier SRU attempt (1.1).

Tested with Timo's PPA and I can't reproduce the problem on either amd64 or i386 systems. Seems fixed.

description: updated

Hello Alan, or anyone else affected,

Accepted compiz into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/compiz/1:0.9.7.8-0ubuntu1.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in compiz (Ubuntu Precise):
importance: Undecided → High
Changed in compiz (Ubuntu):
importance: Undecided → High
Changed in compiz (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Miklos Juhasz (mjuhasz) wrote :

Using the latest proposed package Alt works as expected. No crash.

tags: added: verification-done
removed: verification-needed
Adam Conrad (adconrad) wrote :

Hello Alan, or anyone else affected,

Accepted compiz into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/compiz/1:0.9.7.8-0ubuntu1.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Timo Jyrinki (timo-jyrinki) wrote :

Alt still doesn't crash in 1.4 (and nothing affecting x86 builds was changed from 1.3).

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.7.8-0ubuntu1.4

---------------
compiz (1:0.9.7.8-0ubuntu1.4) precise-proposed; urgency=low

  [ Steve Langasek ]
  * debian/patches/compiz-package-gles2.patch: refresh to account for
    fix_1012956.patch, which introduces non-GLES2 objects that need to be
    patched back out for ARM. LP: #1032902.

compiz (1:0.9.7.8-0ubuntu1.3) precise-proposed; urgency=low

  [ ลukasz 'sil2100' Zemczak ]
  * Cherry-pick upstream patches:
    - CMake Error at FindCompiz.cmake:84 (include): include could not find load
      file: CompizDefaults (LP: #993608)
    - compiz (decor) - Warn: failed to bind pixmap to texture (LP: #929989)
    - gtk-window-decorator crashed with SIGFPE in
      _decor_blend_horz_border_picture() (LP: #963794)
    - [callgrind] compiz spends ~25% of its time constructing/destructing
      strings in PrivateScreen::handleActionEvent (LP: #1005569)
    - gtk-window-decorator crashed with SIGSEGV in meta_get_decoration_geometry
      (LP: #1007754)
    - composite refresh rate falls back to 50Hz, which is wrong in most cases
      (LP: #1009338)
    - [callgrind] compiz spends ~7% of its time inserting into and destructing
      the events list in PrivateScreen::processEvents() (LP: #1006335)
    - It is possible for a dock shadow to be painted even if the dock window
      isn't painted (LP: #1012956)

  [ Timo Jyrinki ]
  * Cherry-pick upstream patches:
    - gtk-window-decorator crashes with BadWindow (invalid Window parameter),
      from XGetWindowProperty() from get_frame_type() (LP: #1019337)
    - Fix gtk-window-decorator crash in meta_get_button_position
      (LP: #1015593)
    - Fix crash LP: #1019337 properly this time. The original fix did not
      handle the case where (win != NULL && xid != None && !valid_window(xid))
      so would still exit with an X error. Now we trap and handle such errors
      gracefully, instead of hitting the default handler which kills
      gtk-window-decorator.
 -- Timo Jyrinki <email address hidden> Tue, 07 Aug 2012 12:32:27 +0300

Changed in compiz (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in compiz:
status: Fix Committed → Fix Released
Changed in compiz-core:
status: Fix Committed → Fix Released
Changed in compiz-core:
status: Fix Released → Fix Committed
TonyR (rooneyo) wrote :

Hello

I have this crash every time I log in to Mythbuntu 12.04.1. I can ignore the error however if I start the MythTV frontend the error appears multiple times. where can I get a patch to fix tjis as it appears to be resolved from the bug report. My system is fully updated however I still experience the problem. What do I do to fix?

Daniel van Vugt (vanvugt) wrote :

TonyR,

The fix is queued for release in compiz 0.9.7.10 for 12.04. However I am not aware of any confirmed schedule for when that will be.

Changed in compiz-core:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments