[nvidia] switcher+nvidia: Alt+Tab makes compiz hang and shows white preview windows

Bug #1006216 reported by Daniel van Vugt on 2012-05-30
28
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Compiz
High
Compiz Linaro Team
compiz (Ubuntu)
High
Unassigned

Bug Description

Using the switcher plugin with nvidia-current-updates (295.49) causes the display to freeze and/or white windows (and icons) to appear in the switcher window.

This doesn't happen if I use the nouveau driver with the same hardware.

Daniel van Vugt (vanvugt) wrote :

Oh dear. The problem isn't just upstream. I can reproduce it on precise, with compiz 1:0.9.7.8-0ubuntu1.

Changed in compiz (Ubuntu):
importance: Undecided → High
summary: - [nvidia] switcher+nvidia: Alt+Tab makes compiz hang ~20sec and shows
- white preview windows
+ [nvidia] switcher+nvidia: Alt+Tab makes compiz hang and shows white
+ preview windows
Changed in compiz:
assignee: nobody → Sam Spilsbury (smspillaz)
Daniel van Vugt (vanvugt) wrote :

I have a hunch that this hang is a feedback loop caused by the XCreateWindow that switcher does. Perhaps drawing that X window is creating damage, which then feeds back into compiz and causes it to be redrawn in a positive feedback loop.

Daniel van Vugt (vanvugt) wrote :

I must remember to assign bugs to myself when I already have ideas of how to fix them :)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Karol Bryd (karolbe) wrote :

I am *really* waiting for the fix. This is the bug which is keeping me from upgrading from 11.04 :(

I am buying (through Paypal) 12-pack of beer, let say Heineken, to the first person who will fix this bug. Anyone? :)

Daniel van Vugt (vanvugt) wrote :

Karol, I believe this bug is caused by the compiz mipmapping code. So you should be able to work around it by:

1. Install compizconfig-settings-manager
2. Run ccsm
3. CCSM > Window Management > Application Switcher > General > Mipmap = OFF

Omer Akram (om26er) on 2012-08-05
Changed in compiz:
status: New → Confirmed
Changed in compiz:
milestone: 0.9.8.0 → 0.9.8.1
Daniel van Vugt (vanvugt) wrote :

This appears to have been fixed recently. I think it was the gles2 merge that did it (lp:compiz r3320).

Changed in compiz:
milestone: 0.9.8.2 → none
status: Confirmed → Fix Released
assignee: Sam Spilsbury (smspillaz) → Compiz Linaro Team (compiz-linaro-team)
Changed in compiz:
milestone: none → 0.9.8.0
Daniel van Vugt (vanvugt) wrote :

It would seem...

This bug was fixed in the package compiz - 1:0.9.8.0-0ubuntu1

---------------
compiz (1:0.9.8.0-0ubuntu1) quantal-proposed; urgency=low

  * debian/control, debian/rules:
    - enable gles on armel and armhf
    - use dh-translations rather than custom code

  [ Sam Spilsbury ]
  * Enable OpenGL ES building
    - Refresh debian/patches/workaround_broken_drivers.patch
    - Remove non-ported plugins from compiz-plugins
    - Add FindOpenGLES2.cmake to compiz-dev

  [ Timo Jyrinki ]
  * New upstream release.
    - Code to make compiz work on GLES. This includes several changes
      to the compiz API. (LP: #201342) (LP: #901097) (LP: #1004251)
      (LP: #1037710)
    - Draft first 0.9.8.0 NEWS and bump VERSION
  * debian/patches/compiz-package-gles2.patch:
    - Remove, obsoleted by the upstream GLES work
  * Disable plugins that don't work on pure GLES on armhf/armel:
    - bench, firepaint, mblur, showmouse, splash, showrepaint, td, widget
 -- Sebastien Bacher <email address hidden> Fri, 31 Aug 2012 22:59:50 +0200

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers