[0.9.8 r3110 regression] 2nd un-maxed window often opens overlapping adjacent workspace

Bug #1002606 reported by Doug McMahon on 2012-05-22
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Compiz
Medium
Sam Spilsbury
compiz (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

easiest way to see here is to open nautilus, then a terminal from ws 1. The terminal will go 1 px into ws 2. Moving to ws 2 & clicking on the terminal icon in launcher will not switch back to ws 1 , screen attached
seen on both 32 & 64 bit installs with nvidia-current
Dell 1330m, 8400m GS

Related branches

Doug McMahon (mc3man) on 2012-05-22
summary: - [0.9.8 r3110 regression] 2nd un-maxed window often opens by 1 px in an
+ [0.9.8 r3110 regression] 2nd un-maxed window often opens with 1 px in an
adjacent workspace
Changed in compiz:
milestone: none → 0.9.8.0
importance: Undecided → Low

a better screen in case others come by
In this case nautilus was opened 2nd on ws 1. Screen is from ws2, note that nautilus shows 2 arrows & there is a 1px white line to the left on the launcher - that is the right edge of the nautilus window

Sam Spilsbury (smspillaz) wrote :

Thanks, assigned.

Changed in compiz:
assignee: nobody → Sam Spilsbury (smspillaz)
Doug McMahon (mc3man) wrote :

At least here the 1 px spill over is caused by place.so (as built by the prepro ppa or here using 0.9.7.8 patched with 04/11 diff

So while of no value to anyone but probably me, 0.9.7.8 patched with 04/11 diff & the standard place.so in ~/.compiz1/plugins give me a decent cube/rotate/expo flash fix without spill over with nvidia until this is squared up in general & nvidia specific as far the white windows

Daniel van Vugt (vanvugt) wrote :

Increased importance, because we now have a duplicate showing the misplacement of windows can be more than just 1px.

summary: - [0.9.8 r3110 regression] 2nd un-maxed window often opens with 1 px in an
+ [0.9.8 r3110 regression] 2nd un-maxed window often opens overlapping
adjacent workspace
Changed in compiz:
importance: Low → Medium
status: New → Confirmed
Doug McMahon (mc3man) wrote :

There is another somewhat obscure window placement issue, likely not related in cause?, but could benefit from a solution that prevents any window from opening off the Ws.
Can be seen in jedit, each time it opens it drops 28px from previous, depending on orig vertical size can quickly leave at the bottom of Ws

Daniel van Vugt (vanvugt) wrote :

Hmm, 28px happens to be the default top frame extent with the Ambiance theme.

Doug McMahon (mc3man) wrote :

jedit/compiz issue has probably been happening for a while, several users I've heard from were former gnome-panel users where the bottom panel would either initially or quickly block any further drop

Just to further mention from the benefit perspective of something containing any window - I've noticed on new installs a couple of windows always open off the Ws by default, usually the bottom.
Thunderbird comes to mind as one I always have to resize by manually moving up to get at the bottom edge/corner

Changed in compiz:
status: Confirmed → In Progress
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz at revision 3242

Changed in compiz:
status: In Progress → Fix Committed
Sebastien Bacher (seb128) wrote :

(seems it's not affecting the current precise version in fact)

Changed in compiz (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in compiz (Ubuntu Precise):
importance: Undecided → Low
status: New → Triaged
milestone: none → ubuntu-12.04.1
milestone: ubuntu-12.04.1 → none
status: Triaged → Invalid
no longer affects: compiz (Ubuntu)
no longer affects: compiz (Ubuntu Precise)
tags: added: compiz-r3110-regression
Launchpad Janitor (janitor) wrote :
Download full text (7.6 KiB)

This bug was fixed in the package compiz - 1:0.9.8+bzr3249-0ubuntu1

---------------
compiz (1:0.9.8+bzr3249-0ubuntu1) quantal-proposed; urgency=low

  * New upstream snapshot.
    - Fall back to a refresh rate that is more likely to look correct; 60Hz.
      (LP: #1009338)
    - Benchmark plugin should consume its key binding, and not pass the key to
      the underlying window. (LP: #1009320)
    - Avoid needless STL operations leading to expensive heap operations.
      (LP: #1006335)
    - Fix a typo that was causing (LP: #1002606)
      (widthIncBorders/heightIncBorders)
    - Check if the window is decorated before trying to change its event window
      states (which won't exist if not decorated) (LP: #1007754)
    - Use the XDamage extension more efficiently (the way it was designed to be
      used). This dramatically reduces CPU usage, reduces wakeups, and
      increases frame rates. It also solves at least one observed performance
      bug (LP: #1007299) and probably several more.
    - Avoid constructing and destructing lots of strings on every single event,
      which was wasting lots of CPU (LP: #1005569)
    - md LINGUAS doesn't exist, it's mnk (Mandinka in ISO 639-3)
    - Move grid plugin to google test and don't depend on the plugin for the
      test (LP: #1005009)
    - Don't read plugin.Initialized and test the value. (LP: #1004848)
    - libcompizconfig's install () commands were still using the old includedir
      and libdir variables rather than their libcompizconfig_* variants.
      (LP: #1005176)
    - Execute the cmake files separately to ensure that DESTDIR is respected.
      (LP: #1005177)
    - Don't set_target_properties on a target that might not exist
      (LP: #1005008)
    - Don't allow windows which we weren't even tracking as decoratable to
      become decorated if they try and change their hints. (LP: #963794)
    - Change the mouse pointer while dragging windows in expo. Just like the
      ubuntu branches do. (LP: #987647)
    - Fix uninitialized memory use (LP: #1004338)
    - Fix uninitialized variable (LP: #1004335)
    - Delay unbinding of pixmaps until then next rebind (LP: #729979)
      (LP: #1002602)
    - Don't drop plugins from the list to try and load before you've even tried
      to load them. Doing so makes missing plugins silently ignored instead of
      an error message (LP: #1002715). It also means valid plugins in more
      unusual, but real locations in LD_LIBRARY_PATH will never get loaded
      (LP: #1002721).
    - If running test cases under a real X server, we don't care if Xvfb is
      missing (LP: #994841)
    - Don't assume pkg_check_modules always sets _PREFIX (LP: #993608)
    - Don't clear selections in ~PrivateScreen because it causes a race between
      the existing and the new compiz instances, breaking --replace and
      non-replace behaviour. (LP: #988684) (LP: #989545)
    - Always paint with infiniteRegion as the clip region if the window is
      transformed and always use the supplied region if painting with offset or
      on transformed screen. (LP: #987639)
    - Add synchronization primitives to the decoration protocol so that there
      isn't a r...

Read more...

Changed in compiz (Ubuntu):
status: New → Fix Released
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers