When dragging a window to the top of the screen and then back down again without releasing the cursor position can become offset

Bug #872177 reported by Sam Spilsbury on 2011-10-11
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Compiz Snapping Windows Plugin
Medium
Sam Spilsbury
compiz-plugins-main (Ubuntu)
Undecided
Sam Spilsbury

Bug Description

1. Drag a window to the top of the screen using the titlebar
2. Drag down really fast
3. The cursor is now detached from the titlebar

Related branches

Changed in compiz-snap-plugin:
status: New → In Progress
Changed in unity:
status: New → In Progress
Changed in compiz-plugins-main (Ubuntu):
status: New → In Progress
Changed in compiz-snap-plugin:
importance: Undecided → Medium
Changed in unity:
importance: Undecided → Low
Changed in compiz-snap-plugin:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz-plugins-main (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz-snap-plugin:
milestone: none → 0.9.6
Changed in unity:
milestone: none → 4.26.0
Changed in compiz-snap-plugin:
status: In Progress → Fix Committed
Changed in unity:
status: In Progress → Fix Committed
Changed in compiz-plugins-main (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-10-25
Changed in unity (Ubuntu):
status: New → Fix Committed
Omer Akram (om26er) on 2012-06-05
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity:
milestone: 4.26.0 → none
Daniel van Vugt (vanvugt) wrote :

Confirmed compiz_snap_plugin.fix_872177 was merged into precise. However the change is dead code which does nothing. I know this because it was causing compiler warnings for that reason, so the change was completely removed in the 0.9.8 branch recently.

no longer affects: unity
no longer affects: unity (Ubuntu)
Changed in compiz-snap-plugin:
status: Fix Committed → Confirmed
Changed in compiz-plugins-main (Ubuntu):
status: Fix Committed → Confirmed
Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 201681, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers