snap movements can cause infinite loops in window movements

Bug #860646 reported by Sam Spilsbury on 2011-09-27
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz Snapping Windows Plugin
High
Sam Spilsbury
compiz-plugins-main (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

Windows remain frozen on screen because we can't accurately ignore our own movements anymore

1. Semi maximize a window
2. Drag it across the screen
3. You shouldn't see jumping when dragging the window

Changed in compiz-snap-plugin:
status: New → In Progress
assignee: nobody → Sam Spilsbury (smspillaz)
importance: Undecided → High
milestone: none → 0.9.6
Didier Roche (didrocks) on 2011-09-28
Changed in compiz-snap-plugin:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-plugins-main - 1:0.9.6-0ubuntu1

---------------
compiz-plugins-main (1:0.9.6-0ubuntu1) oneiric; urgency=low

  * New upstream release:
    - Maximizing a window causes compiz to hang (LP: #860257)
    - snap movements can cause infinite loops in window movements (LP: #860646)
  * Remove debian/patches/01_fix_ghost_windows.patch which is part of the new
    upstream release
  * debian/control:
    - fix overwrite with natty compiz-plugins (LP: #859632)
 -- Didier Roche <email address hidden> Wed, 28 Sep 2011 14:20:00 +0200

Changed in compiz-plugins-main (Ubuntu):
status: New → Fix Released

Hello Sam, or anyone else affected,

Accepted compiz-plugins-main into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in compiz-plugins-main (Ubuntu Oneiric):
status: Fix Released → Fix Committed
tags: added: verification-needed
Ngassam Nkwenga (cyrildz) wrote :

Hey Sam, could you describe a way to observe this issue ?

I have the Snap plugin enable ( I use actually the wobbling window plugin ) and I can not see any frozen.

Ngassam Nkwenga (cyrildz) wrote :

I'm on the proposed repository

description: updated
eric (obrowny06) wrote :

If it is that kind of behaviour (video attached) that you are targetting, yes it happened to me yesterday with the new compiz. I am not able to reproduce it today. I will try again to find how to reproduce.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-plugins-main - 1:0.9.6-0ubuntu4

---------------
compiz-plugins-main (1:0.9.6-0ubuntu4) oneiric-proposed; urgency=low

  * debian/patches/fix-872161.patch:
    - When grabbing a window to demaximize it after dragging it up,
      sometimes the position will not be where you expect it to be
      (LP: #872161)

compiz-plugins-main (1:0.9.6-0ubuntu3) oneiric-proposed; urgency=low

  * Cherry-pick upstream fixes:
    - unmaximizable windows still show orange glow but fail to maximize
      (LP: #827560)
    - compiz crashed with SIGSEGV in CompWindow::serverBorderRect()
      (LP: #834585)
    - Workspace switcher makes windows lose decorations (LP: #853951)
    - Windows get corrupted sometimes when semi-maximizing them (LP: #865177)
    - Windows like gnome-terminal have awkward space around them after being
      semi-maximized (LP: #865179)
    - Grid plugin behaviour random (LP: #862260)
    - Don't apply snapping to maximized windows (LP: #862261)
    - snap movements can cause infinite loops in window movements (LP: #860646)
    - it is possible to see a window in it's pre-animation state during unmap
      animations (LP: #864476)
    - Rendering glitches when resuming from expo mode (LP: #868121)
 -- Didier Roche <email address hidden> Wed, 12 Oct 2011 10:49:59 +0200

Changed in compiz-plugins-main (Ubuntu):
status: Fix Committed → Fix Released
Changed in compiz-plugins-main (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments