Mouse pointer doesn't change when dragging windows in expo

Bug #987647 reported by Daniel van Vugt on 2012-04-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz
Low
Daniel van Vugt
Compiz Expo Plugin
Low
Daniel van Vugt
Compiz Main Plugins
Low
Daniel van Vugt
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Mouse pointer no longer changes when dragging windows in expo.

Was this intentional? I know the expo code in ubuntu is quite different to upstream, but the mouse pointer behaviour should be the same. I'm not totally sure if and when this regressed upstream.

Changed in compiz-core:
status: Triaged → New
Changed in compiz-plugins-main:
milestone: none → 0.9.7.2
Daniel van Vugt (vanvugt) wrote :

OK, it's not a regression. Seems the feature was never implemented upstream. That's all.

Changed in compiz-expo-plugin:
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in compiz-plugins-main:
assignee: nobody → Daniel van Vugt (vanvugt)
no longer affects: compiz-core
summary: - [regression] Mouse pointer no longer changes when dragging windows in
- expo
+ Mouse pointer doesn't change when dragging windows in expo
Changed in compiz-expo-plugin:
status: New → In Progress
importance: Undecided → Low
Changed in compiz-plugins-main:
status: New → In Progress
importance: Undecided → Low
Daniel van Vugt (vanvugt) wrote :

Bazaar is not letting me merge this into lp:compiz-expo-plugin right now:

bzr: ERROR: Cannot lock LockDir(chroot-80817552:///%2Bbranch/compiz-expo-plugin/.bzr/branch/lock): Transport operation not possible: readonly transport

But I have merged it into lp:compiz-plugins-main at revision 29.

Changed in compiz-plugins-main:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix released in Compiz Main Plugins 0.9.7.2

Changed in compiz-plugins-main:
status: Fix Committed → Fix Released
Changed in compiz:
assignee: nobody → Daniel van Vugt (vanvugt)
importance: Undecided → Low
status: New → In Progress
Daniel van Vugt (vanvugt) wrote :

Fix committed to lp:compiz at revision 3226.

Changed in compiz:
status: In Progress → Fix Committed
milestone: none → 0.9.8.0

The mouse point never DID change, nor should it, IMHO. Why would you want the pointer to change when moving a window in expo?

If this feature-request (not bug) is ever implemented, please don't enable it by default, or keep a checkbox to disable this rather odd behaviour.

Daniel van Vugt (vanvugt) wrote :

This change has already been committed to the next release 0.9.8.

It is only designed to reflect the existing behaviour already present in the Ubuntu branch of compiz. However I partially agree -- if you're double clicking in expo then the pointer shouldn't change. It should only change if you start moving a window. But the move plugin suffers from the same kind of problem (changing the mouse pointer when it probably shouldn't). I have opened bug 1011084 to cover this.

If you want any different behaviour like making it configurable then please log a new bug for that.

Daniel van Vugt (vanvugt) wrote :

Won't Fix in lp:compiz-expo-plugin because the branch is corrupt. Also, it has been replaced by lp:compiz where the fix for this bug is committed already.

Changed in compiz-expo-plugin:
status: In Progress → Won't Fix
Launchpad Janitor (janitor) wrote :
Download full text (7.6 KiB)

This bug was fixed in the package compiz - 1:0.9.8+bzr3249-0ubuntu1

---------------
compiz (1:0.9.8+bzr3249-0ubuntu1) quantal-proposed; urgency=low

  * New upstream snapshot.
    - Fall back to a refresh rate that is more likely to look correct; 60Hz.
      (LP: #1009338)
    - Benchmark plugin should consume its key binding, and not pass the key to
      the underlying window. (LP: #1009320)
    - Avoid needless STL operations leading to expensive heap operations.
      (LP: #1006335)
    - Fix a typo that was causing (LP: #1002606)
      (widthIncBorders/heightIncBorders)
    - Check if the window is decorated before trying to change its event window
      states (which won't exist if not decorated) (LP: #1007754)
    - Use the XDamage extension more efficiently (the way it was designed to be
      used). This dramatically reduces CPU usage, reduces wakeups, and
      increases frame rates. It also solves at least one observed performance
      bug (LP: #1007299) and probably several more.
    - Avoid constructing and destructing lots of strings on every single event,
      which was wasting lots of CPU (LP: #1005569)
    - md LINGUAS doesn't exist, it's mnk (Mandinka in ISO 639-3)
    - Move grid plugin to google test and don't depend on the plugin for the
      test (LP: #1005009)
    - Don't read plugin.Initialized and test the value. (LP: #1004848)
    - libcompizconfig's install () commands were still using the old includedir
      and libdir variables rather than their libcompizconfig_* variants.
      (LP: #1005176)
    - Execute the cmake files separately to ensure that DESTDIR is respected.
      (LP: #1005177)
    - Don't set_target_properties on a target that might not exist
      (LP: #1005008)
    - Don't allow windows which we weren't even tracking as decoratable to
      become decorated if they try and change their hints. (LP: #963794)
    - Change the mouse pointer while dragging windows in expo. Just like the
      ubuntu branches do. (LP: #987647)
    - Fix uninitialized memory use (LP: #1004338)
    - Fix uninitialized variable (LP: #1004335)
    - Delay unbinding of pixmaps until then next rebind (LP: #729979)
      (LP: #1002602)
    - Don't drop plugins from the list to try and load before you've even tried
      to load them. Doing so makes missing plugins silently ignored instead of
      an error message (LP: #1002715). It also means valid plugins in more
      unusual, but real locations in LD_LIBRARY_PATH will never get loaded
      (LP: #1002721).
    - If running test cases under a real X server, we don't care if Xvfb is
      missing (LP: #994841)
    - Don't assume pkg_check_modules always sets _PREFIX (LP: #993608)
    - Don't clear selections in ~PrivateScreen because it causes a race between
      the existing and the new compiz instances, breaking --replace and
      non-replace behaviour. (LP: #988684) (LP: #989545)
    - Always paint with infiniteRegion as the clip region if the window is
      transformed and always use the supplied region if painting with offset or
      on transformed screen. (LP: #987639)
    - Add synchronization primitives to the decoration protocol so that there
      isn't a r...

Read more...

Changed in compiz (Ubuntu):
status: New → Fix Released
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers