right-click crashes graphical environment

Bug #954079 reported by Ricardo J. Moreira Teixeira on 2012-03-13
160
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Compiz Main Plugins
High
Łukasz Zemczak
Compiz Shift Switcher Plugin
Fix Committed
High
Unassigned
compiz-plugins-main (Ubuntu)
High
Łukasz Zemczak

Bug Description

When i right-click, on any app it crashes the GUI
---
.tmp.unity.support.test.0:

ApportVersion: 1.94.1-0ubuntu2
Architecture: i386
CompizPlugins: [core,composite,opengl,decor,compiztoolbox,move,dbus,mousepoll,grid,resize,shift,place,gnomecompat,regex,wobbly,session,vpswitch,imgpng,blur,animation,fade,workarounds,cube,rotate,scale,expo,unitymtgrabhandles,unityshell]
CompositorRunning: compiz
DistUpgraded: Log time: 2012-02-28 12:06:54.300615
DistroCodename: precise
DistroRelease: Ubuntu 12.04
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Elitegroup Computer Systems Device [1019:9959]
   Subsystem: Elitegroup Computer Systems Device [1019:9959]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
Package: unity 5.6.0-0ubuntu3
PackageArchitecture: i386
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-18-generic-pae root=UUID=35b26662-ff31-495a-8d87-8ab507f5064d ro vga=792 splash quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic-pae 3.2.9
Tags: precise precise precise precise ubuntu reproducible compiz-0.9
Uname: Linux 3.2.0-18-generic-pae i686
UpgradeStatus: Upgraded to precise on 2012-03-13 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 09/30/2009
dmi.bios.vendor: Phoenix
dmi.bios.version: 1.04JPSA
dmi.board.asset.tag: Tag 12345
dmi.chassis.type: 10
dmi.modalias: dmi:bvnPhoenix:bvr1.04JPSA:bd09/30/2009:svn:pn:pvr:rvn:rn:rvr:cvn:ct10:cvr:
version.compiz: compiz 1:0.9.7.0+bzr3035-0ubuntu1
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.1-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.1-0ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Fabio Marconi (fabiomarconi) wrote :

Please attach here using the button below 'Add attachment or patch' the files:
/var/log/syslog
/var/log/kern.log
/var/log/Xorg.0.log.old
Thanks
fabio
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in ubuntu:
status: New → Incomplete
Fabio Marconi (fabiomarconi) wrote :

Nothing logged in the attached files.
Can you reproduce this bug only clicking on the unity launcher or on the desktop too?
Does it happens in unity 2D too ?
Thanks
fabio

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in ubuntu:
status: Incomplete → New
status: New → Incomplete

Yes, it also happens when I right-click the unity launcher and the desktop.
It doesn't happen in the unity 2d.

Thanks,
Ricardo.

Fabio Marconi (fabiomarconi) wrote :

ok, thatnks
can you please reproduce the bgu then run in a terminal
apport-collect 954079
Thanks
Fabio
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

affects: ubuntu → compiz (Ubuntu)
Changed in compiz (Ubuntu):
status: Incomplete → New
status: New → Incomplete

apport information

tags: added: apport-collected compiz-0.9 precise reproducible ubuntu
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in compiz (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Jelle Foks (jellefoks) wrote :

As I mentioned in #954793, I had that problem and it went away when I turned off the shift switcher in ccsm. Maybe it will help here (that one is marked as a duplicate of this one).

Sebastien Bacher (seb128) wrote :

there are quite some bugs about that recently which get dupped from bug #808007

Sebastien Bacher (seb128) wrote :

stacktrace on the current precise version: https://launchpadlibrarian.net/96773768/Stacktrace.txt

Johnny Rivera (johnnyrivera) wrote :

I came here from the other bug also relating to right-clicking (on Unity to be precise in my case). I can also confirm that disabling the "shift switcher" in ccsm fixed the problem for me. Right-click functionality works, and there are fewer crashes.

Also in my case, disabling the shift switcher in ccsm, resolved the crashes.

Łukasz Zemczak (sil2100) wrote :

For now I can see that compiz button bindings are probably at fault here (since the shift plugin by default sets a button binding to the Terminate action).

Changed in compiz (Ubuntu):
assignee: nobody → Łukasz Zemczak (sil2100)
Changed in compiz-plugins-main:
status: New → In Progress
assignee: nobody → Łukasz Zemczak (sil2100)
Changed in compiz (Ubuntu):
status: Confirmed → Invalid
Changed in compiz (Ubuntu):
assignee: Łukasz Zemczak (sil2100) → nobody
Changed in compiz-plugins-main (Ubuntu):
status: New → Confirmed
Changed in compiz-plugins-main:
status: In Progress → Fix Committed
Changed in compiz-plugins-main (Ubuntu):
assignee: nobody → Łukasz Zemczak (sil2100)
status: Confirmed → In Progress
Changed in compiz-shift-plugin:
assignee: nobody → Łukasz Zemczak (sil2100)
status: New → Triaged
Omer Akram (om26er) on 2012-03-17
no longer affects: compiz (Ubuntu)
Changed in compiz-plugins-main (Ubuntu):
status: In Progress → Fix Committed
Changed in compiz-plugins-main:
importance: Undecided → High
Changed in compiz-plugins-main (Ubuntu):
importance: Undecided → High
Changed in compiz-plugins-main:
milestone: none → 0.9.7.2
Changed in compiz-shift-plugin:
status: Triaged → Fix Committed
importance: Undecided → High
Al Stone (ahs3) wrote :

I see the "fix committed" but I don't see the change in any package yet; any idea when it might be available for an actual update? This bug is incredibly annoying. I had no idea how often I used right click.

Łukasz Zemczak (sil2100) wrote :

The package with the fix included should be available soon. In the meantime you can work-around the problem by disabling the 'shift switcher' plugin using ccsm - or, if you need the shift plugin, just disable the Terminate switcher mouse shortcut in ccsm in the plugin's settings.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-plugins-main - 1:0.9.7.0~bzr19-0ubuntu7

---------------
compiz-plugins-main (1:0.9.7.0~bzr19-0ubuntu7) precise-proposed; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * debian/patches/shift_954079.patch:
    - cherry picked the shift plugin patch for fixing an issue with compiz crashes
      on right-click. This removes an unused option in the plugin. (LP: #954079)
  * debian/patches/fix_broken_build.patch:
    - fixes the build with the newer compiz
  * debian/patches/vpswitch_953834.patch:
    - don't pass through keystrokes you are using to the active window (LP: #953834)

  [ Didier Roche ]
  * debian/control:
    - bump compiz-dev and libcompizconfig0-dev build-dep for ABI break
  * debian/patches/fix_930192.patch:
    - Animations of large or full-screen windows skip frames (not smooth) (LP: #930192)
 -- Didier Roche <email address hidden> Wed, 21 Mar 2012 11:46:41 +0100

Changed in compiz-plugins-main (Ubuntu):
status: Fix Committed → Fix Released
Changed in compiz-plugins-main:
status: Fix Committed → Fix Released
Changed in compiz-plugins-main:
status: Fix Released → Fix Committed
Changed in compiz-plugins-main (Ubuntu):
milestone: none → ubuntu-12.04
Daniel van Vugt (vanvugt) wrote :

Fix released in Compiz Main Plugins 0.9.7.2

Changed in compiz-plugins-main:
status: Fix Committed → Fix Released
Changed in compiz-shift-plugin:
assignee: Łukasz Zemczak (sil2100) → nobody
To post a comment you must log in.