Rendering glitches when resuming from expo mode

Bug #868121 reported by Sam Spilsbury on 2011-10-05
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Compiz Main Plugins
High
Unassigned
Unity
Fix Released
High
Sam Spilsbury
compiz-plugins-main (Ubuntu)
Undecided
Sam Spilsbury
Oneiric
Undecided
Sam Spilsbury
unity (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

When resuming from expo mode, sometimes a glitch is visible where windows on one monitor appear on the other, or maximized windows disappear, but only for one frame.

Related branches

Changed in compiz-plugins-main (Ubuntu):
status: New → In Progress
Changed in unity:
status: New → In Progress
Changed in compiz-expo-plugin:
status: New → In Progress
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz-plugins-main (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity:
milestone: none → 4.24.0
Changed in compiz-expo-plugin:
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Changed in compiz-expo-plugin:
status: In Progress → Fix Committed
Changed in compiz-plugins-main (Ubuntu):
status: In Progress → Fix Committed
Changed in unity:
status: In Progress → Fix Committed
Michael Uvarov (freeakk) wrote :

Also after returning I get windows are invisible. When I try to move mouse, updated elements in the windows stay visible, but not full window.
This bug is a regression, there was no this bug in 11.04.
I think it was appear with opportunity to hide windows when you move other windows in expo mode.

Also after returning windows are still in expo mode: they are stoned and only hiding to the panel and expanding them back helps.

Michael Uvarov (freeakk) wrote :

And this bug is not only in Unity, but also in any DE with Compiz.

Hello Sam, or anyone else affected,

Accepted compiz-plugins-main into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Ngassam Nkwenga (cyrildz) wrote :

Is this a proper bug for dual-monitors users ?
I have all good here with a single Monitor.

Proposed repos activated

Didier Roche (didrocks) on 2011-10-14
Changed in compiz-expo-plugin:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-10-17
Changed in unity (Ubuntu):
status: New → Fix Released
Changed in unity (Ubuntu Oneiric):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-plugins-main - 1:0.9.6-0ubuntu4

---------------
compiz-plugins-main (1:0.9.6-0ubuntu4) oneiric-proposed; urgency=low

  * debian/patches/fix-872161.patch:
    - When grabbing a window to demaximize it after dragging it up,
      sometimes the position will not be where you expect it to be
      (LP: #872161)

compiz-plugins-main (1:0.9.6-0ubuntu3) oneiric-proposed; urgency=low

  * Cherry-pick upstream fixes:
    - unmaximizable windows still show orange glow but fail to maximize
      (LP: #827560)
    - compiz crashed with SIGSEGV in CompWindow::serverBorderRect()
      (LP: #834585)
    - Workspace switcher makes windows lose decorations (LP: #853951)
    - Windows get corrupted sometimes when semi-maximizing them (LP: #865177)
    - Windows like gnome-terminal have awkward space around them after being
      semi-maximized (LP: #865179)
    - Grid plugin behaviour random (LP: #862260)
    - Don't apply snapping to maximized windows (LP: #862261)
    - snap movements can cause infinite loops in window movements (LP: #860646)
    - it is possible to see a window in it's pre-animation state during unmap
      animations (LP: #864476)
    - Rendering glitches when resuming from expo mode (LP: #868121)
 -- Didier Roche <email address hidden> Wed, 12 Oct 2011 10:49:59 +0200

Changed in compiz-plugins-main (Ubuntu):
status: Fix Committed → Fix Released
Changed in compiz-plugins-main (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

Looks like this fix is missing upstream. Was only merged into an oneiric branch.

Changed in compiz-expo-plugin:
status: Fix Released → Triaged
Changed in compiz-expo-plugin:
assignee: Sam Spilsbury (smspillaz) → Daniel van Vugt (vanvugt)
status: Triaged → In Progress
affects: compiz-expo-plugin → compiz-plugins-main
Changed in compiz-plugins-main:
assignee: Daniel van Vugt (vanvugt) → nobody
Changed in compiz-plugins-main:
status: In Progress → Triaged
milestone: none → 0.9.7.2
greg (grigorig) wrote :

Why wasn't the fix merged into master? I am still seeing this issue, if I understand the description correctly.

Daniel van Vugt (vanvugt) wrote :

I'm not convinced this is an issue upstream any more. Especially since bug 862430 is now fixed.

Changed in compiz-plugins-main:
status: Triaged → Invalid
milestone: 0.9.7.2 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers