regression / unable to interact with window-titlebar (window decoration) after minimizing/unminimizing gnome-terminal

Bug #981703 reported by triplesqaurednine on 2012-04-14
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Compiz
High
Daniel van Vugt
Compiz Core
Status tracked in 0.9.7
0.9.7
High
Daniel van Vugt
Arch Linux
New
Undecided
Unassigned
compiz (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

[Impact]
Title bar buttons (close, minimize, maximize) become unresponsive to clicks. This has been observed mainly with Terminal windows, and only by a limited number of people.

[Development Fix]
Fix committed to lp:compiz-core r3096 (compiz 0.9.7 and 0.9.7 series). "Make sure window frames actually get destroyed when they should, to guarantee they get recreated on unminimize."

[Stable Fix]
As above.

[Test Case]
1. open gnome-terminal
2. minimize gnome-terminal
3. un-minimize gnome-terminal
4. try to interact with window title-bar; ie: close/minimize/maximize buttons or even just try to move the window, the titlebar should be unresponsive.

[Regression Potential]
Low. It's been tested by developers for the past week. One-liner.

ORIGINAL DESCRIPTION:
the title says it all, but here is how to reproduce;

1. open gnome-terminal

2. minimize gnome-terminal

3. un-minimize gnome-terminal

4. try to interact with window title-bar; ie: close/minimize/maximize buttons or even just try to move the window, the titlebar should be unresponsive.

So far (and quite oddly) gnome-terminal is the only app i have found that isn't working properly.

however, that being said on my machine is happens 100% of the time. I can however, move the window by using it's gtk menubar.

Related branches

I forgot to mention,

this bug has appeared today (April 14th), in the last few hours.

I built compiz once and noticed the problem. but waited before filing a bug report in case i had just pulled from bzr at a bad time. i waited about 2 hours before building again, and the bug is still there.

cheerz

I also just noticed that AWN can no longer unminimize windows using it's right-click on icon menu.

if i restart compiz, the window may be open, and AWN's menu will still show the option to unminimize too.

I figure these two things are probably related.

Update:

It would seem to be only affecting the gconf-backend (so some setting must be screwed up in there). After switching to the gsettings-backend, the unminimizing problem disappeared...

I am now using the INI-backend, as gsettings didn't seem support a plugin that i use. So ini is fine for now (and working correctly).

cheerz.

Changed in compiz-core:
status: New → Confirmed
importance: Undecided → High
Daniel van Vugt (vanvugt) wrote :

Found the cause. Removing r3092 from lp:compiz-core fixes this regression...

revno: 3092 [merge]
fixes bug(s): https://launchpad.net/bugs/980026
author: Alan Griffiths <email address hidden>
committer: Daniel van Vugt <email address hidden>
branch nick: trunk
timestamp: Fri 2012-04-13 15:07:57 +0800
message:
  Avoid dumping all the windows into first workspace when closing (LP: #980026)
  Reverts to correct logic used before r2838.

Daniel van Vugt (vanvugt) wrote :

Sam says he's looking into this, to see if we can do a fix that doesn't simply revert r3092.

Changed in compiz-core:
assignee: nobody → Sam Spilsbury (smspillaz)
status: Confirmed → In Progress
Changed in compiz-core:
milestone: none → 0.9.7.8

Thanks Daniel.

I wasn't sure if i was the only one who seemed to have this issue, but i did end up trying gconf-backend from scratch (deleted all settings) and it was still persistent. thanks for confirming the bug.

I'll recompile compiz later tonight, and see if it is fixed.

cheerz

Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz-core at revision 3093

Changed in compiz-core:
status: In Progress → Fix Committed
assignee: Sam Spilsbury (smspillaz) → Daniel van Vugt (vanvugt)

Nice.

I built revision 3048, earlier _ but I'll give this a test right now.

cheerz

Daniel van Vugt (vanvugt) wrote :

A better fix has now been committed into lp:compiz-core at revision 3096.

Daniel van Vugt (vanvugt) wrote :

Fix released in Compiz Core 0.9.7.8.

description: updated
Changed in compiz (Ubuntu):
status: New → Triaged
importance: Undecided → High
milestone: none → precise-updates

Hello triplesqaurednine, or anyone else affected,

Accepted compiz into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in compiz (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.7.8-0ubuntu1

---------------
compiz (1:0.9.7.8-0ubuntu1) precise-proposed; urgency=low

  [ Didier Roche ]
  * New upstream bug fix release:
    - [fglrx] Title bar does not update on non-maximized windows (LP: #770283)
    - Some apps (like Remmina) can't full-screen under Compiz (or Unity)
      (LP: #946388)
    - Compiz-core fails to compile with gcc-4.7 - 'cc1plus: all warnings
      being treated as errors' (LP: #972519)
    - Menu shadow clipping flickers while switching menubar items/indicators
      (LP: #978900)
    - Compiz should not move windows to workspace 0,0 when restarted
      (LP: #980026)
    - regression / unable to interact with window-titlebar (window decoration)
      after minimizing/unminimizing gnome-terminal (LP: #981703)
  * debian/patches/workaround_770283.patch,
    debian/patches/fix_976467.patch:
    - removed, upstreamed

  [ Oliver Grawert ]
  * update the GLES2 patch for the new upstream release.

compiz (1:0.9.7.6-0ubuntu2) precise-proposed; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * debian/patches/workaround_770283.patch:
    - Workaround a problem with fglrx not refreshing window decoration textures
      on pixmap modification (LP: #770283)

  [ Oliver Grawert ]
  * update GLES patch for new quilt patch, fix issue with GLES patch that
    forcefully unapplied other quilt patches and resulted in
    gtk-window-decorator to not be started.
 -- Didier Roche <email address hidden> Thu, 26 Apr 2012 09:19:51 +0200

Changed in compiz (Ubuntu):
status: Triaged → Fix Released
Changed in compiz (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in compiz:
milestone: none → 0.9.8.0
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Daniel van Vugt (vanvugt)
no longer affects: compiz-core/0.9.8
Changed in compiz-core:
milestone: 0.9.8.0 → none
status: Fix Committed → Fix Released
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers