Shadow Clipping / Regressions with AWN in compiz 0.9.7.7 (built an hour ago)

Reported by triplesqaurednine on 2012-04-11
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Compiz
High
Sam Spilsbury
Compiz Core
Undecided
Sam Spilsbury
Arch Linux
New
Undecided
Unassigned

Bug Description

I've noticed over the last few days, there has been changes to how shadows are drawn for menus. My understanding is this has a lot to do with menus looking detatched/above unity-launcher, gtk-apps, etc... For a couple days menu shadows were pretty screwed up (some shadows, some not).

Well, now there seems to be some new issues;

1. Menu shadows get clipped when to close to AWN (im sure this is true of cairo-dock too);

http://ompldr.org/vZGNjcQ/compiz-shadows-corrupt.png

I've made the background white, and highlighted the clipped shadow area (which seems to be an area that AWN uses). In the screenshot, you should notice that i am running 'winreflect' plugin (which is unsupported), however, it makes no difference where it has been disabled or removed - winreflect isn't the problem. changes in how shadows are handled is...

2. sub-menus - whenever, you select a sub-menu, than move your cursor away, shadows get clipped and it looks horrible. it basically flickers and leaves no shadow, where the sub-menu once appeared;

http://ompldr.org/vZGNjdQ/compiz-shadows-menu-corrupt.png

the AWN issue isn't super noticable, but the sub-menu issue is an eye-sore.

after reading through other bug reports, it would seem this bug is the same as this one:

https://bugs.launchpad.net/compiz-core/+bug/978900

and this branch fixes the issue;

https://code.launchpad.net/~smspillaz/compiz-core/compiz-core.fix_978900

I've added myself as affected by this bu, to the other report as well.

Changed in compiz-core:
assignee: nobody → Sam Spilsbury (smspillaz)
status: New → In Progress
milestone: none → 0.9.7.8

Thanks Daniel.

Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz-core at revision 3094

Changed in compiz-core:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix released in Compiz Core 0.9.7.8.

Daniel van Vugt (vanvugt) wrote :

Actually, I just tested AWN for the first time and this bug is not fixed at all.

summary: - Shadow Clipping / Regressions compiz 0.9.7.7 (built an hour ago)
+ Shadow Clipping / Regressions with compiz 0.9.7.7 (built an hour ago)
summary: - Shadow Clipping / Regressions with compiz 0.9.7.7 (built an hour ago)
+ Shadow Clipping / Regressions with AWN in compiz 0.9.7.7 (built an hour
+ ago)

Hey Daniel,

I also just tested this, and it's not fixed. I must have forgotten about this, and never enabled animations for menus until now. So yes, this bug still exists.

...and since you have AWN installed, could you see if you can verify this bug;

https://bugs.launchpad.net/compiz-core/+bug/986260

Changed in compiz:
assignee: nobody → Sam Spilsbury (smspillaz)
status: New → Triaged
Changed in compiz:
milestone: none → 0.9.8.0
no longer affects: compiz-core/0.9.7
no longer affects: compiz-core/0.9.8
Changed in compiz:
milestone: 0.9.8.0 → 0.9.8.1
Changed in compiz:
milestone: 0.9.8.2 → 0.9.8.4
Changed in compiz:
milestone: 0.9.8.4 → 0.9.9.0
Changed in compiz:
milestone: 0.9.9.0 → 0.9.9.2
Changed in compiz:
milestone: 0.9.9.2 → 0.9.10.0
MC Return (mc-return) on 2013-06-21
Changed in compiz:
importance: Undecided → High
Changed in compiz:
milestone: 0.9.10.0 → 0.9.10.2
MC Return (mc-return) on 2013-07-24
Changed in compiz:
milestone: 0.9.10.2 → 0.9.11.0
dimx (dimx) wrote :

I can confirm this bug affecting Cairo-dock too on 2 systems
(arch,slackware - either with proprietary or free drivers).
versions 0.9.9 through 0.9.11-bzr

Please update the title accordingly to reflect that it affects Cairo-dock as well as AWN.

Cairo-dock seems to have a larger window than what is drawn, due to a big part of it being transparrent.
Since it is (correctly) treated as a dock by compiz, it is always above other windows.

Now, when the menu of another window is drawn, it is drawn correctly above the invisible part of the dock, but for some reason the shadows are drawn beneath it!!! That must be the reason of clipping occurrence.

What is strange, that even Cairo-dock's own menu appears to clipped (when in vertical mode it becomes very clearly visible).

Some screenshots of menus' shadow clippings:
http://en.zimagez.com/zimage/screenshot-04022014-cropped.php
http://en.zimagez.com/zimage/compizbug2.php

Any help would be appreciated.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers