Place plugin problem with panel in fullscreen and gnome classic

Reported by Mohegan on 2012-04-07
248
This bug affects 75 people
Affects Status Importance Assigned to Milestone
Compiz
Medium
Rock
Compiz Core
Medium
Rock
compiz (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

[Impact]

Flash video fullscreen problem with GNOME panel.

[Test Case]

In precise, when I want watch a flash video in fullscreen (like youtube or other flash site), the gnome panel doesn't dissapear.
If I disable the place plugin with CCSM it works well.

I use the last version of compiz : 1:0.9.7.4-0ubuntu3.

[Regression Potential]

Window placement in general, should be tested by manual/checkbox tests. The same commit has been well tested in Ubuntu 12.10.

Whoopie (whoopie79) wrote :

I can confirm this issue.

It's the same for Virtualbox when trying to switch a guest system to fullscreen.

Changed in compiz-core:
status: New → Confirmed

same as this bug I think https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/977438

it's caused on mine by the clock on the gnome panel updating when using the place plugin. It is bringing the panel to the front (or at least in front of whatever I have fullscreen eg. a video). I have looked at the source in 0.9.8 but I'm not competent enough to write an exception or alter this behavior

Owen Williams (ywwg) wrote :

This bug causes fullscreen mode to be almost useless for me. Whether it's the clock, window list, or workspace pager, my panel comes back almost instantly after I trigger fullscreen mode

Owen Williams (ywwg) wrote :

The patch in this bug seems to fix the issue for me: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/974242

Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in compiz:
status: New → Confirmed
Nibblyn (nibblyn) on 2012-06-02
summary: - Place plugin problem with flash in fullscreen and gnome classic
+ Place plugin problem with panel in fullscreen and gnome classic
everflux (tklaunchpad) wrote :

Is there an AMD64 package to try it out?

Changed in compiz:
milestone: none → 0.9.8.0
Oli (oli) wrote :

Hi all, I created a PPA based on Rock's patch for my bug report (#974242):

sudo add-apt-repository ppa:oli/compiz-place-patch
sudo apt-get update
sudo apt-get upgrade

I was also suffering from this bug and the patch seems to deal with both problems at once. Give it a test and let me know if you have any problems.

Chris Perry (csperry-2802) wrote :

Hi Oli, I was having this problem with gaming in Wine, after switching from Unity to Gnome Classic in Ubuntu 12.04, and it's worked for me. Many thanks!

knoxg (knoxg) wrote :

The ppa:oli/compiz-place-patch PPA fixes the full-screen issue for me ( running remmina remote desktop in full-screen mode )

Guy Verrijdt (gverrijdt) wrote :

The ppa fixed both issues for me.
Thanks a lot.
Probably a silly question, but what will happen when compiz updates? Should I keep the oli-ppa activated in software sources?

Changed in compiz:
assignee: nobody → Oli (oli)
status: Confirmed → In Progress
assignee: Oli (oli) → Rock (rockbuntu)
James Fox (jfox950) wrote :

Hi guys.

I'm having this problem with all full screen applications gthumb youtube and vlc in Ubuntu 12.04. I have 4 machines and all are doing it. Its driving me insane. Of course disabling place windows or logging into gnome classic without effects fix's this.

Gonna try the unofficial patch mentioned in this thread.

Please fix soon :)

Zoubidoo (zoubidoo) wrote :

This is a highly visible bug. Any chance of upping the importance?

Chris Hemsing (c-hemsing) wrote :

Oli, thanks for the patch.

However, I think it is very unfortunate, that you package:

https://launchpad.net/~oli/+archive/compiz-place-patch/+files/compiz-core_0.9.7.8-0ubuntu1.4_amd64.deb

has exactly the same naming as the official:

            http://archive.ubuntu.com/ubuntu/pool/main/c/compiz/compiz-core_0.9.7.8-0ubuntu1.4_amd64.deb

Therefore, your proposed course of action:
sudo add-apt-repository ppa:oli/compiz-place-patch
sudo apt-get update
sudo apt-get upgrade
does not work.

There are ways to circumvent it, sure! Nevertheless, it is unfortunate.

Changed in compiz:
milestone: 0.9.8.0 → 0.9.8.1
Changed in compiz:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz at revision 3324

Guy Verrijdt (gverrijdt) wrote :

I've had my problems fixed by the Oli-ppa (see post 21.07).

Problems came back after a recent update, although the Oli-ppa is still activated.

Chris, you mention ways to circumvent, can you clarify?
How can I force the Oli patch?

Please help

Changed in compiz:
status: Fix Committed → Fix Released

How can I get this update? I refresh the update manager but there isn't any update for compiz.

Thank you in advance.

Changed in compiz-core:
status: Confirmed → Triaged
milestone: none → 0.9.7.10
Daniel van Vugt (vanvugt) wrote :

Fix committed to lp:compiz-core/0.9.7 at revision 3117

Changed in compiz-core:
status: Triaged → Fix Committed
assignee: nobody → Rock (rockbuntu)
Launchpad Janitor (janitor) wrote :
Download full text (5.2 KiB)

This bug was fixed in the package compiz - 1:0.9.8.2+bzr3377-0ubuntu1

---------------
compiz (1:0.9.8.2+bzr3377-0ubuntu1) quantal-proposed; urgency=low

  [ Sam Spilsbury ]
  * debian/python-compizconfig.install
    - Install compizconfig-python.pc
  * debian/patches/100_expo_layout.patch
    - re-add the expo layout that used to be in precise (LP: #1047067)
    - add some testcases

  [ Timo Jyrinki ]
  * New upstream snapshot.
    - Fix multiple window placement bugs (LP: #974242) (LP: #976032)
    - Don't waste CPU looping through and looking at all the windows if you're
      rendering an output that has no damage on it. (LP: #1014986)
    - Updated convert files to fix some typos in the key names. (LP: #1041631)
    - Fix crash when imgsvg is loaded, due to missing symbol
      (decor_apply_gravity from libdecoration). (LP: #956986)
    - Treat unresolved symbols at link time as an error, rather than letting
      them through and cause strange crashes later. (LP: #1043143)
    - Refactors a little bit of the upgrade code and gets it under test to
      prepare to fix (LP: #1042537)
    - Updated AUTHORS from the full bzr log, and re-sort the list.
      (LP: #1042095)
    - Fixes FTBFS for kde4-window-decorator (LP: #1041310)
    - Fix obvious omissions from the introduction of unminimize_*,
      which were causing the unminimize animation settings to be ignored
      (LP: #1040455)
    - resize plugin: don't crash if resize wasn't initiated externally
      (LP: #1045191)
    - Clean up capitalization (LP: #1045652)
    - Avoid division by zero, if plugins try to deform a window down to size
      zero. (LP: #1045235)
    - Make "Unredirect Fullscreen Windows" more reliable. This fixes the
      problem with unredirection failing to engage at all (LP: #1041066) when
      gtk-window-decorator creates offscreen windows that are stacked on top.
      This also fixes the problem with unredirect hiding all windows,
      because it thinks the desktop window should be stacked on top
      (LP: #980663).
    - Ensure unredirected windows don't stay unredirected if they're no longer
      on top. (LP: #1041047)
    - Fix launching terminal functionality and make show-hud default key
      visible. Update the defaults to org.compiz.integrated to reflect the
      actual gnome values pre-gnome-3. (LP: #1040081) (LP: #1046199)
      (LP: #1046190)
    - Fix show-hud, bump COMPIZ_GNOME_INTEGRATED_SETTINGS_LIST_SIZE.
      (LP: #1046212)
    - Fixed: Windows with an alpha-channel, like gnome-terminal, were not
      being considered as possibly covering fullscreen windows. But they most
      certainly can. This ensures such RGBA windows are visible if they're
      stacked above a fullscreen window. (LP: #1046661)
    - Remove ListToStringList (LP: #1046184)
    - Fix typo causing CMake Error (LP: #1045665)
    - Transitions gtk-window-decorator over to use GSettings. Add a testing
      framework for the options code. (LP: #1042323)
    - Also need kdeworkspace since kdecorationbridge.h is there
      (LP: #1046770)
    - Implements some cleanup that was suggested on the merge for the original
      port to gsettings. Other issues fixed as wel...

Read more...

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
Chris Hemsing (c-hemsing) wrote :

This bug has been reported for 12.04 precise.
That was in April, i.e. 7! month ago.
I still don't see the bug being repaired in precise.
However, the last status change is: Confimed -> Fix Released

I think, there is no fix for precise yet.

When will it be fixed? And what is the exact definition of "Fix released"?

Timo Jyrinki (timo-jyrinki) wrote :

"Fix Released" in this bug's compiz(Ubuntu) means it's fixed for the newest Ubuntu release at the time of marking it fixed. It has now also been nominated for 12.04 as per SRU process, and the fix is testable in https://launchpad.net/~unity-team/+archive/sru (ppa:unity-team/sru). There will be additional verification needed when the stable release upgrade hits precise-proposed.

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu Precise):
status: New → Confirmed
Changed in compiz:
importance: Undecided → Medium
Changed in compiz-core:
importance: Undecided → Medium
Changed in compiz (Ubuntu):
importance: Undecided → Medium
Changed in compiz (Ubuntu Precise):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in compiz-core:
status: Fix Committed → Fix Released

Hello Mohegan, or anyone else affected,

Accepted compiz into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/compiz/1:0.9.7.8+bzr3121-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in compiz (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed

Just tested the package from precise-proposed - fixes the problem for me.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.7.8+bzr3121-0ubuntu1

---------------
compiz (1:0.9.7.8+bzr3121-0ubuntu1) precise-proposed; urgency=low

  * New upstream stable branch snapshot.
    - Includes all the previous cherry-picked fixes
    - Fix crash when imgsvg is loaded, due to missing symbol
      (decor_apply_gravity from libdecoration). (LP: #956986)
    - Fix multiple window placement bugs (LP: #974242) (LP: #976032)
    - Fix window handle leak causing gradual degradation in desktop
      performance (LP: #1050610)
    - Some decoration pixmaps get leaked on window resize, due to race
      conditions between gtk-window-decorator and the decor plugin.
      (LP: #1057263)
    - Avoid a NULL dereference and give a useful error message instead.
      (LP: #944653)
    - Fix leakage of destroyed_pixmaps_table, containing pointers to freed
      decor_t's which could result in a freed GHashTable being passed into
      g_hash_table_remove and causing a crash. (LP: #1060171)
  * debian/patches/compiz-package-gles2.patch:
    - Drop the NEWS file, update decor.cpp part to build with new upstream
      code.
  * debian/patches/revert_fix_933776_955035.patch:
    - Cherry-pick the revert from upstream since the bug fix is not
      suitable for SRU as is
  * debian/patches/revert_fix_994841.patch:
    - Cherry-pick also this revert as non-SRU material, not relevant
      to users
  * debian/libdecoration0.symbols:
    - Update with latest symbols
 -- Timo Jyrinki <email address hidden> Mon, 12 Nov 2012 13:56:29 +0200

Changed in compiz (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers