Some CCSM settings are not saved when using compiz 0.9.7.4

Reported by Hugo Osvaldo Barrera on 2012-04-05
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Compiz Core
Undecided
Unassigned
Arch Linux
New
Undecided
Unassigned

Bug Description

A great deal of changes in ccsm aren't saved when using compiz 0.9.7.4. The settings for plugin "animations" don't, for example.

I make changes in CCSM, and compiz does not reflect them. Inspecting ~/.config/compiz-1/compizconfig/Default.ini, the changes where not saved to the file. Editing the .ini manually works fine (though requires a restart of compiz to work).

*Some* settings do work. Activating/deactivating a plugin is always reflected properly in the ini file.
CCSM is configured (in preferences) to use the flat-file backend (it's actually the only option).

Changed in compiz-core:
status: New → Invalid
status: Invalid → Incomplete
Daniel van Vugt (vanvugt) wrote :

Hugo, CCSM, at least in Ubuntu 12.04, uses gconf to store and load the configuration. It is hardcoded in the Ubuntu build of compiz to use gconf. The files for compiz gconf settings are in ~/.gconf/apps/compiz-1/

I'm not sure if and how the ini-backend is still used. I thought it had been retired, but could be wrong.

Hi.
I should have specified; I'm not using Ubuntu (I'm using Arch).
I had though this might have been hardcoded, but as I said; *some* few values are stored properly, as well as which plugins are enabled/disabled.
I made sure (just in case), "~/.gconf/apps/compiz-1/" does not exist in this case.
I belive the bug is in CCSM itself; I've managed to reproduce the bug on another (similar) system.
I've seen no reference to the ini backend being retired, and I wouldn't think it would be a good idea, it'd kill compiz as a standalone WM.

Changed in compiz-core:
status: Incomplete → New
Rob Agnese (ragnese) wrote :

This also happens for me- also on Arch.

I haven't played with all of the plugins, but the ones that aren't sticking for me seem to be ones where I type text into CCSM (setting commands in the Commands plugin and assigning a window-decorator).

I am also using the flat-file configuration and have not heard/read anything about that method being retired...

I've also been able to reproduce the same problems using the ini-backend.

CCSM doesn't seem to be working with flat-file backend (properly). Settings don't seem to be persistent/saved. editing the file by hand works, but CCSM doesn't, really.

This needs to be fixed for all the compiz standalone folks. Pulling in gconf / gnome dependencies isn't doable in these situations - it defeats the purpose of using compiz by itself.

so i've added Archlinux as a distribution affected, but in reality ALL distros are affected by this.

cheerz

I think this bug report can be marked invalid (unless someone pipes in).

For some reason or another the flat-file-backend is now working flawlessly for me. I am using it right now.

cheerz

I can confirm that this works as expected with the latest bzr revision.
Rather than "invalid", I'd close it as "fixed": the bug did exists at the time, and was fixed at some point later on.

Changed in compiz-core:
status: New → Fix Committed
Changed in compiz-core:
status: Fix Committed → Fix Released
no longer affects: compiz-ccsm
Alexey Spiridonov (snarkmaster) wrote :

GSettings was the default backend, and it was losing most of my settings. Once I discovered the flat file backend, everything started to work. CCSM should either fix or drop the gsettings backend, because right now it simply silently loses data.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers