Tests do not build when libgtest-dev is installed but libgtest isn't

Bug #964248 reported by Sam Spilsbury on 2012-03-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz Core
Medium
Sam Spilsbury

Bug Description

According to the Google Test documentation[1], it isn't mandatory for distributions to ship the compiled gtest library, but instead applications are expected to use the shipped sources to compile it locally.

Currently FindGTest.cmake only searches for the headers /and/ the library, and since the library is no longer shipped in Ubuntu, GTest is not found and the tests do not build. The fix is to add GTEST_ROOT_DIR as part of the build process so that it is linked as a static lib should searching for the dynamic one fail.
[1] http://code.google.com/p/googletest/wiki/FAQ

Changed in compiz-core:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 0.9.7.4
description: updated
Changed in compiz-core:
milestone: 0.9.7.4 → none
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz-core at revision 3071

Changed in compiz-core:
milestone: none → 0.9.7.6
status: Confirmed → Fix Committed
milestone: 0.9.7.6 → 0.9.7.4
Daniel van Vugt (vanvugt) wrote :

Fix released in Compiz Core 0.9.7.4

Changed in compiz-core:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers