[regression] [bnr] segfault caused by r3043

Bug #958540 reported by micove on 2012-03-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz Core
Critical
Daniel van Vugt

Bug Description

I was compiling 0.9.7.0 and cherry picking the commit from bzr 3043. If I activate the animations plugins and close any windows compiz segfaults. If I disable the closing animations from the animations plugins there is no segfaults.

If I compile the RC of 0.9.7.2 (everything up to bzr 3058) same thing happens but if I revert commit 3043 the segfaults go away.

Related branches

Revision history for this message
Daniel van Vugt (vanvugt) wrote : Re: [regression] segfault caused by r3043

It sounds like the list of windows is becoming out of date whilst iterating through it. So a copy (the old code) is required for now.

summary: - Regression caused by bzr 3043
+ [regression] segfault caused by r3043
Changed in compiz-core:
assignee: nobody → Daniel van Vugt (vanvugt)
importance: Undecided → Critical
status: New → Triaged
status: Triaged → In Progress
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Marking [bnr] = Bug Never Released. This is a handy way to know which bugs don't need to be mentioned in future release notes.

Changed in compiz-core:
milestone: none → 0.9.7.2
summary: - [regression] segfault caused by r3043
+ [regression] [bnr] segfault caused by r3043
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz-core at revision 3061

Changed in compiz-core:
status: In Progress → Fix Committed
Changed in compiz-core:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers