screen.cpp:3281: virtual bool CompScreenImpl::addAction(CompAction*): Assertion `priv->initialized' failed.

Bug #946118 reported by Daniel van Vugt on 2012-03-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz Core
Medium
Daniel van Vugt
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

screen.cpp:3281: virtual bool CompScreenImpl::addAction(CompAction*): Assertion `priv->initialized' failed.

This happens whenever compiz is run without a valid $DISPLAY or --display option. For example:
  compiz --replace --display 123 composite

Changed in compiz-core:
assignee: nobody → Daniel van Vugt (vanvugt)
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

More details:

(gdb) bt
#0 0x00007ffff729b3a5 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1 0x00007ffff729eb0b in __GI_abort () at abort.c:92
#2 0x00007ffff7293d4d in __GI___assert_fail (assertion=0x7ffff7ba58ff "priv->initialized", file=<optimised out>, line=3281, function=<optimised out>) at assert.c:81
#3 0x00007ffff7b5e9a9 in CompScreenImpl::addAction (this=0x60eca0, action=0x622b80) at /home/dan/bzr/compiz-core/assert/src/screen.cpp:3281
#4 0x00007ffff15e76ed in WaterOptions::initOptions (this=0x622520) at /home/dan/bzr/compiz-core/assert/build/generated/water_options.cpp:38
#5 0x00007ffff15e87f0 in WaterOptions::WaterOptions (this=0x622520, init=true) at /home/dan/bzr/compiz-core/assert/build/generated/water_options.cpp:22
#6 0x00007ffff15e1987 in WaterScreen::WaterScreen (this=0x6224f0, screen=0x60eca0) at /home/dan/bzr/compiz-core/assert/plugins/water/src/water.cpp:1308
#7 0x00007ffff15e68a8 in getInstance (base=0x60eca0) at /home/dan/bzr/compiz-core/assert/plugins/../src/pluginclasshandler/include/core/pluginclasshandler.h:225
#8 PluginClassHandler<WaterScreen, CompScreen, 0>::get (base=0x60eca0) at /home/dan/bzr/compiz-core/assert/plugins/../src/pluginclasshandler/include/core/pluginclasshandler.h:269
#9 0x00007ffff15e6a8c in CompPlugin::VTableForScreenAndWindow<WaterScreen, WaterWindow>::finiScreen (this=<optimised out>, s=<optimised out>) at /home/dan/bzr/compiz-core/assert/plugins/../include/core/plugin.h:245
#10 0x00007ffff7b93908 in CompManager::finiPlugin (p=0x61aea0) at /home/dan/bzr/compiz-core/assert/src/plugin.cpp:316
#11 0x00007ffff7b94e3e in CompPlugin::pop () at /home/dan/bzr/compiz-core/assert/src/plugin.cpp:524
#12 0x00007ffff7b5b4ed in CompScreenImpl::~CompScreenImpl (this=0x60eca0, __in_chrg=<optimised out>) at /home/dan/bzr/compiz-core/assert/src/screen.cpp:4967
#13 0x00007ffff7b5b689 in CompScreenImpl::~CompScreenImpl (this=0x60eca0, __in_chrg=<optimised out>) at /home/dan/bzr/compiz-core/assert/src/screen.cpp:4971
#14 0x000000000040336a in ~auto_ptr (this=<synthetic pointer>, __in_chrg=<optimised out>) at /usr/include/c++/4.6/backward/auto_ptr.h:170
#15 CompManager::init (this=0x7fffffffe430) at /home/dan/bzr/compiz-core/assert/src/main.cpp:140
#16 0x0000000000402999 in main (argc=<optimised out>, argv=0x7fffffffe568) at /home/dan/bzr/compiz-core/assert/src/main.cpp:234

Changed in compiz-core:
status: Triaged → In Progress
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz-core at revision 3042

Changed in compiz-core:
status: In Progress → Fix Committed
Changed in compiz (Ubuntu):
status: New → Confirmed
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in compiz (Ubuntu):
assignee: Daniel van Vugt (vanvugt) → nobody
Changed in compiz-core:
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.7.2-0ubuntu1

---------------
compiz (1:0.9.7.2-0ubuntu1) precise-proposed; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream snapshot:
    - Fix global menu not being ergonomical on large screens (LP: #682788)
    - Fix Alt+Right arrow key (LP: #943612)
    - Fix key bindings for actions while doing tap detection (LP: #944631)
    - Window movement is erratic and buggy, backport (LP: #923683)
    - CompScreenImpl::addAction(CompAction*): Assertion `priv->initialized'
      failed (LP: #946118)
    - gtk-window-decorator crash with SIGSEGV in max_window_name_width()
      (LP: #937815)
    - Finish the implementation of the locally integrated menubars
      (LP: #931245)
    - Unity/compiz intercepts keystrokes from grabbed windows (LP: #806255)
    - Pressing alt doesn't show the menu title bar in top panel (LP: #943194)
    - Fix Alt stealing focus from widgets (LP: #943851)
    - Fix Alt + drag (LP: #945373)
    - lp:compiz-core fails parallel builds (make -jN) (LP: #938417)
    - Changing the HUD shortcut disables all Alt-based combinations. And
      changing the Dash shortcut disables all Super-based shortcuts
      (LP: #945816)
    - Fix key bindings (such as Super) not working on empty workspace or on
      slow/loaded systems (LP: #953089)
    - compiz crashed with signal 5 in Glib::exception_handlers_invoke()
      (LP: #808007)
    - Fix segfault caused by r3043 (LP: #958540)
  * Removed cherry-picked patches:
    - debian/patches/fix_806255.patch
    - debian/patches/fix_923683.patch
    - debian/patches/fix_943194.patch
    - debian/patches/fix_944631.patch
    - debian/patches/fix_alt_pressing.patch
    - debian/patches/additional_alt_tapping_fix.patch

  [ Didier Roche ]
  * pick upstream fix, debian/patches/fix_953839.patch:
    [regression] Invisible resize border is now only 1px wide (LP: #953839)
  * debian/patches/revert_lim.patch:
    - revert the integrated menu patch. It won't be released in precise and
      triggers a regression (in bug #962085)
  * debian/patches/fix_953089_2.patch:
    - second trial to fix remaining corner cases
  * debian/patches/exit_1_if_composite_cant_init.patch:
    - try to workaround a crasher which seems to happen when the composite
      plugin failed to initialize. Hopefully exiting 1 will make gnome-session
      respawning compiz and then the init will work. (LP: #833729)
  * debian/patches/always_replace.patch:
    - right now, always replace the current WM as it seems that some people
      got another compositor running at the start of the session. This will
      hopefully workaround the issue that some people experience.
 -- Didier Roche <email address hidden> Fri, 23 Mar 2012 09:13:51 +0100

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers