decor_match_pixmap (decoration.c:423): Conditional jump or move depends on uninitialised value(s)

Bug #940066 reported by Daniel van Vugt on 2012-02-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz Core
Medium
Daniel van Vugt
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

==22175== Conditional jump or move depends on uninitialised value(s)
==22175== at 0x4C2ABBD: bcmp (mc_replace_strmem.c:679)
==22175== by 0xAF97948: decor_match_pixmap (decoration.c:423)
==22175== by 0xAD7B4D2: DecorationList::updateDecoration(unsigned long, unsigned long) (decor.cpp:796)
==22175== by 0xAD7BA7A: DecorWindow::updateDecoration() (decor.cpp:897)
==22175== by 0xAD7CE40: DecorScreen::handleEvent(_XEvent*) (decor.cpp:2376)
==22175== by 0x4E97AA2: CompScreen::handleEvent(_XEvent*) (event.cpp:1038)
==22175== by 0xB1A5539: BaseSwitchScreen::handleEvent(_XEvent*) (compiztoolbox.cpp:650)
==22175== by 0x4E97AA2: CompScreen::handleEvent(_XEvent*) (event.cpp:1038)
==22175== by 0xA920FCB: MoveScreen::handleEvent(_XEvent*) (move.cpp:634)
==22175== by 0x4E97AA2: CompScreen::handleEvent(_XEvent*) (event.cpp:1038)
==22175== by 0x4E97AD8: CompScreenImpl::alwaysHandleEvent(_XEvent*) (event.cpp:1047)
==22175== by 0x4E6EE0C: PrivateScreen::processEvents() (screen.cpp:825)
==22175==
==22175== Conditional jump or move depends on uninitialised value(s)
==22175== at 0xAF9794B: decor_match_pixmap (decoration.c:423)
==22175== by 0xAD7B4D2: DecorationList::updateDecoration(unsigned long, unsigned long) (decor.cpp:796)
==22175== by 0xAD7BA7A: DecorWindow::updateDecoration() (decor.cpp:897)
==22175== by 0xAD7CE40: DecorScreen::handleEvent(_XEvent*) (decor.cpp:2376)
==22175== by 0x4E97AA2: CompScreen::handleEvent(_XEvent*) (event.cpp:1038)
==22175== by 0xB1A5539: BaseSwitchScreen::handleEvent(_XEvent*) (compiztoolbox.cpp:650)
==22175== by 0x4E97AA2: CompScreen::handleEvent(_XEvent*) (event.cpp:1038)
==22175== by 0xA920FCB: MoveScreen::handleEvent(_XEvent*) (move.cpp:634)
==22175== by 0x4E97AA2: CompScreen::handleEvent(_XEvent*) (event.cpp:1038)
==22175== by 0x4E97AD8: CompScreenImpl::alwaysHandleEvent(_XEvent*) (event.cpp:1047)
==22175== by 0x4E6EE0C: PrivateScreen::processEvents() (screen.cpp:825)
==22175== by 0x4EA4346: CompEventSource::callback() (eventsource.cpp:63)
==22175==

Related branches

Daniel van Vugt (vanvugt) wrote :

It seems the problem is one of those instances of memcmp on padded structures I have been warning about...

Changed in compiz-core:
status: Triaged → In Progress
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in compiz-core:
milestone: none → 0.9.7.0
Daniel van Vugt (vanvugt) wrote :

Merged into lp:compiz-core at revision 3024

Changed in compiz-core:
status: In Progress → Fix Committed
Changed in compiz-core:
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

This bug was fixed in the package compiz - 1:0.9.7.0+bzr3035-0ubuntu1

---------------
compiz (1:0.9.7.0+bzr3035-0ubuntu1) precise; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream snapshot:
    - Fix gtk-window-decorator crash upon demaximizing a window (LP: #930071)
    - Fix core keybindings (LP: #930412)
    - Fixes compiz crash with SIGSEGV on shutdown (LP: #931283)
    - Plugins can't tell the difference between a key-tap and modifier
      key-release (LP: #925293)
    - compiz-core r3001 (and 3002) ftbfs (LP: #933226)
    - Semi-maximized windows have no shadow or frame (LP: #924736)
    - Untranslated strings in gtk-window-decorator (LP: #780505)
    - Initialize the _NET_WM_STATE_FOCUSED (LP: #932087)
    - [regression] Customized shortcuts don't work (LP: #931927)
    - Window stacking problem (LP: #936675)
    - Quickly demaximized windows can receive maximized window decorations if
      they were initially maximized (LP: #936778)
    - Maximized windows do not get shadows at all (LP: #936774)
    - [regression] Launcher, top panel and keyboard un-responsive after using
      any Super-x shortcut (LP: #934058)
    - No draggable border if mutter isn't installed (LP: #936781)
    - Fix compiz crash with SIGSEGV in XDefineCursor() (LP: #936487)
    - Fixes memory leak at DecorWindow::updateSwitcher() (LP: #940115)
    - Unresolved symbols in plugins cause compiz to exit (LP: #938478)
    - Fix compiz spending about 51% of its CPU time in CompRegion
      construction/destruction (LP: #940139)
    - Fix Conditional jump or move depends on uninitialised value(s) in
      decor_match_pixmap (LP: #940066)
    - Fix 'show desktop' behaviour (LP: #871801)
    - Tweak algorithm used to cast shadows on maximized windows (LP: #936784)
    - "Svg" and "Png" should be "SVG and "PNG" (LP: #942890)
    - Fix invalid memory usage after free() in DecorWindow (LP: #943116)
    - Fix alt + F10 (LP: #943223)
  * Removed cherry-picked patches
  * debian/patches/fix_944631.patch:
    - Always replay the keyboard if something was grabbed and didn't trigger
      an action and don't trigger actions which aren't added accidentally
      (LP: #943612) (LP: #944631)
  * debian/patches/fix_923683.patch:
    - Backports a patch which prevents the shift race condition

  [ Didier Roche ]
  * debian/patches/fix_alt_pressing.patch:
    - Patch from ddv to fix all the regressions with the alt key fix and other
      (LP: #943851, #945373)
    - Fix Quicklist are not showing if right-clicking a launcher icon in Expo
      mode if triggered by Super + S (LP: #944979)
  * debian/patches/fix_806255.patch:
    - Unity/compiz intercepts keystrokes from grabbed windows (LP: #806255)
  * debian/patches/fix_943194.patch:
    - second part for the alt key fix (LP: #943194)
  * debian/patches/additional_alt_tapping_fix.patch:
    - again another alt tapping related fix for some regressions from the
      previous branch. Taken from "tapping-panacea" upstream branch.
 -- Didier Roche <email address hidden> Mon, 12 Mar 2012 10:22:10 +0100

Changed in compiz (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers