lp:compiz-core fails parallel builds (make -jN)

Bug #938417 reported by Daniel van Vugt on 2012-02-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz Core
Medium
Daniel van Vugt
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

The exact locations of the failures seems to change depending on the value of N. Not surprising as they are effectively race conditions.

It would be really nice if we could have parallel builds working because it would speed up development, permanently.

Most likely, all the reasons for the build failures will be missing dependencies. i.e. Some target requires another target in order to build, but fails to declare that dependency formally in CMakeLists.txt

Related branches

Changed in compiz-core:
status: New → Incomplete
status: Incomplete → Triaged
importance: Undecided → Medium
Revision history for this message
Sam Spilsbury (smspillaz) wrote : Re: [Bug 938417] [NEW] lp:compiz-core fails parallel builds (make -jN)

On Wed, 22 Feb 2012, Daniel van Vugt wrote:

> Public bug reported:
>
> The exact locations of the failures seems to change depending on the
> value of N. Not surprising as they are effectively race conditions.
>
> It would be really nice if we could have parallel builds working because
> it would speed up development, permanently.
>

There's only two that I know of so far.

The first is one when building po files. I think we need to make them
depend on the OUTPUT and not on the TARGET.

The second is core-xml-file . I think that add_custom_command for
core_options.c|h does not use OUTPUT, so that would cause the dependency
failure there.

> Most likely, all the reasons for the build failures will be missing
> dependencies. i.e. Some target requires another target in order to
> build, but fails to declare that dependency formally in CMakeLists.txt
>
> ** Affects: compiz-core
> Importance: Medium
> Status: Triaged
>
> ** Changed in: compiz-core
> Status: New => Incomplete
>
> ** Changed in: compiz-core
> Status: Incomplete => Triaged
>
> ** Changed in: compiz-core
> Importance: Undecided => Medium
>
> --
> You received this bug notification because you are a member of Compiz
> Maintainers, which is the registrant for Compiz Core.
> https://bugs.launchpad.net/bugs/938417
>
> Title:
> lp:compiz-core fails parallel builds (make -jN)
>
> Status in Compiz Core:
> Triaged
>
> Bug description:
> The exact locations of the failures seems to change depending on the
> value of N. Not surprising as they are effectively race conditions.
>
> It would be really nice if we could have parallel builds working
> because it would speed up development, permanently.
>
> Most likely, all the reasons for the build failures will be missing
> dependencies. i.e. Some target requires another target in order to
> build, but fails to declare that dependency formally in CMakeLists.txt
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/compiz-core/+bug/938417/+subscriptions
>

Changed in compiz-core:
assignee: nobody → Daniel van Vugt (vanvugt)
milestone: none → 0.9.7.2
Changed in compiz (Ubuntu):
status: New → In Progress
Changed in compiz-core:
status: Triaged → In Progress
Changed in compiz (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz-core at revision 3055

Changed in compiz-core:
status: In Progress → Fix Committed
Changed in compiz (Ubuntu):
status: In Progress → Confirmed
assignee: Daniel van Vugt (vanvugt) → nobody
Changed in compiz-core:
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.7.2-0ubuntu1

---------------
compiz (1:0.9.7.2-0ubuntu1) precise-proposed; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream snapshot:
    - Fix global menu not being ergonomical on large screens (LP: #682788)
    - Fix Alt+Right arrow key (LP: #943612)
    - Fix key bindings for actions while doing tap detection (LP: #944631)
    - Window movement is erratic and buggy, backport (LP: #923683)
    - CompScreenImpl::addAction(CompAction*): Assertion `priv->initialized'
      failed (LP: #946118)
    - gtk-window-decorator crash with SIGSEGV in max_window_name_width()
      (LP: #937815)
    - Finish the implementation of the locally integrated menubars
      (LP: #931245)
    - Unity/compiz intercepts keystrokes from grabbed windows (LP: #806255)
    - Pressing alt doesn't show the menu title bar in top panel (LP: #943194)
    - Fix Alt stealing focus from widgets (LP: #943851)
    - Fix Alt + drag (LP: #945373)
    - lp:compiz-core fails parallel builds (make -jN) (LP: #938417)
    - Changing the HUD shortcut disables all Alt-based combinations. And
      changing the Dash shortcut disables all Super-based shortcuts
      (LP: #945816)
    - Fix key bindings (such as Super) not working on empty workspace or on
      slow/loaded systems (LP: #953089)
    - compiz crashed with signal 5 in Glib::exception_handlers_invoke()
      (LP: #808007)
    - Fix segfault caused by r3043 (LP: #958540)
  * Removed cherry-picked patches:
    - debian/patches/fix_806255.patch
    - debian/patches/fix_923683.patch
    - debian/patches/fix_943194.patch
    - debian/patches/fix_944631.patch
    - debian/patches/fix_alt_pressing.patch
    - debian/patches/additional_alt_tapping_fix.patch

  [ Didier Roche ]
  * pick upstream fix, debian/patches/fix_953839.patch:
    [regression] Invisible resize border is now only 1px wide (LP: #953839)
  * debian/patches/revert_lim.patch:
    - revert the integrated menu patch. It won't be released in precise and
      triggers a regression (in bug #962085)
  * debian/patches/fix_953089_2.patch:
    - second trial to fix remaining corner cases
  * debian/patches/exit_1_if_composite_cant_init.patch:
    - try to workaround a crasher which seems to happen when the composite
      plugin failed to initialize. Hopefully exiting 1 will make gnome-session
      respawning compiz and then the init will work. (LP: #833729)
  * debian/patches/always_replace.patch:
    - right now, always replace the current WM as it seems that some people
      got another compositor running at the start of the session. This will
      hopefully workaround the issue that some people experience.
 -- Didier Roche <email address hidden> Fri, 23 Mar 2012 09:13:51 +0100

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers