Menus don't fully appear

Bug #931473 reported by Alan Pope 🍺🐧🐱 🦄 on 2012-02-13
248
This bug affects 55 people
Affects Status Importance Assigned to Milestone
Compiz Core
Medium
Łukasz Zemczak
Compiz Main Plugins
Medium
Unassigned
Compiz Workarounds Plugins
Fix Released
Medium
Łukasz Zemczak
Unity Distro Priority
Medium
Unassigned
compiz-plugins-main (Ubuntu)
Undecided
Unassigned

Bug Description

Sometimes menus of applications or indicators don't fully appear. There's chunks missing. See attached picture. Sometimes I only see the drop shadow and not the full menu, sometimes part of the menu is drawn.

Related branches

Łukasz Zemczak (sil2100) wrote :

I also saw this one - but I noticed it while right-clicking on the window title-bar (as noted checkbox-unity tests results for windowmanagement). It happens seldomly, but still.

tags: added: 0.9.7.0-beta1
Didier Roche (didrocks) on 2012-02-13
Changed in unity-distro-priority:
status: New → Fix Committed
Changed in compiz-core:
importance: Undecided → Medium
status: New → Confirmed
Changed in unity-distro-priority:
importance: Undecided → Medium
Changed in compiz-core:
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 0.9.7.2
Tim Penhey (thumper) wrote :

I noticed this too once, but I've been unable to reproduce, and neither can Sam.

Can anyone give us any steps to reproduce?

Sam Spilsbury (smspillaz) wrote :

This patch backs out revision 2839 which *might* cause this. Please try it with this.

Łukasz Zemczak (sil2100) wrote :

I'll try this patch in a moment to check if it fixes this issue.

I am able to reproduce it quite easily through right-clicks on a window's title bar. How I reproduce it:
Move your mouse tho the title bar of any application, then perform a right-click quickly followed by a left-click. Usually on the second or third try, instead of the menu I only get the menu border and shadow, with the insides transparent.

This happens quite often on my laptop - like every 2-3 sequences as I mentioned above. In normal everyday usage it's a bit more rare, but still not uncommon - I would say every 10-15 times it happens by itself.

My laptop is Intel Core i7 Sandy Bridge based. It's an X220 which is pretty common in Canonical.

I find it happens randomly on various menus, both in the indicator area and application menus. More often happens on the first menu in the list i.e. the file menu rather than the help menu.

Łukasz Zemczak (sil2100) wrote :

I tried the back_out_2839.patch from Sam, but it doesn't seem to fix this problem (sadly). I can still reproduce it the same way as I mentioned before. But I can't seem to be able to reproduce it through normal application menus - i.e. on the File menu or indicators. I just notice it now in the right-click-on-window-title menu. I'll degrade back to the version before the patch to check if the thing I am describing isn't some other bug.

Łukasz Zemczak (sil2100) wrote :

Interesting.

From what I talked with Alan, it seems the bug I'm encountering and his bug are _probably_ different.

Alan said that he wasn't able to observe it on the title bar right-click menu - only on normal menus.
I, on the other hand, can only reproduce it on the title bar, but the bug never happens on normal menus. I'm using an ATI radeon mobility card with fglrx drivers on an old Intel Core2 Duo i386 laptop.

Further to Lukasz comment, I did just get it in a context menu of VirtualBox. I got the drop shadow only, then after a few seconds the window contents filled in.

Tim Penhey (thumper) on 2012-02-16
Changed in compiz-core:
status: Confirmed → In Progress
Łukasz Zemczak (sil2100) wrote :

I'll try dealing with this one - if I won't be able to cope with it, I'll re-assign it back to Sam again ;)

Changed in compiz-core:
assignee: Sam Spilsbury (smspillaz) → Łukasz Zemczak (sil2100)

I seem to be able to reproduce this, but it's difficult on a quick PC. It would probably be more apparent on something lower spec than an i7.

It seems to happen more if you're moving the mouse whilst clicking the menu area. So if you click a menu then move the mouse the next item it happens more often. Also if you move the mouse to a menu, click and then pull the mouse away before the menu has fully displayed then it often breaks up.

See the attached picture. I moved the mouse to the menu and then away and the menu looked unfinished.

Łukasz Zemczak (sil2100) wrote :

Thanks! I think I'm close to finding the issue here. It seems that menus (only the decorator menu and the application menus) have a wrongly set redraw region. The actual redraw region is off - sometimes it's off by a greater magnitude, and then the menu is invisible, or only by a small offset - and then the intersection is redrawn (and the menu is partially visible).

The funny part - the menu decorator (shadows, border) from compiz has the correct coordinates of the menu, but when the actual update of menu contents needs to happen - it's wrong.
Will find this ASAP.

Łukasz Zemczak (sil2100) wrote :

Still working on this one. It seems gtk_menu_popup in gwd sends invalid redraw events for the popup menu. Probably the reason might be some invalid x and y root coordinates. It's probably set not to 0,0 but to the cursor position/popup appearance position. I think it's like that because the update rectangle's x and y coords sent to compiz are 2*(x,y) of the popup position. Will finish this tomorrow!

Tim Penhey (thumper) on 2012-02-16
Changed in compiz-core:
milestone: 0.9.7.2 → 0.9.7.0
Tim Penhey (thumper) on 2012-02-20
tags: added: distro-priority
Changed in compiz-workarounds-plugin:
assignee: nobody → Łukasz Zemczak (sil2100)
importance: Undecided → Medium
status: New → In Progress
Changed in compiz-plugins-main:
status: New → Confirmed
importance: Undecided → Medium
Changed in compiz-plugins-main (Ubuntu):
status: New → Confirmed
Changed in compiz-plugins-main:
milestone: none → 0.9.7.0

The attachment "back_out_2839.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz-workarounds-plugin at revision 119

Changed in compiz-workarounds-plugin:
status: In Progress → Fix Committed
Changed in compiz-plugins-main:
status: Confirmed → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz-plugins-main at revision 20

Changed in compiz-core:
status: In Progress → Fix Committed
Changed in compiz-core:
status: Fix Committed → Fix Released
Changed in compiz-workarounds-plugin:
status: Fix Committed → Fix Released
Changed in compiz-plugins-main:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-plugins-main - 1:0.9.7.0~bzr19-0ubuntu6

---------------
compiz-plugins-main (1:0.9.7.0~bzr19-0ubuntu6) precise; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * debian/patches/workarounds_931473.patch:
    - cherry picked the workarounds plugin patch for fixing menu redraw issues.
      On initial damage events we now force a complete window redraw. (LP: #931473)

  [ Didier Roche ]
  * debian/control:
    - bump compiz-dev and libcompizconfig0-dev build-dep for ABI break
 -- Didier Roche <email address hidden> Mon, 12 Mar 2012 12:45:30 +0100

Changed in compiz-plugins-main (Ubuntu):
status: Confirmed → Fix Released
Didier Roche (didrocks) on 2012-03-14
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
Pablo Zubieta (pabloferz+) wrote :

I installed compiz on Xubuntu 12.04 and I'm still seeing this bug. I have compiz-plugins-main 1:0.9.7.0~bzr19-0ubuntu10.

Daniel van Vugt (vanvugt) wrote :

pabloferz, this bug is marked as Fix Released. If you continue to have similar problems then please log a new bug with screenshot. You might also be experiencing bug 932520, for which the fix has not yet been released.

faiwer (faiwer) wrote :

Daniel van Vugt (vanvugt), I have this bug too on Xubuntu12.04. I can't make screenshot by shutter, because when I making it - menu bug disappears (re-render). // sorry for my bad english :)

$ compiz --version
Compiz 0.9.7.8

Daniel van Vugt (vanvugt) wrote :

If you have any problems at all, please log a _new_ bug.

And if you have trouble capturing graphical bugs with screenshot problems, please consider taking a photo/video of the problem with a camera or phone.

faiwer (faiwer) wrote :

Daniel van Vugt (vanvugt), ok :) Example (attach photo) - in chromium web tool's. I have this bug everythere, but in Crhomium I can call it very easy (1-5 click's on "script" menu).

faiwer (faiwer) wrote :

A small addition: I'm currently using emerald, before - gtk-window-decorator. Bug was in the gtk-window-decorator, too.

Daniel van Vugt (vanvugt) wrote :

Please log a new bug!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers