[regression] Window resizing jitters/flashing is worse in lp:compiz-core than oneiric

Bug #928173 reported by Daniel van Vugt on 2012-02-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz Core
High
Sam Spilsbury

Bug Description

When I resize a window quickly it turns white (often gets stuck that way) and jitters horizontally a little. This bug appears to be a regression in lp:compiz-core that is not present in oneiric. Video attached.

You will also see two other bugs in the video, which are separate bugs (probably) and those are present in oneiric:
Bug 803296: The client area is slow to respond and out of sync with the window frame.
Bug 454218: loss of window border when using compiz resize plugin, option=normal

Related branches

Daniel van Vugt (vanvugt) wrote :
Changed in compiz-core:
assignee: nobody → Sam Spilsbury (smspillaz)
description: updated
Changed in compiz-core:
milestone: none → 0.9.7.0
description: updated
Daniel van Vugt (vanvugt) wrote :

To be fair, the resize bugs in oneiric were pretty bad too, when mode=Normal. Not as bad as this one, but at least Ubuntu uses mode=Rectange which hides all of these bugs.

Daniel van Vugt (vanvugt) wrote :

Unsurprisingly, the bug only occurs when using the decor plugin and gtk-window-decorator. If you run compiz without decorations you won't see the bug at all.

On Tue, 7 Feb 2012, Launchpad Bug Tracker wrote:

Indeed, this is because XSync support has become broken and I haven't
really had time to maintain it.

In reality, this isn't a bigger deal than one would think ubuntu-wise
since we don't use the "live resize" mode due to some drivers being slow
at texture binding. This is an area, however, that I am interested in
optimizing once I have some of my other tasks out of the way.

> Daniel van Vugt (vanvugt) has assigned this bug to you for Compiz Core:
>
> When I resize a window quickly it flashes white and jitters horizontally
> a little. This bug appears to be a regression lp:compiz-core that is not
> present in oneiric. Video attached.
>
> You will also see two other bugs in the video, which are separate bugs (probably) and those are present in oneiric:
> Bug 803296: The client area is slow to respond and out of sync with the window frame.
> Bug 454218: loss of window border when using compiz resize plugin, option=normal
>
> ** Affects: compiz-core
> Importance: High
> Assignee: Sam Spilsbury (smspillaz)
> Status: New
>
> --
> [regression] Window resizing jitters/flashing is worse in lp:compiz-core than oneiric
> https://bugs.launchpad.net/bugs/928173
> You received this bug notification because you are a bug assignee.
>

Daniel van Vugt (vanvugt) wrote :

Blaming the graphics drivers might make sense in the context of how compiz works. However Metacity and Gnome Shell manage to do live resizing perfectly so from the user's perspective there isn't really any excuse. This is discussed in bug 819856.

Sam Spilsbury (smspillaz) wrote :

Texture binding takes 16 ms on nvidia :) I agree that this certainly isn't *the* excuse for not having live resizing but it is *an* excuse (keeping in mind that it used to be a /lot/ slower, even with g-s and metacity back when the decision was made to not do this).

I'm looking into our XSync support now. I've done through and made a pass at optimizing the decor plugin as much as possible, so its already quite fast, but just dependent on how fast the clients repaint their windows.

Daniel van Vugt (vanvugt) wrote :

16ms sounds suspiciously like 60Hz... ie. It was probably blocked waiting for a frame to be rendered. That might be fixable/avoidable.

Daniel van Vugt (vanvugt) wrote :

Merged into lp:compiz-core at revision 2990

Changed in compiz-core:
status: New → Fix Committed
Changed in compiz-core:
status: Fix Committed → Fix Released
no longer affects: compiz (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments