[regression] window movement is erratic and buggy (briefly on startup)

Bug #923683 reported by Daniel van Vugt on 2012-01-30
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Compiz Core
High
Daniel van Vugt
Compiz Main Plugins
Undecided
Sam Spilsbury

Bug Description

When I start compiz (latest lp:compiz-core), moving windows with the "move" plugin doesn't follow the mouse very well. Windows jump erratically and mostly move only about 20% of the distance the mouse pointer moves.

Then after a few seconds of switching windows, it fixes itself. The move plugin honours the mouse movements correctly thereafter.

Related branches

Changed in compiz-core:
importance: Undecided → High
milestone: none → 0.9.7.0
Revision history for this message
Sam Spilsbury (smspillaz) wrote :

Indeed, this is the geometry race condition that I was trying to fix earlier. Core does its best to handle the inherent contradiction between synchronous and asynchronous geometry updates, although in some cases this fails (race condition).

I think the best way to fix this, as I have mentioned earlier is to force all plugins to use the asynchronous path. Though ... we are running out of time for this.

Changed in compiz-core:
assignee: nobody → Sam Spilsbury (smspillaz)
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Why does it happen on startup and then fix itself? And why does it only seem to happen with moves starting with a click? I can't reproduce the bug if I use Alt+F7 and then move the window.

Changed in compiz-core:
assignee: Sam Spilsbury (smspillaz) → Daniel van Vugt (vanvugt)
status: New → In Progress
Changed in compiz-core:
status: In Progress → Fix Committed
summary: - window movement is erratic and buggy (briefly on startup)
+ [regression] window movement is erratic and buggy (briefly on startup)
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Omer, I suspect this fix caused regression bug 923683. Admittedly, that bug is not as bad as this one. But that bug does seem to affect systems that this one did not.

I don't think this bug fix should be in an SRU (yet).

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Ignore that comment. It's meant to go in bug 764330.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Screenshot of the shift bug introduced by Sam's branch.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

And another screenshot.

Changed in compiz-core:
status: Fix Committed → Fix Released
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Fix committed to lp:compiz-plugins-main at revision 33.

(It was committed without any review. Not sure what/how it fixes anything)

Changed in compiz-plugins-main:
status: New → Fix Committed
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 0.9.7.4
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Actually the fix for this bug is in compiz-core. compiz-plugins-main was never related.

The confusion came from a vague and misleading comment on r33.

Changed in compiz-plugins-main:
milestone: 0.9.7.4 → none
status: Fix Committed → Triaged
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers