compiz and X can disagree on the stacking order

Bug #845719 reported by Sam Spilsbury on 2011-09-09
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Compiz Core
Critical
Sam Spilsbury
Unity
Fix Released
Critical
Sam Spilsbury
unity (Ubuntu)
Undecided
Unassigned

Bug Description

This is a meta-bug to track all of the stack sync issues

 * It is possible for a window to issue a ConfigureRequest in between ConfigureRequests internally and when we update the stack causing the ConfigureRequest in between the temporarily updated stack to be processed and given an invalid position
 * It is possible for synethetic ConfigureNotify events sent to core in order to update frame windows can cause the stacking order to become invalid
 * It is possible for created windows to invalidate the stack

Related branches

Sam Spilsbury (smspillaz) wrote :

This fix breaks the ABI

Changed in compiz-core:
status: New → In Progress
importance: Undecided → High
importance: High → Medium
importance: Medium → Critical
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 0.9.5.96
Didier Roche (didrocks) wrote :

note that the approved branch didn't fix the issue. (jibel still have it reliably)

Changed in unity:
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 4.20.0
tags: added: didrocks-oneiric-list
Didier Roche (didrocks) on 2011-09-29
Changed in compiz-core:
status: In Progress → Fix Released
Changed in unity:
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package unity - 4.20.0-0ubuntu1

---------------
unity (4.20.0-0ubuntu1) oneiric; urgency=low

  * New upstream release + cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #835259)
    - dash does not scroll down during keyboard navigation (LP: #852506)
    - compiz crashed with SIGSEGV in _XFreeEventCookies() (LP: #851472)
    - compiz crashed with SIGSEGV in g_object_unref() (LP: #847512)
    - compiz crashed with SIGSEGV in nux::WindowCompositor::MouseEventCycle()
      (LP: #831678)
    - compiz and X can disagree on the stacking order (LP: #845719)
    - compiz crashed with SIGSEGV in unity::dash::LensView::OnResultAdded()
      (LP: #855252)
    - CCSM crashes Unity (LP: #861643)
    - compiz crashed with SIGSEGV in PrivateWindow::addWindowStackChanges()
      (LP: #862115)
    - Touch - When dragging a window with a 3 touch, dragging to the top
      should show the maximize gesture preview. (LP: #750316)
    - compiz crashed with SIGABRT in raise() (LP: #750386)
    - Launcher - Spread should not affect the state of window (LP: #764673)
    - [UIFe] Add system setting icon to Launcher (LP: #764744)
    - compiz crashed with SIGABRT in raise() [Merely unchecking the Unity
      plugin is enough to crash Compiz...] (LP: #823386)
    - Launcher - does not hide if revealed from top 24px of the left edge of
      the screen (LP: #835989)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - Cannot search for some apps in Dash (LP: #837075)
    - Dash - Search box cursor not responding correctly to focus (LP: #839704)
    - Multi-display: Application menu only showing on primary screen
      (LP: #845212)
    - Ellipsized values in size filter (LP: #851359)
    - (oneiric) dash result expansions don't display icons (LP: #854615)
    - run the wrong command if enter is hit before the view is refreshed
      (LP: #856205)
    - Java application windows cut-off/truncated/not displayed properly
      (LP: #857201)
    - compiz crashed with SIGSEGV in sigc::signal_base::impl() (LP: #831769)
    - Minimizing a window should switch focus to the windows underneath it
      (breaks restore) (LP: #859885)
    - Ratings filter allows ratings > 1.0 (LP: #861255)
    - Serious Unity problem stuck in spread when dragging icons back to the
      dash (LP: #862045)
    - Must use hardware keyboard to perform search for applications in Unity
      (LP: #739812)
    - Files lens should also search Downloads (LP: #748915)
    - The dash crosses the monitor boundary when resolution is 1152x864 or
      lesser width (LP: #765338)
    - Dash - dragging a file outside of the Desktop Dash should close the Dash
      (LP: #764641)
    - Text in Dash search text box overflows and doesn't crop with longer
      strings; RtL input starts in wrong place (LP: #834765)
    - Where the average background colour is either very light or dark, adjust
      this value to darken/lighten in order to preserve readability
      (LP: #837993)
    - Dash does not resize when I connect to an external display and mirror
      displays (LP: #83813...

Read more...

Changed in unity (Ubuntu):
status: New → Fix Released
Nick Moffitt (nick-moffitt) wrote :

This does not appear to have fixed the problem. I am current with oneric and am in a situation right now where transient windows appear behind the app windows that own them. I'm lucky my terminals are translucent, or I wouldn't be able to find the "Open Link" entry on the context menu. This goes beyond the context menus from the launcher!

Do you have a way to reproduce this?
On Oct 5, 2011 5:50 AM, "Nick Moffitt" <email address hidden> wrote:
> This does not appear to have fixed the problem. I am current with
> oneric and am in a situation right now where transient windows appear
> behind the app windows that own them. I'm lucky my terminals are
> translucent, or I wouldn't be able to find the "Open Link" entry on the
> context menu. This goes beyond the context menus from the launcher!
>
> --
> You received this bug notification because you are a member of Compiz
> Maintainers, which is the registrant for Compiz Core.
> https://bugs.launchpad.net/bugs/845719
>
> Title:
> compiz and X can disagree on the stacking order
>
> Status in Compiz Core:
> Fix Released
> Status in Unity:
> Fix Released
> Status in “unity” package in Ubuntu:
> Fix Released
>
> Bug description:
> This is a meta-bug to track all of the stack sync issues
>
> * It is possible for a window to issue a ConfigureRequest in between
ConfigureRequests internally and when we update the stack causing the
ConfigureRequest in between the temporarily updated stack to be processed
and given an invalid position
> * It is possible for synethetic ConfigureNotify events sent to core in
order to update frame windows can cause the stacking order to become invalid
> * It is possible for created windows to invalidate the stack
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/compiz-core/+bug/845719/+subscriptions

Nick Moffitt (nick-moffitt) wrote :

It's a cumulative thing that seems to take a day of regular use to arise, but I have a horrible intuition that it may be related to sloppy mouse focus (actually "mouse" mouse focus per gnome-tweak-tool) and switching desktops with keybindings. The behavior seems to start after I've flipped from one workspace to another with keybindings, perhaps moving onto a maximized window.

I've also noticed that selected desktop nautilus icons remain grey unless I move to a workspace that has no other windows on it.

I'll try logging out and reproducing soon.

Sam Spilsbury (smspillaz) wrote :

OK, I'll poke around with focus-follows-mouse for a bit and see what I
can come up with.

There's also a pending update which may fix other issues.

On Wed, Oct 5, 2011 at 3:27 PM, Nick Moffitt <email address hidden> wrote:
> It's a cumulative thing that seems to take a day of regular use to
> arise, but I have a horrible intuition that it may be related to sloppy
> mouse focus (actually "mouse" mouse focus per gnome-tweak-tool) and
> switching desktops with keybindings.  The behavior seems to start after
> I've flipped from one workspace to another with keybindings, perhaps
> moving onto a maximized window.
>
> I've also noticed that selected desktop nautilus icons remain grey
> unless I move to a workspace that has no other windows on it.
>
> I'll try logging out and reproducing soon.
>
> ** Attachment added: "stacking.png"
>   https://bugs.launchpad.net/compiz-core/+bug/845719/+attachment/2511590/+files/stacking.png
>
> --
> You received this bug notification because you are a member of Compiz
> Maintainers, which is the registrant for Compiz Core.
> https://bugs.launchpad.net/bugs/845719
>
> Title:
>  compiz and X can disagree on the stacking order
>
> Status in Compiz Core:
>  Fix Released
> Status in Unity:
>  Fix Released
> Status in “unity” package in Ubuntu:
>  Fix Released
>
> Bug description:
>  This is a meta-bug to track all of the stack sync issues
>
>   * It is possible for a window to issue a ConfigureRequest in between ConfigureRequests internally and when we update the stack causing the ConfigureRequest in between the temporarily updated stack to be processed and given an invalid position
>   * It is possible for synethetic ConfigureNotify events sent to core in order to update frame windows can cause the stacking order to become invalid
>   * It is possible for created windows to invalidate the stack
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/compiz-core/+bug/845719/+subscriptions
>

--
Sam Spilsbury

Sam Spilsbury (smspillaz) wrote :

(Also, when you start your session, can you run compiz by doing compiz
--replace --debug ccp ?)

On Wed, Oct 5, 2011 at 3:57 PM, Sam Spilsbury <email address hidden> wrote:
> OK, I'll poke around with focus-follows-mouse for a bit and see what I
> can come up with.
>
> There's also a pending update which may fix other issues.
>
> On Wed, Oct 5, 2011 at 3:27 PM, Nick Moffitt <email address hidden> wrote:
>> It's a cumulative thing that seems to take a day of regular use to
>> arise, but I have a horrible intuition that it may be related to sloppy
>> mouse focus (actually "mouse" mouse focus per gnome-tweak-tool) and
>> switching desktops with keybindings.  The behavior seems to start after
>> I've flipped from one workspace to another with keybindings, perhaps
>> moving onto a maximized window.
>>
>> I've also noticed that selected desktop nautilus icons remain grey
>> unless I move to a workspace that has no other windows on it.
>>
>> I'll try logging out and reproducing soon.
>>
>> ** Attachment added: "stacking.png"
>>   https://bugs.launchpad.net/compiz-core/+bug/845719/+attachment/2511590/+files/stacking.png
>>
>> --
>> You received this bug notification because you are a member of Compiz
>> Maintainers, which is the registrant for Compiz Core.
>> https://bugs.launchpad.net/bugs/845719
>>
>> Title:
>>  compiz and X can disagree on the stacking order
>>
>> Status in Compiz Core:
>>  Fix Released
>> Status in Unity:
>>  Fix Released
>> Status in “unity” package in Ubuntu:
>>  Fix Released
>>
>> Bug description:
>>  This is a meta-bug to track all of the stack sync issues
>>
>>   * It is possible for a window to issue a ConfigureRequest in between ConfigureRequests internally and when we update the stack causing the ConfigureRequest in between the temporarily updated stack to be processed and given an invalid position
>>   * It is possible for synethetic ConfigureNotify events sent to core in order to update frame windows can cause the stacking order to become invalid
>>   * It is possible for created windows to invalidate the stack
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/compiz-core/+bug/845719/+subscriptions
>>
>
>
>
> --
> Sam Spilsbury
>

--
Sam Spilsbury

Changed in compiz-core:
milestone: 0.9.5.96 → 0.9.7.0
Nick Moffitt (nick-moffitt) wrote :

Sam Spilsbury:
> (Also, when you start your session, can you run compiz by doing compiz
> --replace --debug ccp ?)

As I ran that (and watched all my windows cram up into workspace 1) I
realized that the symptoms I reported here no longer affect me. I
haven't had the gnome-terminal context menu appear behind the terminal
in months, though early in the release it was guaranteed to happen in a
matter of days if not hours.

--
Nick Moffitt

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments