Unity+OpenGL+Compiz+Composite= GL flicker !

Bug #781476 reported by funicorn on 2011-05-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz Core
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

In Ubuntu Natty, Unity needs Compiz and OpenGL, and OpenGL needs composite on, which leads to serious GL flicker when using mplayer watching videos in fullscreen mode through GL output. Switching to xv output the mplayer works just fine, no flickers.

I'm not sure this bug is due to unity, or compiz, or the GL driver. But I am quite sure in the previous version of these projects, with no composite on of compiz, the GL output works fine for mplayer. And I don't think developers have considered the possible consequence of forcing composite on in Compiz.

Please don't tell me the workaround such as giving up trying gl output and turning to xv output. GL output of mplayer is far better than xv output with more speedy video rendering and prettier osd & subtitles.

Omer Akram (om26er) wrote :

more of a compiz/driver bug so moving to compiz for now, might be helpful if you disable 'sync to vblank' and check if that is of any help

affects: unity (Ubuntu) → compiz (Ubuntu)
affects: unity → compiz

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. Compiz, in particular, is in heavy development and this bug may have been fixed in the development version of Ubuntu (12.04) if not on your current version. If you are able, it would be of great help if you could confirm if the bug still exists by testing a livecd (available at ubuntu.com). When you test it and it is still an issue, kindly upload the updated logs by running apport-collect <bug #> and any other logs that are relevant for this particular issue. If you are unable to test the development version, please let us know if you are able to reproduce this issue on Ubuntu 11.10.

Thank you for your help and patience.

affects: compiz → compiz-core
Changed in compiz-core:
status: New → Incomplete
Changed in compiz (Ubuntu):
status: New → Incomplete
Daniel van Vugt (vanvugt) wrote :

This bug is most likely a duplicate of one of:
   bug 880707
   bug 755841
   bug 798868
all of which are fixed in Ubuntu 12.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers