Collective zc.buildout recipes

zope2zeoserver failing with "Unable to import ZEO"

Reported by Rocky Burt on 2008-01-03
6
Affects Status Importance Assigned to Milestone
collective.buildout
Undecided
LeoRochael

Bug Description

With plone.recipe.zope2zeoserver 0.9 (not present with 0.8) there is a problem whereby the constructor of the recipe checks for the existence of the zope2-location directory which doesn't yet exist.

The constructor of the recipe gets loaded before the other recipes are run which means the zope2 recipe wouldn't have yet created the zope2 parts directory. So when the installation of the zope2zeoserver recipe gets run it overwrites the sys.path with directories that do not contain the zope2 parts directory so ZEO libs cannot be found. The solution here should be to move the self.ws_locations var generation out of the constructor into the install method. At this point the zope2 parts directory should exist and the checking of said directory will pass.

LeoRochael (leorochael) wrote :

I'll fix this one in a couple of days from now, if it isn't already

Changed in collective.buildout:
assignee: nobody → leorochael
status: New → Confirmed

Fix commited to the trunk.

Hanno, notice I've dialed back the recipe version from 1.0 to 0.10, as I think this deserves a Brown-paper-bag release ASAP, while 1.0 should be a simple renaming of the last 0.x release that is considered stable IMHO. If you disagree, feel free to set the version to 1.0 again.

Rocky, please test the trunk and confirm if it fixes this issue for you. It seems to be solved in my tests.

Hanno, would you be so kind as to make another release as soon as Rocky confirms? Thanks in advance.

LeoRochael (leorochael) on 2008-01-08
Changed in collective.buildout:
status: Confirmed → Fix Committed
Hanno Schlichting (hannosch) wrote :

I released a new version, still waiting on confirmation from Rocky though.

The version number is fine as 0.10. Ideally I would like to name the release 1.0 which has Windows support as well ;)

Changed in collective.buildout:
status: Fix Committed → Fix Released
Rocky Burt (rocky-burt) wrote :

I just tested version 0.10 and works like a champ. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers