Collective zc.buildout recipes

plone.recipe.zope2zeoserver generates conf disregarding blob-storage

Reported by ken manheimer on 2007-12-28
8
Affects Status Importance Assigned to Milestone
collective.buildout
Undecided
Unassigned

Bug Description

when generating a zeo server, the plone.recipe.zope2zeoserver recipe generates a zeo.conf file with a storage specification that completely lacks provision for blobs, whether or not a blob-storage setting is specified. the generated storage specification looks like:

  <filestorage 1>
    path /home/klm/Servers/PloneoutBlobs/var/filestorage/Data.fs
  </filestorage>

but, supposing a .cfg blob-storage setting = /home/klm/Servers/PloneoutBlobs/var/blobstorage, that should look like:

 <blobstorage 1>
   blob-dir /home/klm/Servers/PloneoutBlobs/var/blobstorage
   <filestorage 1>
     path /home/klm/Servers/PloneoutBlobs/var/filestorage/Data.fs
   </filestorage>
 </blobstorage>

(the exact syntax was not easy to track down. i found it in a unit test for Zope 2.11 a1, lib/python/ZEO/tests/testZEO.py .)

i use this form in running plone sites with the right version of zodb installed - thanks to andi ziedler, https://dev.plone.org/plone/ticket/6805 - to confirm that it works, handling blobs correctly. see http://myriadicity.net/Sundry/PloneBlobs for more details.

I've created a branch with my work for this issue:

https://svn.plone.org/svn/collective/buildout/plone.recipe.zope2zeoserver/branches/rochael-blobsupport

"./bin/zeoserver start" works, or at least starts up, with a proper blob configuration.

LeoRochael (leorochael) wrote :

everything seems to work on now with my latest changes.

Everyone, please test with this branch and report.

ken manheimer (ken-manheimer) wrote :

i can confirm that your version of plone.recipe.zope2zeoserver resolves the problems i was seeing! the server's zeo.conf has the correct blobstorage storage declaration. thanks!

Hanno Schlichting (hannosch) wrote :

In http://wiki.zope.org/ZODB/BlobsZeroCopy the blob-cache-writable zeo.conf option is mentioned which defaults to False and needs to be set to True in order to allow direct access from ZEO clients to the blob files.

If this is still the case in the final implementation this setting should be added and documented. Anyone willing to do this?

Hanno

P.S. I merged the rochael-blobsupport branch to trunk, bugfixes can go there directly. Thx for the work!

On Dec 29, 2007 10:59 PM, Hanno Schlichting <email address hidden> wrote:
> In http://wiki.zope.org/ZODB/BlobsZeroCopy the blob-cache-writable
> zeo.conf option is mentioned which defaults to False and needs to be set
> to True in order to allow direct access from ZEO clients to the blob
> files.

BTW, in the actual configuration schema, this option has been renamed
to shared-blob-dir, and it's not a zeo.conf option, but a zope.conf
one (it's the client that has to be instructed not to stream the blob
over to the server).

I'll need this option, by the way, but I might not be able to get
around to it till a week from now. Other generous souls are welcome to
it.

>
> If this is still the case in the final implementation this setting
> should be added and documented. Anyone willing to do this?
>
> Hanno
>
> P.S. I merged the rochael-blobsupport branch to trunk, bugfixes can go
> there directly. Thx for the work!
>
>
> --
> plone.recipe.zope2zeoserver generates conf disregarding blob-storage
> https://bugs.launchpad.net/bugs/179115
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Hanno Schlichting (hannosch) wrote :

All zope2zeoserver related issues have been resolved and are part of the new 0.9 release.

ZEO client related stuff goes into https://bugs.launchpad.net/collective.buildout/+bug/179113.

Changed in collective.buildout:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers