Collective zc.buildout recipes

plone_3 buildout: instance fg fails on windows when python path is too long

Reported by Sune Woeller on 2007-12-21
4
Affects Status Importance Assigned to Milestone
collective.buildout
Medium
Hanno Schlichting

Bug Description

On windows:

After adding additional eggs in my buildout.cfg, running zope with ./bin/instance fg fails.

Its caused by the longer python path.

The error happens in line 91 in plone.recipe.zope2instance-1.0-py2.4.egg\plone\recipe\zope2instance\ctl.py

Its funny, running parts/instance/bi/runzope.bat works fine.

The recipe uses runzope (no .bat):

{{{
(Pdb) program
'"c:\\zopedev\\absalon_buildout\\parts\\instance\\bin\\runzope"'
}}}

But trying

{{{
(Pdb) os.system("c:\\zopedev\\absalon_buildout\\parts\\instance\\bin\\runzope.bat")
Linjen med input er for lang.
}}}

gives the same problem.

The line "Linjen med input er for lang." is a silly danish windows error message meaning "the input line is too long" or something...

{{{
$ ./bin/instance.exe fg
"c:\zopedev\my_buildout\parts\instance\bin\runzope"
Linjen med input er for lang.

c:\zopedev\my_buildout>@set PYTHONPATH=c:\zopedev\my_buildout\eggs\elementtree-1.2.6_20050316-py2.4-win32.egg;c:\zopedev\my_buildout\src\heritage.policy;c:
\zopedev\my_buildout\src\heritage.orm;c:\zopedev\my_buildout\src\heritage.base;c:\zopedev\my_buildout\src\heritage.dataimport;c:\zopedev\my_buildout\s
rc\z3c.form\src;c:\zopedev\my_buildout\eggs\libxml2dom-0.4.5-py2.4.egg;c:\zopedev\my_buildout\eggs\plone.app.blob-1.0a2-py2.4.egg;c:\zopedev\my_buildout\eg
gs\archetypes.kss-1.2.4.1-py2.4.egg;c:\zopedev\my_buildout\eggs\kss.core-1.2.4-py2.4.egg;c:\zopedev\my_buildout\eggs\plone.app.content-1.0.1-py2.4.egg;c:\zopede
v\my_buildout\eggs\plone.app.contentmenu-1.0.3-py2.4.egg;c:\zopedev\my_buildout\eggs\plone.app.contentrules-1.0.2-py2.4.egg;c:\zopedev\my_buildout\eggs\plo
ne.app.controlpanel-1.0.3-py2.4.egg;c:\zopedev\my_buildout\eggs\plone.app.customerize-1.0.1-py2.4.egg;c:\zopedev\my_buildout\eggs\plone.app.form-1.0.4-py2.4.egg
;c:\zopedev\my_buildout\eggs\plone.app.i18n-1.0-py2.4.egg;c:\zopedev\my_buildout\eggs\plone.app.iterate-1.0-py2.4.egg;c:\zopedev\my_buildout\eggs\plone.app
.kss-1.2.4-py2.4.egg;c:\zopedev\my_buildout\eggs\plone.app.layout-1.0.4-py2.4.egg;c:\zopedev\my_buildout\eggs\plone.app.linkintegrity-1.0.3-py2.4.egg;c:\zopedev
\my_buildout\eggs\plone.app.openid-1.0.1-py2.4.egg;c:\zopedev\my_buildout\eggs\plone.app.portlets-1.0.3-py2.4.egg;c:\zopedev\my_buildout\eggs\plone.app.red
irector-1.0.2-py2.4.egg;c:\zopedev\my_buildout\eggs\plone.app.viewletmanager-1.0-py2.4.egg;c:\zopedev\my_buildout\eggs\plone.app.vocabularies-1.0.1-py2.4.egg;c:
\zopedev\my_buildout\eggs\plone.app.workflow-1.0.1.1-py2.4.egg;c:\zopedev\my_buildout\eggs\plone.contentrules-1.0.1.1-py2.4.egg;c:\zopedev\my_buildout\eggs
\plone.fieldsets-1.0-py2.4.egg;c:\zopedev\my_buildout\eggs\plone.i18n-1.0.2-py2.4.egg;c:\zopedev\my_buildout\eggs\plone.intelligenttext-1.0.1-py2.4.egg;c:\zoped
ev\my_buildout\eggs\plone.locking-1.0-py2.4.egg;c:\zopedev\my_buildout\eggs\plone.memoize-1.0.3-py2.4.egg;c:\zopedev\my_buildout\eggs\plone.openid-1.0.1-py
2.4.egg;c:\zopedev\my_buildout\eggs\plone.portlets-1.0.3-py2.4.egg;c:\zopedev\my_buildout\eggs\plone.session-1.1-py2.4.egg;c:\zopedev\my_buildout\eggs\plon
e.theme-1.0-py2.4.egg;c:\zopedev\my_buildout\eggs\wicked-1.1.6-py2.4.egg;c:\zopedev\my_buildout\eggs\five.customerize-0.2-py2.4.egg;c:\zopedev\my_buildout\
eggs\five.localsitemanager-0.2-py2.4.egg;c:\zopedev\my_buildout\eggs\setuptools-0.6c7-py2.4.egg;c:\zopedev\my_buildout\eggs\python_openid-2.0.1-py2.4.egg;c:\zop
edev\my_buildout\eggs\archetypes.schemaextender-1.0b1-py2.4.egg;c:\zopedev\my_buildout\eggs\zodbcode-3.4.0-py2.4.egg;c:\zopedev\my_buildout\eggs\zope.proxy
-3.4.0-py2.4-win32.egg;c:\zopedev\my_buildout\eggs\zdaemon-1.4a2-py2.4.egg;c:\zopedev\my_buildout\eggs\zconfig-2.4a6-py2.4.egg;c:\zopedev\my_buildout\eggs\
zope.testing-3.0-py2.4.egg;c:\zopedev\my_buildout\eggs\zope.interface-3.3.0.1-py2.4-win32.egg;c:\zopedev\my_buildout\eggs\zodb3-3.8.0c1-py2.4-win32.egg;c:\zoped
ev\my_buildout\eggs\collective.lead-1.0rc2-py2.4.egg;c:\zopedev\my_buildout\eggs\sqlalchemy-0.3.11-py2.4.egg;c:\zopedev\my_buildout\parts\zope2\lib\python;

}}}

Sune Woeller (sune-woeller) wrote :

Testet with 1.1 versiob of recipes, still having the problem.

Hanno Schlichting (hannosch) wrote :

The problem is nasty. I tricked around it on my Windows machine by using short folder names like "c:\z\1", but that's obviously not a very satisfying workaround. I'll see if I find a way around this problem.

Changed in collective.buildout:
status: New → Confirmed
Hanno Schlichting (hannosch) wrote :

Sidnei and I talked about this and we might have found a way around this. Sidnei looks into it :)

Hanno Schlichting (hannosch) wrote :

Assign to Sidnei, he has a solution for this bug :)

Changed in collective.buildout:
assignee: nobody → sidnei
Hanno Schlichting (hannosch) wrote :

This is really fixed now and will be released today.

Changed in collective.buildout:
status: Confirmed → Fix Released
Sidnei da Silva (sidnei) wrote :

Changed runzope.bat to run servicewrapper.py to and avoid setting a long PYTHONPATH because it will certainly exceed the maximum environment size.

Assigning to Hanno for release.

Changed in collective.buildout:
assignee: sidnei → schlichting
importance: Undecided → Medium
status: Fix Released → Fix Committed
Hanno Schlichting (hannosch) wrote :

Released in V2.1

Changed in collective.buildout:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers