trying to get the info from an oval in the whiteboard throws exception

Bug #720258 reported by buzzdee on 2011-02-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Coccinella
Low
buzzdee

Bug Description

I get this exception when I double click on an oval in the whiteboard where I actually excpected to get the information about the oval instead:

invalid character "]"
in expression "...ength $args}] % 2 == 1]"
invalid character "]"
in expression "...ength $args}] % 2 == 1]"
    (parsing expression "[expr {[llength $args}...")
    invoked from within
"if {[expr {[llength $args}] % 2 == 1]} {
 return -code "args must have an even number of elements"
    }"
    (procedure "ttk::optionmenuex" line 7)
    invoked from within
"ttk::optionmenuex $wmb $token\($op) none None dotted Dotted dash-dotted Dash-dotted dashed Dashed"
    ("eval" body line 1)
    invoked from within
"eval {
      ttk::optionmenuex $wmb $token\($op)
  } $menuOptsEx($opname)"
    (procedure "Build" line 309)
    invoked from within
"Build $wcan $id -usewingeom 0 -jid <email address hidden>/Coccinella@defiant -thread 29d3ef0c27e73431d0d3cf787a0822954a083c01 -state normal -ti..."
    ("eval" body line 1)
    invoked from within
"eval {Build $wcan $id} [array get opts]"
    (procedure "::ItemInspector::ItemInspector" line 19)
    invoked from within
"::ItemInspector::ItemInspector .wb1.fmain.fc.can current"
    (command bound to event)

buzzdee (sebastia) wrote :

and fixed with svn revision 2864. Bug was probably introduced when doing the expr raid, adding the {}. the closing part was in the wrong place...

Changed in coccinella:
milestone: none → 0.96.22
assignee: nobody → buzzdee (sebastia)
importance: Undecided → Low
status: New → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers