Public servers dropdown is broken

Bug #555902 reported by sander on 2010-04-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Coccinella
Undecided
buzzdee

Bug Description

In the past, it was possible to select a public server in several dialogs (registering a new account, installation wizard, rooms,...) by clicking on the dropdown arrow. The menu was populated with servers from the XML file on http://xmpp.org/services/

Maybe it became broken because the URL of the XML file had been changed?

buzzdee (sebastia) wrote :

when I grep the whole sources for services-full.xml then I don't find anything?

Changed in coccinella:
milestone: none → 0.96.20
buzzdee (sebastia) wrote :

svn revision #2812 fixes the problem,

from the changelog:
fix for bug #555902, update the URL used to retrieve the
list of public servers in jabber/Jabber.tcl, and use package
xml instead of qdxml to parse the xml file.

this must have been broken within qdxml since a longer time... svn log tells me the last change to it was done by matben in summer 2007

Changed in coccinella:
assignee: nobody → buzzdee (sebastia)
status: New → Fix Committed
sander (s-devrieze) wrote :

I just tested with older versions of Coccinella that worked for sure in the past and I can confirm they are also broken. Maybe it got broken because the content of the XML file changed? It would be better in the end to improve qdxml, because Coccinella likely will be faster with qdxml: http://thecoccinella.org/node/41

sander (s-devrieze) on 2010-09-30
Changed in coccinella:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers